Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функции ИНДЕКС и ПОИСКПОЗ в работе с нечисловыми значениями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функции ИНДЕКС и ПОИСКПОЗ в работе с нечисловыми значениями (Формулы/Formulas)
Функции ИНДЕКС и ПОИСКПОЗ в работе с нечисловыми значениями
GP75 Дата: Понедельник, 02.01.2023, 02:53 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 113
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте товарищи. С прошедшим вас. На праздниках решил сделать файлик excel с небольшой автоматизацией с помощью функций ПОИСКПОЗ и ИНДЕКС, Не могу заставить еxcel вычислить нудное значение. Что не так с формулой или с файлом?
К сообщению приложен файл: 2573858.xls(481.5 Kb)
 
Ответить
СообщениеЗдравствуйте товарищи. С прошедшим вас. На праздниках решил сделать файлик excel с небольшой автоматизацией с помощью функций ПОИСКПОЗ и ИНДЕКС, Не могу заставить еxcel вычислить нудное значение. Что не так с формулой или с файлом?

Автор - GP75
Дата добавления - 02.01.2023 в 02:53
OlehandR Дата: Понедельник, 02.01.2023, 04:40 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 2 ±
Замечаний: 0% ±

Здравствуйте
Формула у вас верная, просто вы ищите число 2,71, а там при протягивании формулы стоит число 2,70999999999999. Сделайте в столбце CD округление и все будет работать
Код
=ОКРУГЛ(CD2+0,01;2)

Ну и вашу можно чуть изменить
Код
=ИНДЕКС('8'!CE:CH;ПОИСКПОЗ(AF3;'8'!CD:CD;0);ПОИСКПОЗ(AK1;'8'!CE1:CH1;0))
К сообщению приложен файл: 3492990.xls(481.5 Kb)


Сообщение отредактировал OlehandR - Понедельник, 02.01.2023, 04:40
 
Ответить
СообщениеЗдравствуйте
Формула у вас верная, просто вы ищите число 2,71, а там при протягивании формулы стоит число 2,70999999999999. Сделайте в столбце CD округление и все будет работать
Код
=ОКРУГЛ(CD2+0,01;2)

Ну и вашу можно чуть изменить
Код
=ИНДЕКС('8'!CE:CH;ПОИСКПОЗ(AF3;'8'!CD:CD;0);ПОИСКПОЗ(AK1;'8'!CE1:CH1;0))

Автор - OlehandR
Дата добавления - 02.01.2023 в 04:40
GP75 Дата: Понедельник, 02.01.2023, 11:53 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 113
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо добрый человек!
Всё просто оказалось.
 
Ответить
СообщениеСпасибо добрый человек!
Всё просто оказалось.

Автор - GP75
Дата добавления - 02.01.2023 в 11:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функции ИНДЕКС и ПОИСКПОЗ в работе с нечисловыми значениями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!