Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Написание логической функции - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Написание логической функции (Формулы/Formulas)
Написание логической функции
89261338705ra Дата: Среда, 11.01.2023, 15:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Нужна Ваша помощь в написании логической функции. Задача в следующем: необходимо сформировать список товаров со всеми свойствами данного товара, таким образом, чтобы наименование и встречалось один раз, а все свойства были перечислены в одной ячейке.
Я пробовал использовать функции ЕСЛИ и СЦЕПИТЬ, но окончательно запутался и теперь прошу помощи здесь!
К сообщению приложен файл: 0539910.xlsx (18.3 Kb)
 
Ответить
СообщениеЗдравствуйте! Нужна Ваша помощь в написании логической функции. Задача в следующем: необходимо сформировать список товаров со всеми свойствами данного товара, таким образом, чтобы наименование и встречалось один раз, а все свойства были перечислены в одной ячейке.
Я пробовал использовать функции ЕСЛИ и СЦЕПИТЬ, но окончательно запутался и теперь прошу помощи здесь!

Автор - 89261338705ra
Дата добавления - 11.01.2023 в 15:17
Gustav Дата: Среда, 11.01.2023, 16:14 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2305
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Формулы для ячеек C2, D2 и E2 соответственно:
Код
=ЕСЛИ(A2<>A1;1;C1+1)

Код
=ЕСЛИ(C2=1;B2;D1&", "&B2)

Код
=ЕСЛИ(СЧЁТЕСЛИ($A$2:$A$296;A2)=C2;D2;"")

И все три протягиваем вниз по своим столбцам. По окончании в непустых ячейках колонки E - искомые сцепленные строки. Далее включаем автофильтр, фильтруем непустые значения в колонке E, копируем нужные столбцы (A и E), выбираем свободное от данных место (можно на другом листе) и вставляем "Специальной вставкой" как значения.


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеФормулы для ячеек C2, D2 и E2 соответственно:
Код
=ЕСЛИ(A2<>A1;1;C1+1)

Код
=ЕСЛИ(C2=1;B2;D1&", "&B2)

Код
=ЕСЛИ(СЧЁТЕСЛИ($A$2:$A$296;A2)=C2;D2;"")

И все три протягиваем вниз по своим столбцам. По окончании в непустых ячейках колонки E - искомые сцепленные строки. Далее включаем автофильтр, фильтруем непустые значения в колонке E, копируем нужные столбцы (A и E), выбираем свободное от данных место (можно на другом листе) и вставляем "Специальной вставкой" как значения.

Автор - Gustav
Дата добавления - 11.01.2023 в 16:14
Nic70y Дата: Среда, 11.01.2023, 16:35 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 8026
Репутация: 1953 ±
Замечаний: 0% ±

Excel 2010
см. файл, формулы на двух листах
К сообщению приложен файл: 3217347.xlsx (29.8 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениесм. файл, формулы на двух листах

Автор - Nic70y
Дата добавления - 11.01.2023 в 16:35
89261338705ra Дата: Среда, 11.01.2023, 16:36 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Gustav, все получилось. Спасибо большое за помощь!
 
Ответить
СообщениеGustav, все получилось. Спасибо большое за помощь!

Автор - 89261338705ra
Дата добавления - 11.01.2023 в 16:36
89261338705ra Дата: Среда, 11.01.2023, 17:44 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Спасибо!!!
 
Ответить
СообщениеNic70y, Спасибо!!!

Автор - 89261338705ra
Дата добавления - 11.01.2023 в 17:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Написание логической функции (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!