Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод нескольких строк из массива данных по одному критерию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод нескольких строк из массива данных по одному критерию (Иное/Other)
Вывод нескольких строк из массива данных по одному критерию
Tattiana-R Дата: Пятница, 13.01.2023, 09:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Есть таблица (лист Данные), в которой отражается обучение сотрудников, в графах заполняется информация - ФИО, должность, дата проведения, тема и другие) . Необходимо в заполняемую форму (лист ИКОС) перенести информацию по фамилии (которую необходимо ввести в лист ИКОС - строка 5, далее подтягивается информация, на строке 9 (лист ИКОС) появляется обучение, но появляется только одна строка, а мне надо чтобы появлялись все строки которые есть на листе Данные.
Я уже и ВПР и индексом пробовала, ни как.
Во вложении документ в котором проблема и документ в котором показано как необходимо, чтобы выглядело, в информацию туда внесла для примера.
Помогите пжлста.
Может быть эта тема уже поднималась, но я не смогла найти похожее.
К сообщению приложен файл: __1.xlsx(20.5 Kb)
 
Ответить
СообщениеЕсть таблица (лист Данные), в которой отражается обучение сотрудников, в графах заполняется информация - ФИО, должность, дата проведения, тема и другие) . Необходимо в заполняемую форму (лист ИКОС) перенести информацию по фамилии (которую необходимо ввести в лист ИКОС - строка 5, далее подтягивается информация, на строке 9 (лист ИКОС) появляется обучение, но появляется только одна строка, а мне надо чтобы появлялись все строки которые есть на листе Данные.
Я уже и ВПР и индексом пробовала, ни как.
Во вложении документ в котором проблема и документ в котором показано как необходимо, чтобы выглядело, в информацию туда внесла для примера.
Помогите пжлста.
Может быть эта тема уже поднималась, но я не смогла найти похожее.

Автор - Tattiana-R
Дата добавления - 13.01.2023 в 09:23
Nic70y Дата: Пятница, 13.01.2023, 10:08 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8005
Репутация: 1949 ±
Замечаний: 0% ±

Excel 2010
1) вариант формулой массива (удалил объединенные ячейки)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Данные!E:E;НАИМЕНЬШИЙ(ЕСЛИ($B$5=Данные!$A$11:$A$500;СТРОКА(Данные!$A$11:$A$500));СТРОКА(A1)));"")
2) вариант доп.столбец на листе Данные
К сообщению приложен файл: 11.xlsx(20.2 Kb) · 12.xlsx(23.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение1) вариант формулой массива (удалил объединенные ячейки)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Данные!E:E;НАИМЕНЬШИЙ(ЕСЛИ($B$5=Данные!$A$11:$A$500;СТРОКА(Данные!$A$11:$A$500));СТРОКА(A1)));"")
2) вариант доп.столбец на листе Данные

Автор - Nic70y
Дата добавления - 13.01.2023 в 10:08
Tattiana-R Дата: Пятница, 13.01.2023, 10:15 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Спасибо Вам большое!!!!
 
Ответить
СообщениеNic70y, Спасибо Вам большое!!!!

Автор - Tattiana-R
Дата добавления - 13.01.2023 в 10:15
bigor Дата: Пятница, 13.01.2023, 10:21 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 722
Репутация: 151 ±
Замечаний: 0% ±

нет
немассивная:
Код
=IFERROR(INDEX(Данные.$E$11:$H$500;AGGREGATE(15;6;(ROW(Данные.$A$11:$A$500)-11)/(Данные.$A$11:$A$500=$B$5);ROW(A1));COLUMN(A1));"")

но принципа тот же
 
Ответить
Сообщениенемассивная:
Код
=IFERROR(INDEX(Данные.$E$11:$H$500;AGGREGATE(15;6;(ROW(Данные.$A$11:$A$500)-11)/(Данные.$A$11:$A$500=$B$5);ROW(A1));COLUMN(A1));"")

но принципа тот же

Автор - bigor
Дата добавления - 13.01.2023 в 10:21
Tattiana-R Дата: Пятница, 13.01.2023, 16:29 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

bigor, Спасибо большое!
 
Ответить
Сообщениеbigor, Спасибо большое!

Автор - Tattiana-R
Дата добавления - 13.01.2023 в 16:29
прохожий2019 Дата: Суббота, 14.01.2023, 10:53 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 980
Репутация: 271 ±
Замечаний: 0% ±

365 Beta Channel
365, 2021:
Код
=ФИЛЬТР(Данные!E11:H500;Данные!A11:A500=B5)
К сообщению приложен файл: _1.xlsx(21.5 Kb)
 
Ответить
Сообщение365, 2021:
Код
=ФИЛЬТР(Данные!E11:H500;Данные!A11:A500=B5)

Автор - прохожий2019
Дата добавления - 14.01.2023 в 10:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод нескольких строк из массива данных по одному критерию (Иное/Other)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!