Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Окрасить ячейку по данным из столбца через столбцы. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Окрасить ячейку по данным из столбца через столбцы. (Формулы/Formulas)
Окрасить ячейку по данным из столбца через столбцы.
Tecnik27702 Дата: Среда, 18.01.2023, 22:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Добрый вечер!
Извините, думаю задача сложная, потому пишу подробно.
Делаю таблицу для почтальона, для контроля выдачи подписок на газеты и журналы. Часть сделал. Но не получается составить формулу для условного форматирования ячеек на основе данных не последовательных столбцов. То, что смог сделать, не на весь необходимый диапазон, и она уже космических размеров.
Таблицей будут пользоваться в смартфоне, поэтому на сколько возможно решить задачу формулами.

Структура таблицы

Сделано

Не доделано
Вариант 1

Вариант 2 (если не получиться вариант 1)
К сообщению приложен файл: 01__.xlsx (15.3 Kb)


Сообщение отредактировал Tecnik27702 - Среда, 18.01.2023, 22:05
 
Ответить
СообщениеДобрый вечер!
Извините, думаю задача сложная, потому пишу подробно.
Делаю таблицу для почтальона, для контроля выдачи подписок на газеты и журналы. Часть сделал. Но не получается составить формулу для условного форматирования ячеек на основе данных не последовательных столбцов. То, что смог сделать, не на весь необходимый диапазон, и она уже космических размеров.
Таблицей будут пользоваться в смартфоне, поэтому на сколько возможно решить задачу формулами.

Структура таблицы

Сделано

Не доделано
Вариант 1

Вариант 2 (если не получиться вариант 1)

Автор - Tecnik27702
Дата добавления - 18.01.2023 в 22:03
Pelena Дата: Среда, 18.01.2023, 22:53 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18721
Репутация: 4265 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Формула УФ для порядковых номеров для Вариант 1
Код
=СУММПРОИЗВ((ТРАНСП($D$4:$H$4)=ЛЕВСИМВ($J$4:$BE$4;ДЛСТР(ТРАНСП($D$4:$H$4))))*(ТРАНСП($D5:$H5)>0)*($J$2:$BE$2="Да")*($J5:$BE5=""))
К сообщению приложен файл: 01_.xlsx (16.9 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула УФ для порядковых номеров для Вариант 1
Код
=СУММПРОИЗВ((ТРАНСП($D$4:$H$4)=ЛЕВСИМВ($J$4:$BE$4;ДЛСТР(ТРАНСП($D$4:$H$4))))*(ТРАНСП($D5:$H5)>0)*($J$2:$BE$2="Да")*($J5:$BE5=""))

Автор - Pelena
Дата добавления - 18.01.2023 в 22:53
Tecnik27702 Дата: Пятница, 20.01.2023, 00:45 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Вот это крутое решение! Работает отлично.
Честно говоря, я бы использовал одновременно и Вариант 1, и Вариант 2 :)
Формула потрясающая. Восторга нет предела.
 
Ответить
СообщениеВот это крутое решение! Работает отлично.
Честно говоря, я бы использовал одновременно и Вариант 1, и Вариант 2 :)
Формула потрясающая. Восторга нет предела.

Автор - Tecnik27702
Дата добавления - 20.01.2023 в 00:45
Pelena Дата: Пятница, 20.01.2023, 09:01 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18721
Репутация: 4265 ±
Замечаний: ±

Excel 2016 & Mac Excel
я бы использовал одновременно и Вариант 1, и Вариант 2

Вариант 2 проще. Формула УФ для диапазона D5:H11
Код
=СУММПРОИЗВ((D$4=ЛЕВСИМВ($J$4:$BE$4;ДЛСТР(D$4)))*(D5>0)*($J$2:$BE$2="Да")*($J5:$BE5=""))
К сообщению приложен файл: 1371978.xlsx (16.5 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
я бы использовал одновременно и Вариант 1, и Вариант 2

Вариант 2 проще. Формула УФ для диапазона D5:H11
Код
=СУММПРОИЗВ((D$4=ЛЕВСИМВ($J$4:$BE$4;ДЛСТР(D$4)))*(D5>0)*($J$2:$BE$2="Да")*($J5:$BE5=""))

Автор - Pelena
Дата добавления - 20.01.2023 в 09:01
Tecnik27702 Дата: Пятница, 20.01.2023, 15:10 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Я думал, что формула будет проще предыдущей, за минусом чего-то. Но я даже не догадывался, что же надо убрать.
Сума сойти как удобно стало!
Всё классно работает! + это понятно, всё же Большущее спасибо!
Тема решена.
 
Ответить
СообщениеЯ думал, что формула будет проще предыдущей, за минусом чего-то. Но я даже не догадывался, что же надо убрать.
Сума сойти как удобно стало!
Всё классно работает! + это понятно, всё же Большущее спасибо!
Тема решена.

Автор - Tecnik27702
Дата добавления - 20.01.2023 в 15:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Окрасить ячейку по данным из столбца через столбцы. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!