Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула МАКС с 2мя условиями для отбора текстового значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула МАКС с 2мя условиями для отбора текстового значения (Формулы/Formulas)
Формула МАКС с 2мя условиями для отбора текстового значения
vladmikhail Дата: Понедельник, 27.02.2023, 20:49 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Всем привет!
Не смог найти ответ на волнующий вопрос, прошу помочь.
Следует отобрать текстовое значение если оно максимально или минимально по дате и соответствует буквенному значению судна.
В файле примера отметил поля где нужна формула (Только в выделенных ячейках нужно вставить значение (ТИП) если оно соответствует максимальной или минимальной дате + Букве группе)

Два дня потратил на изобретение требуемой формулы и бессчетно(
К сообщению приложен файл: primer_2.xlsx (12.5 Kb)


Сообщение отредактировал vladmikhail - Понедельник, 27.02.2023, 23:39
 
Ответить
СообщениеВсем привет!
Не смог найти ответ на волнующий вопрос, прошу помочь.
Следует отобрать текстовое значение если оно максимально или минимально по дате и соответствует буквенному значению судна.
В файле примера отметил поля где нужна формула (Только в выделенных ячейках нужно вставить значение (ТИП) если оно соответствует максимальной или минимальной дате + Букве группе)

Два дня потратил на изобретение требуемой формулы и бессчетно(

Автор - vladmikhail
Дата добавления - 27.02.2023 в 20:49
elovkov Дата: Вторник, 28.02.2023, 08:01 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
удалите, не правильно написал формулу


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Вторник, 28.02.2023, 08:02
 
Ответить
Сообщениеудалите, не правильно написал формулу

Автор - elovkov
Дата добавления - 28.02.2023 в 08:01
Nic70y Дата: Вторник, 28.02.2023, 08:05 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 8656
Репутация: 2214 ±
Замечаний: 0% ±

Excel 2010
вдруг правильно
Код
=ИНДЕКС(C:C;МИН(ЕСЛИ(МАКС(ЕСЛИ(D$1:N$1="Конец";ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7))=ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7;СТРОКА(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7))))
Код
=ИНДЕКС(C:C;МИН(ЕСЛИ(МИН(ЕСЛИ(D$1:N$1="Начало";ЕСЛИ(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7>0;ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);))))=ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7;СТРОКА(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7))))
Код
=ИНДЕКС(C:C;МИН(ЕСЛИ(МИН(ЕСЛИ(D$1:N$1="Начало";ЕСЛИ(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7>0;ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7)))=ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7;СТРОКА(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7))))


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Вторник, 28.02.2023, 11:09
 
Ответить
Сообщениевдруг правильно
Код
=ИНДЕКС(C:C;МИН(ЕСЛИ(МАКС(ЕСЛИ(D$1:N$1="Конец";ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7))=ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7;СТРОКА(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7))))
Код
=ИНДЕКС(C:C;МИН(ЕСЛИ(МИН(ЕСЛИ(D$1:N$1="Начало";ЕСЛИ(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7>0;ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);))))=ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7;СТРОКА(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7))))
Код
=ИНДЕКС(C:C;МИН(ЕСЛИ(МИН(ЕСЛИ(D$1:N$1="Начало";ЕСЛИ(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7>0;ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7)))=ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7;СТРОКА(ИНДЕКС(D:N;ПОИСКПОЗ(A8;A:A;);):N7))))

Автор - Nic70y
Дата добавления - 28.02.2023 в 08:05
vladmikhail Дата: Вторник, 28.02.2023, 10:43 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Огромное спасибо, правильно ли я понимаю что шапка должна равняться "Конец"/"Начало" т.к. по некоторым слишком большие значения и формула может неправильный тип выбрать?

И сейчас заметил что формула почему-то не корректно выводит значение на начало периода. Я в ячейке D15 скорректировал дату на самую начальную допустим 1.3.20г., при этом тип рейса не изменился в ячейке с формулами, как можно это подкорректировать?

На сколько я понял, формула отбирает первый в столбце ТИП, при это если вставить формулу из колонки с концом формула также не работает(


Сообщение отредактировал vladmikhail - Вторник, 28.02.2023, 10:47
 
Ответить
СообщениеNic70y, Огромное спасибо, правильно ли я понимаю что шапка должна равняться "Конец"/"Начало" т.к. по некоторым слишком большие значения и формула может неправильный тип выбрать?

И сейчас заметил что формула почему-то не корректно выводит значение на начало периода. Я в ячейке D15 скорректировал дату на самую начальную допустим 1.3.20г., при этом тип рейса не изменился в ячейке с формулами, как можно это подкорректировать?

На сколько я понял, формула отбирает первый в столбце ТИП, при это если вставить формулу из колонки с концом формула также не работает(

Автор - vladmikhail
Дата добавления - 28.02.2023 в 10:43
Nic70y Дата: Вторник, 28.02.2023, 11:08 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8656
Репутация: 2214 ±
Замечаний: 0% ±

Excel 2010
vladmikhail, да, действительно промахнулся при копипасте.
см. файл
К сообщению приложен файл: 0494061_1.xlsx (13.7 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеvladmikhail, да, действительно промахнулся при копипасте.
см. файл

Автор - Nic70y
Дата добавления - 28.02.2023 в 11:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула МАКС с 2мя условиями для отбора текстового значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!