Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма при условии с датой - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма при условии с датой (Формулы/Formulas)
Сумма при условии с датой
Kustov Дата: Пятница, 03.03.2023, 20:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Возник следующий вопрос.

Делаю документ из условно трёх связанных листов: два рабочих, один служебный. На втором листе идёт отдельный столбец год, отдельный - месяц. Нужно сделать условие, при котором будут суммироваться все значения за месяц. В документе подобное есть на первом листе, но этот вопрос я решил, создав на служебном листе список дат по шаблону
1.02.2023 28.02.2023
1.03.2023 31.03.2023
1.04.2023 30.04.2023
И в формуле, суммирующей значения за месяц сделал ссылки на эти ячейки. После этого их можно было протащить, распространив формулу на весь столбец. Во втором случае это не получится, та как один месяц охватывает 8 строк и тут протащить не получится, только редактировать каждую ячейку вручную

Подскажите, пожалуйста, что можно сделать? Я пытался через ДАТА и ссылки на ячейки, но план тоже не удался

Необходимо на листе Учёт отформатировать столбец Н, чтобы он собирал с листа Доход столбца В данные и вносил их в соответствующую категорию в зависимости от категории D и соответственно дате
К сообщению приложен файл: obrazec.xlsx (67.3 Kb)
 
Ответить
СообщениеЗдравствуйте! Возник следующий вопрос.

Делаю документ из условно трёх связанных листов: два рабочих, один служебный. На втором листе идёт отдельный столбец год, отдельный - месяц. Нужно сделать условие, при котором будут суммироваться все значения за месяц. В документе подобное есть на первом листе, но этот вопрос я решил, создав на служебном листе список дат по шаблону
1.02.2023 28.02.2023
1.03.2023 31.03.2023
1.04.2023 30.04.2023
И в формуле, суммирующей значения за месяц сделал ссылки на эти ячейки. После этого их можно было протащить, распространив формулу на весь столбец. Во втором случае это не получится, та как один месяц охватывает 8 строк и тут протащить не получится, только редактировать каждую ячейку вручную

Подскажите, пожалуйста, что можно сделать? Я пытался через ДАТА и ссылки на ячейки, но план тоже не удался

Необходимо на листе Учёт отформатировать столбец Н, чтобы он собирал с листа Доход столбца В данные и вносил их в соответствующую категорию в зависимости от категории D и соответственно дате

Автор - Kustov
Дата добавления - 03.03.2023 в 20:39
Nic70y Дата: Суббота, 04.03.2023, 08:49 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММЕСЛИМН(Доход!B:B;Доход!A:A;">="&ДАТА(ВПР(9E+307;C$2:C2;1);ПОИСК(ПСТР(ВПР("我";D$2:D2;1);2;2);"ёнвеварпрайюнюлвгенктояек")/2;1);Доход!A:A;"<="&КОНМЕСЯЦА(ДАТА(ВПР(9E+307;C$2:C2;1);ПОИСК(ПСТР(ВПР("我";D$2:D2;1);2;2);"ёнвеварпрайюнюлвгенктояек")/2;1);0);Доход!D:D;G2)
К сообщению приложен файл: 919.xlsx (68.8 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММЕСЛИМН(Доход!B:B;Доход!A:A;">="&ДАТА(ВПР(9E+307;C$2:C2;1);ПОИСК(ПСТР(ВПР("我";D$2:D2;1);2;2);"ёнвеварпрайюнюлвгенктояек")/2;1);Доход!A:A;"<="&КОНМЕСЯЦА(ДАТА(ВПР(9E+307;C$2:C2;1);ПОИСК(ПСТР(ВПР("我";D$2:D2;1);2;2);"ёнвеварпрайюнюлвгенктояек")/2;1);0);Доход!D:D;G2)

Автор - Nic70y
Дата добавления - 04.03.2023 в 08:49
Kustov Дата: Суббота, 04.03.2023, 16:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Большое спасибо!)
 
Ответить
СообщениеNic70y, Большое спасибо!)

Автор - Kustov
Дата добавления - 04.03.2023 в 16:38
jakim Дата: Суббота, 04.03.2023, 17:51 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Смотрите приложение


Сообщение отредактировал jakim - Суббота, 04.03.2023, 17:54
 
Ответить
Сообщение
Смотрите приложение

Автор - jakim
Дата добавления - 04.03.2023 в 17:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма при условии с датой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!