Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выводит значение первой строки вместо того, что он посчитал - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Выводит значение первой строки вместо того, что он посчитал
optartgarant Дата: Среда, 19.04.2023, 10:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

2016
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(ПОИСКПОЗ(K2;$B$1:$B$29;0);ПОИСКПОЗ(L2;$C$1:$C$29;0));ИНДЕКС($F:$F;МАКС(ЕСЛИ(B$1:B$100=K2;ЕСЛИ($C$1:$C$100=L2;СТРОКА($F$1:$F$100))));));"")

Суть вот в чем. Excel считает внутри себя, то есть в форме аргументов ячейки всё правильно, он находит нужное значение, но по итогу выводит значение первой строки
К сообщению приложен файл: 4318527.jpg (51.3 Kb) · 2485739.jpg (24.7 Kb)


Сообщение отредактировал optartgarant - Среда, 19.04.2023, 10:39
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(ПОИСКПОЗ(K2;$B$1:$B$29;0);ПОИСКПОЗ(L2;$C$1:$C$29;0));ИНДЕКС($F:$F;МАКС(ЕСЛИ(B$1:B$100=K2;ЕСЛИ($C$1:$C$100=L2;СТРОКА($F$1:$F$100))));));"")

Суть вот в чем. Excel считает внутри себя, то есть в форме аргументов ячейки всё правильно, он находит нужное значение, но по итогу выводит значение первой строки

Автор - optartgarant
Дата добавления - 19.04.2023 в 10:06
elovkov Дата: Среда, 19.04.2023, 12:42 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 383
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Конечно с исходником было бы удобнее, но что-то в поиске номера строки перемудрено, может так пойдет?
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(ПОИСКПОЗ(K2;$B$1:$B$29;0);ПОИСКПОЗ(L2;$C$1:$C$29;0));ИНДЕКС($F:$F;ПОИСКПОЗ(K2;$B$1:$B$29;0)));"")


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеКонечно с исходником было бы удобнее, но что-то в поиске номера строки перемудрено, может так пойдет?
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(ПОИСКПОЗ(K2;$B$1:$B$29;0);ПОИСКПОЗ(L2;$C$1:$C$29;0));ИНДЕКС($F:$F;ПОИСКПОЗ(K2;$B$1:$B$29;0)));"")

Автор - elovkov
Дата добавления - 19.04.2023 в 12:42
optartgarant Дата: Среда, 19.04.2023, 13:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

2016
elovkov, высылаю исходник, и к сожалению ваш ответ не подходит
К сообщению приложен файл: problema.xlsx (53.9 Kb)
 
Ответить
Сообщениеelovkov, высылаю исходник, и к сожалению ваш ответ не подходит

Автор - optartgarant
Дата добавления - 19.04.2023 в 13:05
Serge_007 Дата: Среда, 19.04.2023, 13:10 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
optartgarant, формулы массива вводятся нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 20230419_optartgarant.xls (76.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеoptartgarant, формулы массива вводятся нажатием Ctrl+Shift+Enter

Автор - Serge_007
Дата добавления - 19.04.2023 в 13:10
optartgarant Дата: Среда, 19.04.2023, 13:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

2016
Serge_007, Огромное спасибо, теперь всё выводит как подобает.
 
Ответить
СообщениеSerge_007, Огромное спасибо, теперь всё выводит как подобает.

Автор - optartgarant
Дата добавления - 19.04.2023 в 13:14
elovkov Дата: Среда, 19.04.2023, 13:23 | Сообщение № 6
Группа: Друзья
Ранг: Обитатель
Сообщений: 383
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
формулы массива

Наглядный пример для чего нужен исходник, сразу ответ
Мою если доработать немного, то с массивным вводом тоже вроде работает
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(ПОИСКПОЗ(F2;$B$1:$B$29;0);ПОИСКПОЗ(G2;$C$1:$C$29;0));ИНДЕКС(D:D;ПОИСКПОЗ(F2&G2;$B$1:$B$29&$C$1:$C$29;0)));"")


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
формулы массива

Наглядный пример для чего нужен исходник, сразу ответ
Мою если доработать немного, то с массивным вводом тоже вроде работает
Код
=ЕСЛИОШИБКА(ЕСЛИ(И(ПОИСКПОЗ(F2;$B$1:$B$29;0);ПОИСКПОЗ(G2;$C$1:$C$29;0));ИНДЕКС(D:D;ПОИСКПОЗ(F2&G2;$B$1:$B$29&$C$1:$C$29;0)));"")

Автор - elovkov
Дата добавления - 19.04.2023 в 13:23
Serge_007 Дата: Среда, 19.04.2023, 13:26 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Наглядный пример для чего нужен исходник
Так мы правила форума писали-то десять лет назад не "от фонаря", а на основе собственного опыта ;)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Наглядный пример для чего нужен исходник
Так мы правила форума писали-то десять лет назад не "от фонаря", а на основе собственного опыта ;)

Автор - Serge_007
Дата добавления - 19.04.2023 в 13:26
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!