Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Среднее значение - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Среднее значение
Gold_Barsik9945 Дата: Вторник, 23.05.2023, 06:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 40% ±

Как найти СРЗНАЧ() в Е3 из выделенных ячейках за месяц (Е5, Е6)
К сообщению приложен файл: podschjot_raskhoda_za_period.xls (54.5 Kb)
 
Ответить
СообщениеКак найти СРЗНАЧ() в Е3 из выделенных ячейках за месяц (Е5, Е6)

Автор - Gold_Barsik9945
Дата добавления - 23.05.2023 в 06:35
DrMini Дата: Вторник, 23.05.2023, 07:04 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Может так:
Код
=СРЗНАЧЕСЛИ(E4:E22;">0";E4:E22)
 
Ответить
СообщениеМожет так:
Код
=СРЗНАЧЕСЛИ(E4:E22;">0";E4:E22)

Автор - DrMini
Дата добавления - 23.05.2023 в 07:04
elovkov Дата: Вторник, 23.05.2023, 07:20 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 385
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Может так:

Можно просто
Код
=СРЗНАЧЕСЛИ(E4:E22;">0")


:shades:


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
Может так:

Можно просто
Код
=СРЗНАЧЕСЛИ(E4:E22;">0")


:shades:

Автор - elovkov
Дата добавления - 23.05.2023 в 07:20
DrMini Дата: Вторник, 23.05.2023, 07:30 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Можно просто

Согласен. Сначала опубликовал и потом увидел, что диапазон усреднения тот же и поленился подправить.
:)
 
Ответить
Сообщение
Можно просто

Согласен. Сначала опубликовал и потом увидел, что диапазон усреднения тот же и поленился подправить.
:)

Автор - DrMini
Дата добавления - 23.05.2023 в 07:30
Nic70y Дата: Вторник, 23.05.2023, 08:07 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8831
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ((ГОД($A$3)=ГОД($A$4:$A22))*(МЕСЯЦ($A$3)=МЕСЯЦ($A$4:$A22))*E4:E22)/СУММПРОИЗВ((ГОД($A$3)=ГОД($A$4:$A22))*(МЕСЯЦ($A$3)=МЕСЯЦ($A$4:$A22))*ЕЧИСЛО(E4:E22))


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((ГОД($A$3)=ГОД($A$4:$A22))*(МЕСЯЦ($A$3)=МЕСЯЦ($A$4:$A22))*E4:E22)/СУММПРОИЗВ((ГОД($A$3)=ГОД($A$4:$A22))*(МЕСЯЦ($A$3)=МЕСЯЦ($A$4:$A22))*ЕЧИСЛО(E4:E22))

Автор - Nic70y
Дата добавления - 23.05.2023 в 08:07
DrMini Дата: Вторник, 23.05.2023, 08:18 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
По аналогии формулы Николая и всего написанного выше:
Код
=СУММ(E4:E22)/СЧЁТЕСЛИ(E4:E22;"<>0")

:p
 
Ответить
СообщениеПо аналогии формулы Николая и всего написанного выше:
Код
=СУММ(E4:E22)/СЧЁТЕСЛИ(E4:E22;"<>0")

:p

Автор - DrMini
Дата добавления - 23.05.2023 в 08:18
Nic70y Дата: Вторник, 23.05.2023, 09:02 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 8831
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
DrMini, elovkov, есть 2 проблемы:
1) Gold_Barsik9945 не нужно среднее значение >0 или <>0, а нужно за месяц
2) у него Excel 2003, т.к. он опять вошел не с того аккаунта этого не видно.
К сообщению приложен файл: 18.xls (44.0 Kb)


ЮMoney 41001841029809
 
Ответить
СообщениеDrMini, elovkov, есть 2 проблемы:
1) Gold_Barsik9945 не нужно среднее значение >0 или <>0, а нужно за месяц
2) у него Excel 2003, т.к. он опять вошел не с того аккаунта этого не видно.

Автор - Nic70y
Дата добавления - 23.05.2023 в 09:02
DrMini Дата: Вторник, 23.05.2023, 09:26 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
нужно за месяц

Ясно. Тогда и название темы не плохо было бы подправить.
 
Ответить
Сообщение
нужно за месяц

Ясно. Тогда и название темы не плохо было бы подправить.

Автор - DrMini
Дата добавления - 23.05.2023 в 09:26
Serge_007 Дата: Вторник, 23.05.2023, 09:34 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
название темы
ТС получил за него замечание


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
название темы
ТС получил за него замечание

Автор - Serge_007
Дата добавления - 23.05.2023 в 09:34
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!