Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Гиперссылкой скопировать диапазон книги (формулами) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Гиперссылкой скопировать диапазон книги (формулами) (Формулы/Formulas)
Гиперссылкой скопировать диапазон книги (формулами)
forumyurok Дата: Вторник, 23.05.2023, 16:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

2021
Подскажите необходимо из одной книги (первый файл-в дальнейшем 1ф) скопировать диапазон ячеек в другую (2ф) и добавить столбец с формулой берущей данные из 1ф. Формула не должна находиться в 1ф.
Пока мысли вслух:
гиперссылкой скопировать диапазон книги (часть таблицы-допустим $А$4:$Cчисло) в другую, не открытую книгу (уже существующий файл в той же папке).
Причём последняя копируемая ячейка должна быть последней ячейкой в своём столбце содержащая данные - 'число', а столбец $C заранее известен, как и первая левая ячейка $A$4.
'число' - переменное кол-во строк которые в 1ф будут в дальнейшем добавляться или удаляться (Во 2ф строки начиная со 107 по 131 должны удалиться - т.к. их нет в 1ф)
Во 2ф в столбце D идёт расчёт из 1ф по принципу =ЕСЛИ(E4-ЦЕЛОЕ(E4)<0,3;ОКРУГЛВНИЗ(E4;0);ОКРУГЛВВЕРХ(E4;0)) с относительной гиперссылкой на 1ф
И возможно-ли в конечном итоге преобразовать результаты работы гиперссылок в числа (есть ли такие операторы, или же это делается только форматированием "вручную" ячеек-убиранием цвета, подчёркивания, но не убирается переход при нажатии)?

Буду весьма признателен Вам за помощь!
К сообщению приложен файл: tufli_prajs_2022.xlsx (16.4 Kb) · inst_prajs_tufli_2022.xlsx (22.0 Kb)
 
Ответить
СообщениеПодскажите необходимо из одной книги (первый файл-в дальнейшем 1ф) скопировать диапазон ячеек в другую (2ф) и добавить столбец с формулой берущей данные из 1ф. Формула не должна находиться в 1ф.
Пока мысли вслух:
гиперссылкой скопировать диапазон книги (часть таблицы-допустим $А$4:$Cчисло) в другую, не открытую книгу (уже существующий файл в той же папке).
Причём последняя копируемая ячейка должна быть последней ячейкой в своём столбце содержащая данные - 'число', а столбец $C заранее известен, как и первая левая ячейка $A$4.
'число' - переменное кол-во строк которые в 1ф будут в дальнейшем добавляться или удаляться (Во 2ф строки начиная со 107 по 131 должны удалиться - т.к. их нет в 1ф)
Во 2ф в столбце D идёт расчёт из 1ф по принципу =ЕСЛИ(E4-ЦЕЛОЕ(E4)<0,3;ОКРУГЛВНИЗ(E4;0);ОКРУГЛВВЕРХ(E4;0)) с относительной гиперссылкой на 1ф
И возможно-ли в конечном итоге преобразовать результаты работы гиперссылок в числа (есть ли такие операторы, или же это делается только форматированием "вручную" ячеек-убиранием цвета, подчёркивания, но не убирается переход при нажатии)?

Буду весьма признателен Вам за помощь!

Автор - forumyurok
Дата добавления - 23.05.2023 в 16:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Гиперссылкой скопировать диапазон книги (формулами) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!