Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление процентного соотношение данных из массива - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Вычисление процентного соотношение данных из массива
sodcover Дата: Понедельник, 25.09.2023, 06:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Имеются данные потерь картофеля от заболевания за пять лет в конкретном регионе России. В каждом регионе есть несколько повторений. Необходимо узнать сколько раз в процентном соотношении за пятилетний период встречались значения потерь картофеля <10; 10-20; >20 суммарно внутри каждого региона.
К сообщению приложен файл: poteri.xlsx (24.0 Kb)
 
Ответить
СообщениеИмеются данные потерь картофеля от заболевания за пять лет в конкретном регионе России. В каждом регионе есть несколько повторений. Необходимо узнать сколько раз в процентном соотношении за пятилетний период встречались значения потерь картофеля <10; 10-20; >20 суммарно внутри каждого региона.

Автор - sodcover
Дата добавления - 25.09.2023 в 06:44
Nic70y Дата: Понедельник, 25.09.2023, 09:26 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8801
Репутация: 2295 ±
Замечаний: 0% ±

Excel 2010
вдруг правильно
Код
=ЕСЛИ($A2<>"";ЕСЛИ(СТОЛБЕЦ()<>8;СЧЁТЕСЛИ($B2:$F2;G$1);СЧЁТ($B2:$F2)-$G2-$I2);СУММ(ИНДЕКС(G:G;СУММПРОИЗВ(МАКС(1;($A$1:$A1="")*СТРОКА($A$1:$A1)))+1):G1)/СЧЁТ(ИНДЕКС($B:$F;СУММПРОИЗВ(МАКС(1;($A$1:$A1="")*СТРОКА($A$1:$A1))+1);):$F1))
К сообщению приложен файл: 18.xlsx (30.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевдруг правильно
Код
=ЕСЛИ($A2<>"";ЕСЛИ(СТОЛБЕЦ()<>8;СЧЁТЕСЛИ($B2:$F2;G$1);СЧЁТ($B2:$F2)-$G2-$I2);СУММ(ИНДЕКС(G:G;СУММПРОИЗВ(МАКС(1;($A$1:$A1="")*СТРОКА($A$1:$A1)))+1):G1)/СЧЁТ(ИНДЕКС($B:$F;СУММПРОИЗВ(МАКС(1;($A$1:$A1="")*СТРОКА($A$1:$A1))+1);):$F1))

Автор - Nic70y
Дата добавления - 25.09.2023 в 09:26
Pelena Дата: Понедельник, 25.09.2023, 11:03 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 19211
Репутация: 4427 ±
Замечаний: ±

Excel 365 & Mac Excel
О как! А я тут отвечаю >(
sodcover, зачем темы дублируете?


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеО как! А я тут отвечаю >(
sodcover, зачем темы дублируете?

Автор - Pelena
Дата добавления - 25.09.2023 в 11:03
sodcover Дата: Вторник, 26.09.2023, 06:38 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Здравствуйте, благодарю за помощь. Прошу прощение за дублирование темы. Случайно получилось. Я не специально. Запуталась(((
 
Ответить
СообщениеЗдравствуйте, благодарю за помощь. Прошу прощение за дублирование темы. Случайно получилось. Я не специально. Запуталась(((

Автор - sodcover
Дата добавления - 26.09.2023 в 06:38
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!