Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отобрать аргумент и выбор значения по последней дате - Мир MS Excel

Старая форма входа
  • Страница 1 из 2
  • 1
  • 2
  • »
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отобрать аргумент и выбор значения по последней дате (Формулы/Formulas)
Отобрать аргумент и выбор значения по последней дате
torg0096420 Дата: Пятница, 10.11.2023, 15:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Добрый день. Прошу помочь в решении одной задачи.
Необходимо из списка по отбору выбрать последнее по дате значение
К сообщению приложен файл: poslednee_znachenie_po_date.xlsx (10.3 Kb)
 
Ответить
СообщениеДобрый день. Прошу помочь в решении одной задачи.
Необходимо из списка по отбору выбрать последнее по дате значение

Автор - torg0096420
Дата добавления - 10.11.2023 в 15:10
Arti3223 Дата: Пятница, 10.11.2023, 15:19 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 10 ±
Замечаний: 0% ±

2016
Добрый день.

Вариант
Код
=ПРОСМОТР(C17;C6:D12)
 
Ответить
СообщениеДобрый день.

Вариант
Код
=ПРОСМОТР(C17;C6:D12)

Автор - Arti3223
Дата добавления - 10.11.2023 в 15:19
DrMini Дата: Пятница, 10.11.2023, 15:23 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте.
выбрать последнее по дате значение

И в ячейку C17:
Код
=МАКС(C6:C12)
К сообщению приложен файл: 9385134.xlsx (11.1 Kb)


Сообщение отредактировал DrMini - Пятница, 10.11.2023, 15:33
 
Ответить
СообщениеЗдравствуйте.
выбрать последнее по дате значение

И в ячейку C17:
Код
=МАКС(C6:C12)

Автор - DrMini
Дата добавления - 10.11.2023 в 15:23
torg0096420 Дата: Пятница, 10.11.2023, 15:28 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Выбираем Продукция 2 и из его отбора получаем значение по последней дате
 
Ответить
СообщениеВыбираем Продукция 2 и из его отбора получаем значение по последней дате

Автор - torg0096420
Дата добавления - 10.11.2023 в 15:28
elovkov Дата: Пятница, 10.11.2023, 15:28 | Сообщение № 5
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
И в ячейку C17:

До кучи, можно еще в ячейку В17 продукцию выбрать
Код
=ПРОСМОТР(C17;ВЫБОР({1;2};C6:C12;B6:B12))


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
И в ячейку C17:

До кучи, можно еще в ячейку В17 продукцию выбрать
Код
=ПРОСМОТР(C17;ВЫБОР({1;2};C6:C12;B6:B12))

Автор - elovkov
Дата добавления - 10.11.2023 в 15:28
Gustav Дата: Пятница, 10.11.2023, 15:31 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2652
Репутация: 1114 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Я так понял, что отталкиваться надо от названия. Если так, то для D17 формула массива (ввод по Ctrl+Shift+Enter):
Код
=ВПР(9^9;ЕСЛИ(B6:B12=B17;C6:D12);2)

где 9^9 - бесконечно большая дата в числовом выражении.


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеЯ так понял, что отталкиваться надо от названия. Если так, то для D17 формула массива (ввод по Ctrl+Shift+Enter):
Код
=ВПР(9^9;ЕСЛИ(B6:B12=B17;C6:D12);2)

где 9^9 - бесконечно большая дата в числовом выражении.

Автор - Gustav
Дата добавления - 10.11.2023 в 15:31
Nic70y Дата: Пятница, 10.11.2023, 15:34 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
дата
Код
=СУММПРОИЗВ(МАКС((B6:B12=B17)*C6:C12))
расходы
Код
=СУММЕСЛИМН(D6:D12;B6:B12;B17;C6:C12;C17)
К сообщению приложен файл: 18.xlsx (10.6 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениедата
Код
=СУММПРОИЗВ(МАКС((B6:B12=B17)*C6:C12))
расходы
Код
=СУММЕСЛИМН(D6:D12;B6:B12;B17;C6:C12;C17)

Автор - Nic70y
Дата добавления - 10.11.2023 в 15:34
elovkov Дата: Пятница, 10.11.2023, 15:35 | Сообщение № 8
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
Выбираем Продукция 2

А если сначала выбираем продукцию, потом по ней последнюю дату - можно так:
Код
=МАКС(ЕСЛИ(B17=B6:B12;C6:C12;))

Массивная - вводится нажатием ктрл-шифт-ентер


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
Выбираем Продукция 2

А если сначала выбираем продукцию, потом по ней последнюю дату - можно так:
Код
=МАКС(ЕСЛИ(B17=B6:B12;C6:C12;))

Массивная - вводится нажатием ктрл-шифт-ентер

Автор - elovkov
Дата добавления - 10.11.2023 в 15:35
torg0096420 Дата: Пятница, 10.11.2023, 15:45 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
=ВПР(9^9;ЕСЛИ(B6:B12=B17;C6:D12);2) Работает
Возможно без массива (много данных - застревает)
Результат - выбор продукции и на выходе одно значение по последней дате или единственное
 
Ответить
Сообщение=ВПР(9^9;ЕСЛИ(B6:B12=B17;C6:D12);2) Работает
Возможно без массива (много данных - застревает)
Результат - выбор продукции и на выходе одно значение по последней дате или единственное

Автор - torg0096420
Дата добавления - 10.11.2023 в 15:45
torg0096420 Дата: Пятница, 10.11.2023, 17:00 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Прогонял по реальным данным-даты не отсортированы, формула возвращает последнее значение из выборки, хотя дата не актуальная - в файле пример привел.
Можно это пожалуйста поправить))
К сообщению приложен файл: 8378511.xlsx (11.1 Kb)
 
Ответить
СообщениеПрогонял по реальным данным-даты не отсортированы, формула возвращает последнее значение из выборки, хотя дата не актуальная - в файле пример привел.
Можно это пожалуйста поправить))

Автор - torg0096420
Дата добавления - 10.11.2023 в 17:00
Nic70y Дата: Пятница, 10.11.2023, 17:07 | Сообщение № 11
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
Прогонял по реальным
но не все формулы
К сообщению приложен файл: 19.xlsx (11.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Прогонял по реальным
но не все формулы

Автор - Nic70y
Дата добавления - 10.11.2023 в 17:07
DrMini Дата: Пятница, 10.11.2023, 17:11 | Сообщение № 12
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Так?
К сообщению приложен файл: 6183058.xlsx (11.8 Kb)
 
Ответить
СообщениеТак?

Автор - DrMini
Дата добавления - 10.11.2023 в 17:11
Nic70y Дата: Пятница, 10.11.2023, 17:13 | Сообщение № 13
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
DrMini, ВПР вернет первое вхождение по дате игнорируя продукцию


ЮMoney 41001841029809
 
Ответить
СообщениеDrMini, ВПР вернет первое вхождение по дате игнорируя продукцию

Автор - Nic70y
Дата добавления - 10.11.2023 в 17:13
torg0096420 Дата: Пятница, 10.11.2023, 17:16 | Сообщение № 14
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Немного не так. На выходе против продукции выходит значение, даты вспомогательной нет.
Продукция 2 1350 и все (это элемент таблицы и дат нет)
или
Продукция 2 1505
 
Ответить
СообщениеНемного не так. На выходе против продукции выходит значение, даты вспомогательной нет.
Продукция 2 1350 и все (это элемент таблицы и дат нет)
или
Продукция 2 1505

Автор - torg0096420
Дата добавления - 10.11.2023 в 17:16
DrMini Дата: Пятница, 10.11.2023, 17:17 | Сообщение № 15
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
ВПР вернет первое вхождение по дате игнорируя продукцию

Ага. Знаю. Но совпало. Может torg0096420, это и нужно. А рядом через ИНДЕКС ещё добавил.
Задание с самого начала несколько раз изменялось. Так и найдём ИСТИНУ.
:)
 
Ответить
Сообщение
ВПР вернет первое вхождение по дате игнорируя продукцию

Ага. Знаю. Но совпало. Может torg0096420, это и нужно. А рядом через ИНДЕКС ещё добавил.
Задание с самого начала несколько раз изменялось. Так и найдём ИСТИНУ.
:)

Автор - DrMini
Дата добавления - 10.11.2023 в 17:17
DrMini Дата: Пятница, 10.11.2023, 17:19 | Сообщение № 16
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Продукция 2 1350 и все (это элемент таблицы и дат нет)
или
Продукция 2 1505

%)
 
Ответить
Сообщение
Продукция 2 1350 и все (это элемент таблицы и дат нет)
или
Продукция 2 1505

%)

Автор - DrMini
Дата добавления - 10.11.2023 в 17:19
Gustav Дата: Пятница, 10.11.2023, 17:28 | Сообщение № 17
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2652
Репутация: 1114 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
даты не отсортированы

Эх, об этом хорошо бы сразу в начале говорить, а не квест устраивать! Стало быть, предварительное определение максимальной даты неизбежно.

Тогда уточните, пожалуйста, еще: цена не может в один день меняться несколько раз? В вашей версии Excel 2016 уже есть функция МАКСЕСЛИ ?


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
даты не отсортированы

Эх, об этом хорошо бы сразу в начале говорить, а не квест устраивать! Стало быть, предварительное определение максимальной даты неизбежно.

Тогда уточните, пожалуйста, еще: цена не может в один день меняться несколько раз? В вашей версии Excel 2016 уже есть функция МАКСЕСЛИ ?

Автор - Gustav
Дата добавления - 10.11.2023 в 17:28
torg0096420 Дата: Пятница, 10.11.2023, 17:32 | Сообщение № 18
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

2016
Если ввел в заблуждение заданием, не специально, выяснилось на проверке.
МАКСЕСЛИ в 2016 нет появился в 2019
 
Ответить
СообщениеЕсли ввел в заблуждение заданием, не специально, выяснилось на проверке.
МАКСЕСЛИ в 2016 нет появился в 2019

Автор - torg0096420
Дата добавления - 10.11.2023 в 17:32
DrMini Дата: Пятница, 10.11.2023, 17:32 | Сообщение № 19
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Да и там еще один параметр Продукция 2 была написана без пробела.
В файле подправил.
К сообщению приложен файл: 0323020.xlsx (11.9 Kb)
 
Ответить
СообщениеДа и там еще один параметр Продукция 2 была написана без пробела.
В файле подправил.

Автор - DrMini
Дата добавления - 10.11.2023 в 17:32
DrMini Дата: Пятница, 10.11.2023, 17:33 | Сообщение № 20
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
МАКСЕСЛИ в 2016 нет

Тогда мой вариант "хромает".
 
Ответить
Сообщение
МАКСЕСЛИ в 2016 нет

Тогда мой вариант "хромает".

Автор - DrMini
Дата добавления - 10.11.2023 в 17:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отобрать аргумент и выбор значения по последней дате (Формулы/Formulas)
  • Страница 1 из 2
  • 1
  • 2
  • »
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!