Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск слова в тексте по столбцу и извлечение текста - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск слова в тексте по столбцу и извлечение текста (Формулы/Formulas)
Поиск слова в тексте по столбцу и извлечение текста
denis_afanase8 Дата: Четверг, 16.11.2023, 21:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

Добрый день, уважаемые знатоки!


Хотелось бы немного расширить возможности формулы поиска и извлечения, которая отражена в посте Поиск слова в тексте по столбцу и извлечение значения

В связи с чем прошу помочь в решении следующей задачи, которая была озвучена в указанном посте в последнем сообщении .

Имеется столбец, в котором необходимо найти все сообщения, содержащие номер заказа (в данном случаи 111) и проверить статус заказа в этом сообщении. Вывести статус заказа, который встречается в последнем сообщении, содержащий номер заказа (в данном случаи 111).

Если такого заказа нет, выдать сообщение "Заказ отсутствует".

Порядковые номера сообщений не повторяются, они индивидуальные для каждого сообщения.
К сообщению приложен файл: primerxlsx_2.xls (31.5 Kb)


Сообщение отредактировал denis_afanase8 - Четверг, 16.11.2023, 21:48
 
Ответить
Сообщение
Добрый день, уважаемые знатоки!


Хотелось бы немного расширить возможности формулы поиска и извлечения, которая отражена в посте Поиск слова в тексте по столбцу и извлечение значения

В связи с чем прошу помочь в решении следующей задачи, которая была озвучена в указанном посте в последнем сообщении .

Имеется столбец, в котором необходимо найти все сообщения, содержащие номер заказа (в данном случаи 111) и проверить статус заказа в этом сообщении. Вывести статус заказа, который встречается в последнем сообщении, содержащий номер заказа (в данном случаи 111).

Если такого заказа нет, выдать сообщение "Заказ отсутствует".

Порядковые номера сообщений не повторяются, они индивидуальные для каждого сообщения.

Автор - denis_afanase8
Дата добавления - 16.11.2023 в 21:47
gling Дата: Четверг, 16.11.2023, 23:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2519
Репутация: 674 ±
Замечаний: 0% ±

2010
Здравствуйте.
Вариант в файле.
К сообщению приложен файл: 1115319.xls (52.0 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Вариант в файле.

Автор - gling
Дата добавления - 16.11.2023 в 23:54
denis_afanase8 Дата: Суббота, 18.11.2023, 21:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

Благодарю за ответ gling.

Согласно Вашему варианту решения, выводится все три статуса заказа.

И если изменить один из заказов "111" на "112", то результат не изменится.

Необходимо, что бы отображался один результат, в данном случаи должен быть результат "В комплектации", т.к. он встречается в последнем сообщении с заказом "111".

Высылаю свой вариант решения с учетом формул, которые были представлены Здесь и сообщением выше.


Находим последнее сообщение, в котором встречается заказ с номером "111" и выводим порядковый номер этого сообщения
Код
=МАКС(ЕЧИСЛО(ПОИСК(A2;B2:B7))*C2:C7)


Выводим последнее сообщение, в котором встречается заказ с номером "111"
Код
=ЕСЛИ(E2;ИНДЕКС(B2:B7;E2);"Заказ отсутствует")


Находим в выведенном сообщении статус заказа и отображаем его
Код
=СцепитьЕсли(B17:B21;1;A17:A21;"; ";1)
К сообщению приложен файл: 4309434.xls (58.5 Kb)


Сообщение отредактировал denis_afanase8 - Суббота, 18.11.2023, 22:26
 
Ответить
Сообщение
Благодарю за ответ gling.

Согласно Вашему варианту решения, выводится все три статуса заказа.

И если изменить один из заказов "111" на "112", то результат не изменится.

Необходимо, что бы отображался один результат, в данном случаи должен быть результат "В комплектации", т.к. он встречается в последнем сообщении с заказом "111".

Высылаю свой вариант решения с учетом формул, которые были представлены Здесь и сообщением выше.


Находим последнее сообщение, в котором встречается заказ с номером "111" и выводим порядковый номер этого сообщения
Код
=МАКС(ЕЧИСЛО(ПОИСК(A2;B2:B7))*C2:C7)


Выводим последнее сообщение, в котором встречается заказ с номером "111"
Код
=ЕСЛИ(E2;ИНДЕКС(B2:B7;E2);"Заказ отсутствует")


Находим в выведенном сообщении статус заказа и отображаем его
Код
=СцепитьЕсли(B17:B21;1;A17:A21;"; ";1)

Автор - denis_afanase8
Дата добавления - 18.11.2023 в 21:54
gling Дата: Суббота, 18.11.2023, 22:35 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2519
Репутация: 674 ±
Замечаний: 0% ±

2010
Тогда так
Код
=ЕСЛИ(МАКС(B11:B15)=0;"Нет данных";ИНДЕКС($A$11:$A$15;ПОИСКПОЗ(МАКС($B$11:$B$15);$B$11:$B$15;)))
К сообщению приложен файл: 3503942.xls (52.5 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Суббота, 18.11.2023, 23:01
 
Ответить
СообщениеТогда так
Код
=ЕСЛИ(МАКС(B11:B15)=0;"Нет данных";ИНДЕКС($A$11:$A$15;ПОИСКПОЗ(МАКС($B$11:$B$15);$B$11:$B$15;)))

Автор - gling
Дата добавления - 18.11.2023 в 22:35
denis_afanase8 Дата: Понедельник, 20.11.2023, 21:09 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 40% ±

Благодарю за помощь gling, всё заработало!
 
Ответить
Сообщение
Благодарю за помощь gling, всё заработало!

Автор - denis_afanase8
Дата добавления - 20.11.2023 в 21:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск слова в тексте по столбцу и извлечение текста (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!