Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Соединение разных Дат с числом и прописью - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Соединение разных Дат с числом и прописью
andron359 Дата: Понедельник, 27.11.2023, 10:35 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 40% ±

2010
Добрый день !
Есть исходные : например
11.01.2023 - в формате дата
12.01.2023 - в формате дата
13.02.2023 - в формате дата
15.02.2024 - в формате дата
Необходимо сделать если:
начало работы 11.01.2023 окончание работы 11.01.2023 должно быть 11 ЯНВАРЯ,2023
начало работы 11.01.2023 окончание работы 12.01.2023 должно быть 11 - 12 ЯНВАРЯ,2023
начало работы 11.01.2023 окончание работы 13.02.2023 должно быть 11 ЯНВАРЯ - 13 ФЕВРАЛЯ,2023
начало работы 11.01.2023 окончание работы 15.02.2024 должно быть 11 ЯНВАРЯ,2023 - 15 ФЕВРАЛЯ,2024

Пробовал сделать сам , ничего не получается .
 
Ответить
СообщениеДобрый день !
Есть исходные : например
11.01.2023 - в формате дата
12.01.2023 - в формате дата
13.02.2023 - в формате дата
15.02.2024 - в формате дата
Необходимо сделать если:
начало работы 11.01.2023 окончание работы 11.01.2023 должно быть 11 ЯНВАРЯ,2023
начало работы 11.01.2023 окончание работы 12.01.2023 должно быть 11 - 12 ЯНВАРЯ,2023
начало работы 11.01.2023 окончание работы 13.02.2023 должно быть 11 ЯНВАРЯ - 13 ФЕВРАЛЯ,2023
начало работы 11.01.2023 окончание работы 15.02.2024 должно быть 11 ЯНВАРЯ,2023 - 15 ФЕВРАЛЯ,2024

Пробовал сделать сам , ничего не получается .

Автор - andron359
Дата добавления - 27.11.2023 в 10:35
elovkov Дата: Понедельник, 27.11.2023, 10:52 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 385
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Как-то так
Код
=ЕСЛИ(A1=B1;ПРОПИСН(ТЕКСТ(B1;"[$-FC19]ДД ММММ, ГГГГ"));ЕСЛИ(МЕСЯЦ(A1)=МЕСЯЦ(B1);ДЕНЬ(A1)&" - "&ПРОПИСН(ТЕКСТ(B1;"[$-FC19]ДД ММММ, ГГГГ"));ЕСЛИ(ГОД(A1)=ГОД(B1);ПРОПИСН(ТЕКСТ(A1;"[$-FC19]ДД ММММ"))&" - "&ПРОПИСН(ТЕКСТ(B1;"[$-FC19]ДД ММММ, ГГГГ"));ПРОПИСН(ТЕКСТ(A1;"[$-FC19]ДД ММММ, ГГГГ"))&" - "&ПРОПИСН(ТЕКСТ(B1;"[$-FC19]ДД ММММ, ГГГГ")))))
К сообщению приложен файл: daty.xlsx (8.4 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеКак-то так
Код
=ЕСЛИ(A1=B1;ПРОПИСН(ТЕКСТ(B1;"[$-FC19]ДД ММММ, ГГГГ"));ЕСЛИ(МЕСЯЦ(A1)=МЕСЯЦ(B1);ДЕНЬ(A1)&" - "&ПРОПИСН(ТЕКСТ(B1;"[$-FC19]ДД ММММ, ГГГГ"));ЕСЛИ(ГОД(A1)=ГОД(B1);ПРОПИСН(ТЕКСТ(A1;"[$-FC19]ДД ММММ"))&" - "&ПРОПИСН(ТЕКСТ(B1;"[$-FC19]ДД ММММ, ГГГГ"));ПРОПИСН(ТЕКСТ(A1;"[$-FC19]ДД ММММ, ГГГГ"))&" - "&ПРОПИСН(ТЕКСТ(B1;"[$-FC19]ДД ММММ, ГГГГ")))))

Автор - elovkov
Дата добавления - 27.11.2023 в 10:52
andron359 Дата: Понедельник, 27.11.2023, 11:07 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 40% ±

2010
elovkov,
Спасибо огромное , всё как нужно ,

Ну и ещё вопрос , как формулами переводить даты , например:
в ячейку пишем 23.11.2023 в формате Краткий формат даты
а необходимо получить - 23rd of November, 2023 / 23 Ноября, 2023
 
Ответить
Сообщениеelovkov,
Спасибо огромное , всё как нужно ,

Ну и ещё вопрос , как формулами переводить даты , например:
в ячейку пишем 23.11.2023 в формате Краткий формат даты
а необходимо получить - 23rd of November, 2023 / 23 Ноября, 2023

Автор - andron359
Дата добавления - 27.11.2023 в 11:07
elovkov Дата: Понедельник, 27.11.2023, 11:10 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 385
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Немного поправил, чтобы один месяц разных лет правильно понимался
Код
=ЕСЛИ(A4=B4;ПРОПИСН(ТЕКСТ(B4;"[$-FC19]ДД ММММ, ГГГГ"));ЕСЛИ(И(МЕСЯЦ(A4)=МЕСЯЦ(B4);ГОД(A4)=ГОД(B4));ДЕНЬ(A4)&" - "&ПРОПИСН(ТЕКСТ(B4;"[$-FC19]ДД ММММ, ГГГГ"));ЕСЛИ(ГОД(A4)=ГОД(B4);ПРОПИСН(ТЕКСТ(A4;"[$-FC19]ДД ММММ"))&" - "&ПРОПИСН(ТЕКСТ(B4;"[$-FC19]ДД ММММ, ГГГГ"));ПРОПИСН(ТЕКСТ(A4;"[$-FC19]ДД ММММ, ГГГГ"))&" - "&ПРОПИСН(ТЕКСТ(B4;"[$-FC19]ДД ММММ, ГГГГ")))))


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеНемного поправил, чтобы один месяц разных лет правильно понимался
Код
=ЕСЛИ(A4=B4;ПРОПИСН(ТЕКСТ(B4;"[$-FC19]ДД ММММ, ГГГГ"));ЕСЛИ(И(МЕСЯЦ(A4)=МЕСЯЦ(B4);ГОД(A4)=ГОД(B4));ДЕНЬ(A4)&" - "&ПРОПИСН(ТЕКСТ(B4;"[$-FC19]ДД ММММ, ГГГГ"));ЕСЛИ(ГОД(A4)=ГОД(B4);ПРОПИСН(ТЕКСТ(A4;"[$-FC19]ДД ММММ"))&" - "&ПРОПИСН(ТЕКСТ(B4;"[$-FC19]ДД ММММ, ГГГГ"));ПРОПИСН(ТЕКСТ(A4;"[$-FC19]ДД ММММ, ГГГГ"))&" - "&ПРОПИСН(ТЕКСТ(B4;"[$-FC19]ДД ММММ, ГГГГ")))))

Автор - elovkov
Дата добавления - 27.11.2023 в 11:10
elovkov Дата: Понедельник, 27.11.2023, 12:27 | Сообщение № 5
Группа: Друзья
Ранг: Обитатель
Сообщений: 385
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
необходимо получить - 23rd of November, 2023 / 23 Ноября, 2023


поиграть с форматами
Код
=ТЕКСТ(A1;"[$-FC01] ДД ММММ, ГГГГ")&" / "&ТЕКСТ(A1;"[$-FC19] ДД ММММ, ГГГГ")


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
необходимо получить - 23rd of November, 2023 / 23 Ноября, 2023


поиграть с форматами
Код
=ТЕКСТ(A1;"[$-FC01] ДД ММММ, ГГГГ")&" / "&ТЕКСТ(A1;"[$-FC19] ДД ММММ, ГГГГ")

Автор - elovkov
Дата добавления - 27.11.2023 в 12:27
andron359 Дата: Понедельник, 27.11.2023, 12:35 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 40% ±

2010
elovkov,

Спасибо , я понял ,
а где можно найти форматы дат для разных языков : [$-FC01] / [$-FC19] и т.д.
 
Ответить
Сообщениеelovkov,

Спасибо , я понял ,
а где можно найти форматы дат для разных языков : [$-FC01] / [$-FC19] и т.д.

Автор - andron359
Дата добавления - 27.11.2023 в 12:35
elovkov Дата: Понедельник, 27.11.2023, 12:55 | Сообщение № 7
Группа: Друзья
Ранг: Обитатель
Сообщений: 385
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Я просто про 19 знал, попробовал 1 - получил английский))) пробуйте


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеЯ просто про 19 знал, попробовал 1 - получил английский))) пробуйте

Автор - elovkov
Дата добавления - 27.11.2023 в 12:55
DrMini Дата: Понедельник, 27.11.2023, 13:48 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
где можно найти форматы дат для разных языков

в формате ячеек
К сообщению приложен файл: 9536001.jpg (53.4 Kb)
 
Ответить
Сообщение
где можно найти форматы дат для разных языков

в формате ячеек

Автор - DrMini
Дата добавления - 27.11.2023 в 13:48
andron359 Дата: Понедельник, 27.11.2023, 15:14 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 40% ±

2010
DrMini,

Добрый день ,
про эти я знаю , я спрашивал про такие [$-FC01]
 
Ответить
СообщениеDrMini,

Добрый день ,
про эти я знаю , я спрашивал про такие [$-FC01]

Автор - andron359
Дата добавления - 27.11.2023 в 15:14
DrMini Дата: Понедельник, 27.11.2023, 15:29 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
про эти я знаю

Я выбирал нужный мне формат даты (например на иврите)

потом во все форматы и там правил под себя
К сообщению приложен файл: 8086316.jpg (50.2 Kb) · 7415313.jpg (49.4 Kb)
 
Ответить
Сообщение
про эти я знаю

Я выбирал нужный мне формат даты (например на иврите)

потом во все форматы и там правил под себя

Автор - DrMini
Дата добавления - 27.11.2023 в 15:29
andron359 Дата: Понедельник, 27.11.2023, 16:00 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 40% ±

2010
DrMini,

Спасибо ,
 
Ответить
СообщениеDrMini,

Спасибо ,

Автор - andron359
Дата добавления - 27.11.2023 в 16:00
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!