Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать форму для автоматического изменения значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать форму для автоматического изменения значений (Формулы/Formulas)
Как сделать форму для автоматического изменения значений
monychev-solid-rus Дата: Понедельник, 27.11.2023, 18:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2013
Здравствуйте уважаемые знатоки Excell! Есть такая задача:
Есть форма (шаблон) по номерам квартир (всего больше 1000 номеров). Нужно как то сделать чтобы при вписывании номера квартиры проставлялся автоматически тип квартиры и таблица автоматически заполнялась нужными данными. Сделал форму (шаблон) на отдельном листе, типы и номера квартир на отдельном листе и данные для учета в шаблоне на отдельном листе. При помощи каких формул можно сделать чтобы данные автоматически проставлялись в форму? В самом Экселе написал и выделил цветом в каких ячейках должно что быть). Если можно объяснить как сделать проще эту автоматизацию (лучше без макросов если можно). Заранее всем спасибо
К сообщению приложен файл: tablica_dlja_pnr.xlsx (46.9 Kb)
 
Ответить
СообщениеЗдравствуйте уважаемые знатоки Excell! Есть такая задача:
Есть форма (шаблон) по номерам квартир (всего больше 1000 номеров). Нужно как то сделать чтобы при вписывании номера квартиры проставлялся автоматически тип квартиры и таблица автоматически заполнялась нужными данными. Сделал форму (шаблон) на отдельном листе, типы и номера квартир на отдельном листе и данные для учета в шаблоне на отдельном листе. При помощи каких формул можно сделать чтобы данные автоматически проставлялись в форму? В самом Экселе написал и выделил цветом в каких ячейках должно что быть). Если можно объяснить как сделать проще эту автоматизацию (лучше без макросов если можно). Заранее всем спасибо

Автор - monychev-solid-rus
Дата добавления - 27.11.2023 в 18:00
AlexM Дата: Понедельник, 27.11.2023, 18:28 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
Код
=ВПР(T10;ЕСЛИ({0;1};'Типы квартир'!A2:A1170;'Типы квартир'!B2:B1170);2;)
К сообщению приложен файл: tablica_dlja_pnr1.xlsx (46.2 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 27.11.2023, 19:57
 
Ответить
Сообщение
Код
=ВПР(T10;ЕСЛИ({0;1};'Типы квартир'!A2:A1170;'Типы квартир'!B2:B1170);2;)

Автор - AlexM
Дата добавления - 27.11.2023 в 18:28
DrMini Дата: Понедельник, 27.11.2023, 19:25 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте monychev-solid-rus,
Посмотрите в файле.

[p.s.]Объединённые ячейки это зло![/p.s.]
[offtop]Лист Квартиры я немного подправил.[/offtop]
К сообщению приложен файл: 6712694.xlsx (49.3 Kb)


Сообщение отредактировал DrMini - Понедельник, 27.11.2023, 19:28
 
Ответить
СообщениеЗдравствуйте monychev-solid-rus,
Посмотрите в файле.

[p.s.]Объединённые ячейки это зло![/p.s.]
[offtop]Лист Квартиры я немного подправил.[/offtop]

Автор - DrMini
Дата добавления - 27.11.2023 в 19:25
DrMini Дата: Понедельник, 27.11.2023, 19:33 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Добрый вечер AlexM,
Подскажите пожалуйста, как работает вот этот кусок формулы:
Код
ЕСЛИ({0;1}
 
Ответить
СообщениеДобрый вечер AlexM,
Подскажите пожалуйста, как работает вот этот кусок формулы:
Код
ЕСЛИ({0;1}

Автор - DrMini
Дата добавления - 27.11.2023 в 19:33
AlexM Дата: Понедельник, 27.11.2023, 19:39 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
DrMini, ВПР ищет значение в первом столбце таблицы. Чтобы функция работала в этой задаче нужно в таблице поменять столбцы. Такой прием это делает.
Почитайте еще тему ВПР не по первому столбцу



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеDrMini, ВПР ищет значение в первом столбце таблицы. Чтобы функция работала в этой задаче нужно в таблице поменять столбцы. Такой прием это делает.
Почитайте еще тему ВПР не по первому столбцу

Автор - AlexM
Дата добавления - 27.11.2023 в 19:39
DrMini Дата: Понедельник, 27.11.2023, 20:24 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
нужно в таблице поменять столбцы

Спасибо. Постараюсь запомнить. Вдруг ИНДЕКС с ПОИСКПОЗ не подойдёт
 
Ответить
Сообщение
нужно в таблице поменять столбцы

Спасибо. Постараюсь запомнить. Вдруг ИНДЕКС с ПОИСКПОЗ не подойдёт

Автор - DrMini
Дата добавления - 27.11.2023 в 20:24
AlexM Дата: Понедельник, 27.11.2023, 20:25 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4379
Репутация: 1081 ±
Замечаний: 0% ±

Excel 2003
Добавил формулы в таблицу. Формулы для столбца В и С и далее
Код
=ЕСЛИ(B26=0;0;ИНДЕКС(Квартиры!$A:$Q;ПОИСКПОЗ(Лист1!$P$10;Квартиры!$A:$A;)+$A27;B$26-1))

Код
=ИНДЕКС(Квартиры!$A:$Q;ПОИСКПОЗ(Лист1!$P$10;Квартиры!$A:$A;)+$A27;C$26-1)

Объединенные перед вставкой формул разделил, потом объединил.
В таблице УФ скрывает пустые значения
К сообщению приложен файл: tablica_dlja_pnr2.xlsx (48.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеДобавил формулы в таблицу. Формулы для столбца В и С и далее
Код
=ЕСЛИ(B26=0;0;ИНДЕКС(Квартиры!$A:$Q;ПОИСКПОЗ(Лист1!$P$10;Квартиры!$A:$A;)+$A27;B$26-1))

Код
=ИНДЕКС(Квартиры!$A:$Q;ПОИСКПОЗ(Лист1!$P$10;Квартиры!$A:$A;)+$A27;C$26-1)

Объединенные перед вставкой формул разделил, потом объединил.
В таблице УФ скрывает пустые значения

Автор - AlexM
Дата добавления - 27.11.2023 в 20:25
monychev-solid-rus Дата: Вторник, 28.11.2023, 09:09 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

2013
Всем огромное спасибо, сейчас буду смотреть и разбираться)) Вы точно гении Excell'a))
 
Ответить
СообщениеВсем огромное спасибо, сейчас буду смотреть и разбираться)) Вы точно гении Excell'a))

Автор - monychev-solid-rus
Дата добавления - 28.11.2023 в 09:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать форму для автоматического изменения значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!