Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР работает не корректно - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР работает не корректно (Формулы/Formulas)
ВПР работает не корректно
Svyaz Дата: Четверг, 30.11.2023, 20:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

стандартный 2016
Здравствуйте!

Не могу понять - вроде элементарная формула - поиск числа в таблице по другому числу, но начиная с 134 строки число 14,2 искомое число съезжает на строку выше (14,1).
Затем на целом числе и следующее (15 и 15,1, 16 и 16,1) выбирает правильно, а остальные съезжает.
Что за фигня такая?
К сообщению приложен файл: sboj_vpr.xlsx (34.1 Kb)


всем привет!
 
Ответить
СообщениеЗдравствуйте!

Не могу понять - вроде элементарная формула - поиск числа в таблице по другому числу, но начиная с 134 строки число 14,2 искомое число съезжает на строку выше (14,1).
Затем на целом числе и следующее (15 и 15,1, 16 и 16,1) выбирает правильно, а остальные съезжает.
Что за фигня такая?

Автор - Svyaz
Дата добавления - 30.11.2023 в 20:11
Serge_007 Дата: Четверг, 30.11.2023, 20:59 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16450
Репутация: 2746 ±
Замечаний: ±

Excel 2016
возвращает 180,4
Так и должно быть
Что не так?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщениевозвращает 180,4
Так и должно быть
Что не так?

Автор - Serge_007
Дата добавления - 30.11.2023 в 20:59
Svyaz Дата: Четверг, 30.11.2023, 21:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

стандартный 2016
смотрим по 1 строчке: 1 - возвращает 12, 1,1 возвращает 12,7.
Но это уже не важно.
Я понял наполовину что не так:
те цифры, что не верно возвращают ручками перебиваю - и всё нормально получается.
Хотя формат ячеек одинаковый. Куйня какая то


всем привет!
 
Ответить
Сообщениесмотрим по 1 строчке: 1 - возвращает 12, 1,1 возвращает 12,7.
Но это уже не важно.
Я понял наполовину что не так:
те цифры, что не верно возвращают ручками перебиваю - и всё нормально получается.
Хотя формат ячеек одинаковый. Куйня какая то

Автор - Svyaz
Дата добавления - 30.11.2023 в 21:05
Svyaz Дата: Четверг, 30.11.2023, 21:17 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

стандартный 2016
точно, 14,2 даже без перезабивки уже верно возвращает а, к примеру, 16,3 - строка съезжает, пока число не перебъёшь.
Что ей в числе не нравится?


всем привет!
 
Ответить
Сообщениеточно, 14,2 даже без перезабивки уже верно возвращает а, к примеру, 16,3 - строка съезжает, пока число не перебъёшь.
Что ей в числе не нравится?

Автор - Svyaz
Дата добавления - 30.11.2023 в 21:17
DrMini Дата: Четверг, 30.11.2023, 21:18 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
ручками перебиваю - и всё нормально получается

Такая же фигня.
Интересно в чём проблема?
Неужели из-за того, что офис пиратский?
Такого раньше не замечал...
 
Ответить
Сообщение
ручками перебиваю - и всё нормально получается

Такая же фигня.
Интересно в чём проблема?
Неужели из-за того, что офис пиратский?
Такого раньше не замечал...

Автор - DrMini
Дата добавления - 30.11.2023 в 21:18
Svyaz Дата: Четверг, 30.11.2023, 21:27 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

стандартный 2016
У меня только офис и лицензионный (:
Главное копирую с формулой (*+0,1) ячейку рабочую, вставляю - и не помогает! Только ручками число менять.
Блин, их у меня очень много, сколько же дней дрочить!!!


всем привет!
 
Ответить
СообщениеУ меня только офис и лицензионный (:
Главное копирую с формулой (*+0,1) ячейку рабочую, вставляю - и не помогает! Только ручками число менять.
Блин, их у меня очень много, сколько же дней дрочить!!!

Автор - Svyaz
Дата добавления - 30.11.2023 в 21:27
i691198 Дата: Четверг, 30.11.2023, 22:13 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 82 ±
Замечаний: 0% ±

У вас какая то проблема с первым столбцом. Я удалил из него данные, по новой ввел в первые четыре строки значения 1; 1,1; 1,2; 1,3 и протянул вниз. Ошибка ушла, проверьте у себя. И еще, измените в формуле ВПР последний параметр на 0 - точное совпадение.
 
Ответить
СообщениеУ вас какая то проблема с первым столбцом. Я удалил из него данные, по новой ввел в первые четыре строки значения 1; 1,1; 1,2; 1,3 и протянул вниз. Ошибка ушла, проверьте у себя. И еще, измените в формуле ВПР последний параметр на 0 - точное совпадение.

Автор - i691198
Дата добавления - 30.11.2023 в 22:13
gling Дата: Четверг, 30.11.2023, 22:22 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2505
Репутация: 668 ±
Замечаний: 0% ±

2010
Блин, их у меня очень много,
Попробуйте выделить столбец A на ленте Данные - Текст по столбцам - Готово, может поможет?


ЯД-41001506838083
 
Ответить
Сообщение
Блин, их у меня очень много,
Попробуйте выделить столбец A на ленте Данные - Текст по столбцам - Готово, может поможет?

Автор - gling
Дата добавления - 30.11.2023 в 22:22
Gustav Дата: Четверг, 30.11.2023, 22:34 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2649
Репутация: 1114 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Замечена пара интересных моментов (играемся на значении 16,3 в строке 155).

Первый момент: изменим в формуле ячейки E155 четвертый параметр с 1 на 0, т.е. на точное совпадение:
Код
=ВПР(D155;$A$2:$B$1392;2;0)

Упс! Формула "сломалась" - #Н/Д. Что это означает? Это означает, что значение 16,3 из ячейки A155 НЕ РАВНО (по каким-то причинам) значению 16,3 из ячейки D155.

Второй момент: откатим изменение формулы по Ctrl+Z. Далее выделим ячейку A155, скопируем ее, выделим ячейку D155 и вставим специальной вставкой "Вставить значение". Теперь формула в E155 считает правильно. Если опять поменяем параметр с 1 на 0, то в этот раз тоже считает правильно.

Конкретные выводы делать не буду - у меня их нет, рекомендую каждому подумать самостоятельно.

В качестве "пилюли" работает, вроде бы, такой финт. В свободную колонку, например, H, вводим формулу:
Код
=ОКРУГЛ(A155;1)

Результат копируем и вставляем "только значением" в A155 - починилось. Так, можно всю колонку A заменить на округленные значения.


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеЗамечена пара интересных моментов (играемся на значении 16,3 в строке 155).

Первый момент: изменим в формуле ячейки E155 четвертый параметр с 1 на 0, т.е. на точное совпадение:
Код
=ВПР(D155;$A$2:$B$1392;2;0)

Упс! Формула "сломалась" - #Н/Д. Что это означает? Это означает, что значение 16,3 из ячейки A155 НЕ РАВНО (по каким-то причинам) значению 16,3 из ячейки D155.

Второй момент: откатим изменение формулы по Ctrl+Z. Далее выделим ячейку A155, скопируем ее, выделим ячейку D155 и вставим специальной вставкой "Вставить значение". Теперь формула в E155 считает правильно. Если опять поменяем параметр с 1 на 0, то в этот раз тоже считает правильно.

Конкретные выводы делать не буду - у меня их нет, рекомендую каждому подумать самостоятельно.

В качестве "пилюли" работает, вроде бы, такой финт. В свободную колонку, например, H, вводим формулу:
Код
=ОКРУГЛ(A155;1)

Результат копируем и вставляем "только значением" в A155 - починилось. Так, можно всю колонку A заменить на округленные значения.

Автор - Gustav
Дата добавления - 30.11.2023 в 22:34
bigor Дата: Пятница, 01.12.2023, 14:45 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
если посмотреть внутрь файла
/row>
<row r="3" spans="1:6" x14ac:dyDescent="0.35">
<c r="A3" s="3">
<v>1.1000000000000001</v>
</c>
<c r="B3" s="3">
<v>12.7</v>
</c>
</row>
<row r="4" spans="1:6" x14ac:dyDescent="0.35">
<c r="A4" s="3">
<v>1.2000000000000002</v>
</c>
<c r="B4" s="3">
<v>13.399999999999999</v>
</c>
</row>
<row r="5" spans="1:6" x14ac:dyDescent="0.35">
<c r="A5" s="3">
<v>1.3000000000000003</v>
</c>
<c r="B5" s="3">
<v>14.099999999999998</v>
</c>
</row>
<row r="6" spans="1:6" x14ac:dyDescent="0.35">
<c r="A6" s="3">
<v>1.4000000000000004</v>
</c>
<c r="B6" s="3">
<v>14.799999999999997</v>
</c>
</row>
<row r="7" spans="1:6" x14ac:dyDescent="0.35">
<c r="A7" s="3">
<v>1.5</v>
</c>
<c r="B7" s="3">
<v>15.499999999999996</v>
</c>
</row>
, становится еще непонятнее, лишние цифры до 4, находятся в 17 разряде после точки, и excel их видеть вообще то не должен, но 1,2 он почему то все равно игнорирует, хотя 1,3 с лишней тройкой обрабатывает нормально


Сообщение отредактировал bigor - Пятница, 01.12.2023, 14:51
 
Ответить
Сообщениеесли посмотреть внутрь файла
/row>
<row r="3" spans="1:6" x14ac:dyDescent="0.35">
<c r="A3" s="3">
<v>1.1000000000000001</v>
</c>
<c r="B3" s="3">
<v>12.7</v>
</c>
</row>
<row r="4" spans="1:6" x14ac:dyDescent="0.35">
<c r="A4" s="3">
<v>1.2000000000000002</v>
</c>
<c r="B4" s="3">
<v>13.399999999999999</v>
</c>
</row>
<row r="5" spans="1:6" x14ac:dyDescent="0.35">
<c r="A5" s="3">
<v>1.3000000000000003</v>
</c>
<c r="B5" s="3">
<v>14.099999999999998</v>
</c>
</row>
<row r="6" spans="1:6" x14ac:dyDescent="0.35">
<c r="A6" s="3">
<v>1.4000000000000004</v>
</c>
<c r="B6" s="3">
<v>14.799999999999997</v>
</c>
</row>
<row r="7" spans="1:6" x14ac:dyDescent="0.35">
<c r="A7" s="3">
<v>1.5</v>
</c>
<c r="B7" s="3">
<v>15.499999999999996</v>
</c>
</row>
, становится еще непонятнее, лишние цифры до 4, находятся в 17 разряде после точки, и excel их видеть вообще то не должен, но 1,2 он почему то все равно игнорирует, хотя 1,3 с лишней тройкой обрабатывает нормально

Автор - bigor
Дата добавления - 01.12.2023 в 14:45
Nic70y Дата: Пятница, 01.12.2023, 17:04 | Сообщение № 11
Группа: Друзья
Ранг: Экселист
Сообщений: 8649
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
Код
=ВПР(E2+0,01;$A$2:$B$1392;2;1)
вдруг правильно


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ВПР(E2+0,01;$A$2:$B$1392;2;1)
вдруг правильно

Автор - Nic70y
Дата добавления - 01.12.2023 в 17:04
DrMini Дата: Пятница, 01.12.2023, 19:53 | Сообщение № 12
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
вдруг правильно

Да правильно если так:
Код
ВПР(E2+0,01;$A$2:$B$1392;2;1)

но вот почему не работает если интервальный просмотр ЛОЖЬ?
И в первом и в Вашем Nic70y, случае?
Подписался на эту тему и вдруг будет объяснение.
[offtop]Может это закинуть в Мозговой Штурм?[/offtop]


Сообщение отредактировал DrMini - Пятница, 01.12.2023, 19:56
 
Ответить
Сообщение
вдруг правильно

Да правильно если так:
Код
ВПР(E2+0,01;$A$2:$B$1392;2;1)

но вот почему не работает если интервальный просмотр ЛОЖЬ?
И в первом и в Вашем Nic70y, случае?
Подписался на эту тему и вдруг будет объяснение.
[offtop]Может это закинуть в Мозговой Штурм?[/offtop]

Автор - DrMini
Дата добавления - 01.12.2023 в 19:53
Nic70y Дата: Пятница, 01.12.2023, 20:46 | Сообщение № 13
Группа: Друзья
Ранг: Экселист
Сообщений: 8649
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
Может это закинуть в Мозговой Штурм?

Михаил, тут не чего штурмовать
но вот почему не работает если интервальный просмотр ЛОЖЬ?

bigor ответил на этот вопрос, только я не пойму чему он удивился*
это не первый случай -
скорее всего эти числа в эксель попали не из эксель и Gustav предложил вариант обэкселить* эти числа.
эксель отображает не всегда, то что есть на самом* деле и это не только эксель
у каждой программы (и не только) свои погрешности.

я никогда не заморачиволся в причине - искал решение -
это следствие отсутствие интернете в те мои давние годы
[p.s.]о ВПР узнал только на форуме)[/p.s.]


ЮMoney 41001841029809
 
Ответить
Сообщение
Может это закинуть в Мозговой Штурм?

Михаил, тут не чего штурмовать
но вот почему не работает если интервальный просмотр ЛОЖЬ?

bigor ответил на этот вопрос, только я не пойму чему он удивился*
это не первый случай -
скорее всего эти числа в эксель попали не из эксель и Gustav предложил вариант обэкселить* эти числа.
эксель отображает не всегда, то что есть на самом* деле и это не только эксель
у каждой программы (и не только) свои погрешности.

я никогда не заморачиволся в причине - искал решение -
это следствие отсутствие интернете в те мои давние годы
[p.s.]о ВПР узнал только на форуме)[/p.s.]

Автор - Nic70y
Дата добавления - 01.12.2023 в 20:46
DrMini Дата: Суббота, 02.12.2023, 06:04 | Сообщение № 14
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
скорее всего эти числа в эксель попали не из эксель

Попробовал заполнить оба столбца через прогрессию

так же "ошибается"
я никогда не заморачиволся в причине - искал решение

Код
=СУММПРОИЗВ(($A$1:$A$1392=D1)*$B$1:$B$1392)

у меня вот так заработало.
тут не чего штурмовать

После Вашего объяснения полностью соглашусь - погорячился.
:D
К сообщению приложен файл: 6407063.png (20.5 Kb) · vpr_rabotaet_nekorrektno.xlsx (31.2 Kb)
 
Ответить
Сообщение
скорее всего эти числа в эксель попали не из эксель

Попробовал заполнить оба столбца через прогрессию

так же "ошибается"
я никогда не заморачиволся в причине - искал решение

Код
=СУММПРОИЗВ(($A$1:$A$1392=D1)*$B$1:$B$1392)

у меня вот так заработало.
тут не чего штурмовать

После Вашего объяснения полностью соглашусь - погорячился.
:D

Автор - DrMini
Дата добавления - 02.12.2023 в 06:04
Svyaz Дата: Суббота, 02.12.2023, 09:34 | Сообщение № 15
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

стандартный 2016
Спасибо всем БОЛЬШОЕ!!!!

Выбрал вариант:
В качестве "пилюли" работает, вроде бы, такой финт. В свободную колонку, например, H, вводим формулу:

=ОКРУГЛ(A155;1)


всем привет!
 
Ответить
СообщениеСпасибо всем БОЛЬШОЕ!!!!

Выбрал вариант:
В качестве "пилюли" работает, вроде бы, такой финт. В свободную колонку, например, H, вводим формулу:

=ОКРУГЛ(A155;1)

Автор - Svyaz
Дата добавления - 02.12.2023 в 09:34
DrMini Дата: Суббота, 02.12.2023, 10:26 | Сообщение № 16
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Так, можно всю колонку A заменить на округленные значения.

Паразитируя на решении которое предложил Gustav, можно и так:
Код
=ВПР(E2;ОКРУГЛ(A2:B1392;1);2;)

[p.s.]всё не проверял, но те, что не работали - работают.[/p.s.]
 
Ответить
Сообщение
Так, можно всю колонку A заменить на округленные значения.

Паразитируя на решении которое предложил Gustav, можно и так:
Код
=ВПР(E2;ОКРУГЛ(A2:B1392;1);2;)

[p.s.]всё не проверял, но те, что не работали - работают.[/p.s.]

Автор - DrMini
Дата добавления - 02.12.2023 в 10:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР работает не корректно (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!