Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование нескольких значений ВПР с одинаковым критерием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование нескольких значений ВПР с одинаковым критерием (Формулы/Formulas)
Суммирование нескольких значений ВПР с одинаковым критерием
DarkDark Дата: Понедельник, 04.12.2023, 10:35 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день, прощу помощи в настройки формулы для суммирования нескольких значений ВПР с одинаковым критерием и в некоторых случаях с разным если это возможно. Изначальных файл очень кривой, будет выгрузка из 1С, а конечная таблица будет как в примере.
К сообщению приложен файл: 18_na_01_04_2023_novaja_7_iz_1.xlsx (13.5 Kb)
 
Ответить
СообщениеДобрый день, прощу помощи в настройки формулы для суммирования нескольких значений ВПР с одинаковым критерием и в некоторых случаях с разным если это возможно. Изначальных файл очень кривой, будет выгрузка из 1С, а конечная таблица будет как в примере.

Автор - DarkDark
Дата добавления - 04.12.2023 в 10:35
alexa1965 Дата: Понедельник, 04.12.2023, 10:58 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 341
Репутация: 55 ±
Замечаний: 0% ±

2003> 2019 >2016
Добрый день! А почему не СУММЕСЛИ? например для ячейки Е14
Код
=СУММЕСЛИ(A5:A20;"226 стац";B5:B20)+СУММЕСЛИ(A5:A20;"227 стац";B5:B20)


Главное не быть балабастиком
 
Ответить
СообщениеДобрый день! А почему не СУММЕСЛИ? например для ячейки Е14
Код
=СУММЕСЛИ(A5:A20;"226 стац";B5:B20)+СУММЕСЛИ(A5:A20;"227 стац";B5:B20)

Автор - alexa1965
Дата добавления - 04.12.2023 в 10:58
elovkov Дата: Понедельник, 04.12.2023, 11:09 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
А почему не СУММЕСЛИ?

Чутка доработаю, это если все номера трехзначные и не больше двух номеров в условии, для Е11 и протянуть вниз:
Код
=СУММЕСЛИ($A$5:$A$20;ПСТР(D11;1;3)&" "&$E$10;$B$5:$B$20)+ЕСЛИ(ДЛСТР(D11)>3;СУММЕСЛИ($A$5:$A$20;ПРАВБ(D11;3)&" "&$E$10;$B$5:$B$20);0)

Выполняются все исходные пожелания)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Понедельник, 04.12.2023, 11:09
 
Ответить
Сообщение
А почему не СУММЕСЛИ?

Чутка доработаю, это если все номера трехзначные и не больше двух номеров в условии, для Е11 и протянуть вниз:
Код
=СУММЕСЛИ($A$5:$A$20;ПСТР(D11;1;3)&" "&$E$10;$B$5:$B$20)+ЕСЛИ(ДЛСТР(D11)>3;СУММЕСЛИ($A$5:$A$20;ПРАВБ(D11;3)&" "&$E$10;$B$5:$B$20);0)

Выполняются все исходные пожелания)

Автор - elovkov
Дата добавления - 04.12.2023 в 11:09
Nic70y Дата: Понедельник, 04.12.2023, 11:33 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($A$5:$A$20&0;ПОДСТАВИТЬ($D11;",";" "&E$10&0)&" "&E$10&0))*$B$5:$B$20)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК($A$5:$A$20&0;ПОДСТАВИТЬ($D11;",";" "&E$10&0)&" "&E$10&0))*$B$5:$B$20)

Автор - Nic70y
Дата добавления - 04.12.2023 в 11:33
DarkDark Дата: Понедельник, 04.12.2023, 13:07 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем огромное спасибо за варианты.
 
Ответить
СообщениеВсем огромное спасибо за варианты.

Автор - DarkDark
Дата добавления - 04.12.2023 в 13:07
elovkov Дата: Понедельник, 04.12.2023, 13:37 | Сообщение № 6
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
Nic70y, а зачем &0 вводится? Вроде и без него работает


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеNic70y, а зачем &0 вводится? Вроде и без него работает

Автор - elovkov
Дата добавления - 04.12.2023 в 13:37
Nic70y Дата: Понедельник, 04.12.2023, 13:42 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 8650
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
зачем &0
ПОИСК без 0 найдет стац в стацзам,
с ПОИСК будет считать по любому кол-ву введенных в D


ЮMoney 41001841029809
 
Ответить
Сообщение
зачем &0
ПОИСК без 0 найдет стац в стацзам,
с ПОИСК будет считать по любому кол-ву введенных в D

Автор - Nic70y
Дата добавления - 04.12.2023 в 13:42
elovkov Дата: Понедельник, 04.12.2023, 14:06 | Сообщение № 8
Группа: Друзья
Ранг: Обитатель
Сообщений: 364
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
Ааа, это сразу для всех столбцов, понял тогда


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеАаа, это сразу для всех столбцов, понял тогда

Автор - elovkov
Дата добавления - 04.12.2023 в 14:06
DarkDark Дата: Среда, 06.12.2023, 13:36 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
А подскажите пожалуйста еще один момент, как изменится формула если например не нужно прицеплять к 223 "стац" а просто собрать все суммы значения 223 без привязки "стац"
К сообщению приложен файл: 2996523.xlsx (8.3 Kb)
 
Ответить
СообщениеА подскажите пожалуйста еще один момент, как изменится формула если например не нужно прицеплять к 223 "стац" а просто собрать все суммы значения 223 без привязки "стац"

Автор - DarkDark
Дата добавления - 06.12.2023 в 13:36
DrMini Дата: Среда, 06.12.2023, 13:59 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
просто собрать все суммы значения 223

Код
=СУММПРОИЗВ(($A$1:$A$10=M14)*$B$1:$B$10)
 
Ответить
Сообщение
просто собрать все суммы значения 223

Код
=СУММПРОИЗВ(($A$1:$A$10=M14)*$B$1:$B$10)

Автор - DrMini
Дата добавления - 06.12.2023 в 13:59
DrMini Дата: Среда, 06.12.2023, 14:01 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Или так:
Код
=СУММЕСЛИ($A$1:$A$10;M14;$B$1:$B$10)
К сообщению приложен файл: 6771512.xlsx (9.4 Kb)
 
Ответить
СообщениеИли так:
Код
=СУММЕСЛИ($A$1:$A$10;M14;$B$1:$B$10)

Автор - DrMini
Дата добавления - 06.12.2023 в 14:01
DarkDark Дата: Среда, 06.12.2023, 14:09 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
DrMini, благодарю
 
Ответить
СообщениеDrMini, благодарю

Автор - DarkDark
Дата добавления - 06.12.2023 в 14:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование нескольких значений ВПР с одинаковым критерием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!