Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ранжирование с пропуском ячеек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранжирование с пропуском ячеек (Формулы/Formulas)
Ранжирование с пропуском ячеек
Tati_37 Дата: Среда, 06.12.2023, 20:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
Доброго времени суток. Есть файл с прогнозными данными. Файл во вложении. Необходимо в одном столбике проранжировать только регионы и только магазины.
К сообщению приложен файл: rang.xlsx (6.4 Kb)
 
Ответить
СообщениеДоброго времени суток. Есть файл с прогнозными данными. Файл во вложении. Необходимо в одном столбике проранжировать только регионы и только магазины.

Автор - Tati_37
Дата добавления - 06.12.2023 в 20:42
bigor Дата: Среда, 06.12.2023, 22:52 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
Tati_37, файл пустой
 
Ответить
СообщениеTati_37, файл пустой

Автор - bigor
Дата добавления - 06.12.2023 в 22:52
Tati_37 Дата: Среда, 06.12.2023, 23:16 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
Извиняюсь...
К сообщению приложен файл: 7695879.xlsx (10.7 Kb)
 
Ответить
СообщениеИзвиняюсь...

Автор - Tati_37
Дата добавления - 06.12.2023 в 23:16
bigor Дата: Четверг, 07.12.2023, 09:58 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
Tati_37, для магазинов
Код
=IF(LEFT(A4;2)="Ма";(RANK(B4;IF(LEFT($A$4:$A$36;2)="Ма";$B$4:$B$36;0)));"")
массивная. для регионов, заменить = на <> (если не будет Магадана :) , иначе в left брать больше букв)
 
Ответить
СообщениеTati_37, для магазинов
Код
=IF(LEFT(A4;2)="Ма";(RANK(B4;IF(LEFT($A$4:$A$36;2)="Ма";$B$4:$B$36;0)));"")
массивная. для регионов, заменить = на <> (если не будет Магадана :) , иначе в left брать больше букв)

Автор - bigor
Дата добавления - 07.12.2023 в 09:58
Tati_37 Дата: Пятница, 08.12.2023, 00:13 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
bigor, формула внесена, но что-то мною внесено неправильно, получилась какая-то ерунда, Где-то не догоняю, как можно исправить?
 
Ответить
Сообщениеbigor, формула внесена, но что-то мною внесено неправильно, получилась какая-то ерунда, Где-то не догоняю, как можно исправить?

Автор - Tati_37
Дата добавления - 08.12.2023 в 00:13
bigor Дата: Пятница, 08.12.2023, 10:02 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
Tati_37, конечно хотелось бы видеть, что за ерунда у вас получилась. Но похоже excel не работает с массивом во втором параметре ранг() :(

поэтому попробуем без него
для магазинов
Код
=ЕСЛИ(ЛЕВСИМВ($A$4:$A$35;5)="Магаз";СУММПРОИЗВ((ЛЕВСИМВ($A$4:$A$35;5)="Магаз")*($B$4:$B$35>B4))+1;"")

для регионов
Код
=ЕСЛИ(ЛЕВСИМВ($A$4:$A$35;5)<>"Магаз";СУММПРОИЗВ((ЛЕВСИМВ($A$4:$A$35;5)<>"Магаз")*($B$4:$B$35>B4))+1;"")


Сообщение отредактировал bigor - Пятница, 08.12.2023, 14:09
 
Ответить
СообщениеTati_37, конечно хотелось бы видеть, что за ерунда у вас получилась. Но похоже excel не работает с массивом во втором параметре ранг() :(

поэтому попробуем без него
для магазинов
Код
=ЕСЛИ(ЛЕВСИМВ($A$4:$A$35;5)="Магаз";СУММПРОИЗВ((ЛЕВСИМВ($A$4:$A$35;5)="Магаз")*($B$4:$B$35>B4))+1;"")

для регионов
Код
=ЕСЛИ(ЛЕВСИМВ($A$4:$A$35;5)<>"Магаз";СУММПРОИЗВ((ЛЕВСИМВ($A$4:$A$35;5)<>"Магаз")*($B$4:$B$35>B4))+1;"")

Автор - bigor
Дата добавления - 08.12.2023 в 10:02
Tati_37 Дата: Суббота, 09.12.2023, 20:26 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
bigor, забыла прикрепить файл.
По второму варианту вроде как получилось, но ранжирование идет с пропуском - т.е. по примеру получилось среди регионов 2 вторых места (нет третьего), а по магазинам нет например 1, зато есть несколько вторых...
К сообщению приложен файл: 5773266.xlsx (16.8 Kb)
 
Ответить
Сообщениеbigor, забыла прикрепить файл.
По второму варианту вроде как получилось, но ранжирование идет с пропуском - т.е. по примеру получилось среди регионов 2 вторых места (нет третьего), а по магазинам нет например 1, зато есть несколько вторых...

Автор - Tati_37
Дата добавления - 09.12.2023 в 20:26
bigor Дата: Воскресенье, 10.12.2023, 16:49 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
Tati_37, Вы неверно перенесли формулу в свою таблицу. Смотрите картинку и сравните с вашим файлом
К сообщению приложен файл: 7277592.png (177.1 Kb)


Сообщение отредактировал bigor - Воскресенье, 10.12.2023, 16:49
 
Ответить
СообщениеTati_37, Вы неверно перенесли формулу в свою таблицу. Смотрите картинку и сравните с вашим файлом

Автор - bigor
Дата добавления - 10.12.2023 в 16:49
Tati_37 Дата: Воскресенье, 10.12.2023, 23:09 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 40% ±

Excel 2019
bigor, Ура! Получилось! СПАСИБО!!!
 
Ответить
Сообщениеbigor, Ура! Получилось! СПАСИБО!!!

Автор - Tati_37
Дата добавления - 10.12.2023 в 23:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранжирование с пропуском ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!