Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как добавить логику дат и високосного года - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как добавить логику дат и високосного года (Формулы/Formulas)
Как добавить логику дат и високосного года
amirovadi Дата: Четверг, 21.12.2023, 06:21 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

2016
Добрый день уважаемые гуру Excel!
Коллега поставила задачу, 2 день бьюсь. Где-то нашла файл подходящий и вот в нем нет учета високосного года в датах.
При выборе февраля месяца на листе "Входные данные" не появляется дата 29 февраля на листе "Активность менеджеров".
Да я понимаю, что нет привязки к дням недели и прочему. Но уже чайник закипает.
Помогите пожалуйста.
Нужно я так понимаю добавить сравнение годов на високосный или нет и добавить в формулу сцепку или логику на листе "Активность менеджеров" в ячейке дат.
К сообщению приложен файл: tipovoj_otchet_po_aktivnosti_k.xlsx (219.5 Kb)
 
Ответить
СообщениеДобрый день уважаемые гуру Excel!
Коллега поставила задачу, 2 день бьюсь. Где-то нашла файл подходящий и вот в нем нет учета високосного года в датах.
При выборе февраля месяца на листе "Входные данные" не появляется дата 29 февраля на листе "Активность менеджеров".
Да я понимаю, что нет привязки к дням недели и прочему. Но уже чайник закипает.
Помогите пожалуйста.
Нужно я так понимаю добавить сравнение годов на високосный или нет и добавить в формулу сцепку или логику на листе "Активность менеджеров" в ячейке дат.

Автор - amirovadi
Дата добавления - 21.12.2023 в 06:21
Nic70y Дата: Четверг, 21.12.2023, 08:10 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8649
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
amirovadi, первое число выбранного месяца у Вас текст - число месяц без года,
при прибавлении 1 получается уже дата, но так, как в ней нет года - эксель присваивает текущий год, он не високосный
добавить сравнение годов на високосный или нет
просто добавить в дату год


ЮMoney 41001841029809
 
Ответить
Сообщениеamirovadi, первое число выбранного месяца у Вас текст - число месяц без года,
при прибавлении 1 получается уже дата, но так, как в ней нет года - эксель присваивает текущий год, он не високосный
добавить сравнение годов на високосный или нет
просто добавить в дату год

Автор - Nic70y
Дата добавления - 21.12.2023 в 08:10
amirovadi Дата: Четверг, 21.12.2023, 09:40 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

2016
но так, как в ней нет года - эксель присваивает текущий год, он не високосный


Логику я понял, СПАСИБО! Но...
Добрый человек направьте на путь истинный. Уже и так пытался добавить и сяк, не получается.
 
Ответить
Сообщение
но так, как в ней нет года - эксель присваивает текущий год, он не високосный


Логику я понял, СПАСИБО! Но...
Добрый человек направьте на путь истинный. Уже и так пытался добавить и сяк, не получается.

Автор - amirovadi
Дата добавления - 21.12.2023 в 09:40
amirovadi Дата: Четверг, 21.12.2023, 09:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

2016
уже и так не помогает =ЕСЛИОШИБКА(ЕСЛИ(МЕСЯЦ(BB2+1)='входные данные'!$D$50; ЕСЛИ(ДЕНЬ(BB2+1)=ДЕНЬ(BB2); ГОД(BB2)+1; BB2+1); ""); "")
 
Ответить
Сообщениеуже и так не помогает =ЕСЛИОШИБКА(ЕСЛИ(МЕСЯЦ(BB2+1)='входные данные'!$D$50; ЕСЛИ(ДЕНЬ(BB2+1)=ДЕНЬ(BB2); ГОД(BB2)+1; BB2+1); ""); "")

Автор - amirovadi
Дата добавления - 21.12.2023 в 09:48
Nic70y Дата: Четверг, 21.12.2023, 10:13 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 8649
Репутация: 2207 ±
Замечаний: 0% ±

Excel 2010
amirovadi, особо во все формулы не вникал,
см. файл.

устроит?
К сообщению приложен файл: 24.xlsx (233.7 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеamirovadi, особо во все формулы не вникал,
см. файл.

устроит?

Автор - Nic70y
Дата добавления - 21.12.2023 в 10:13
amirovadi Дата: Четверг, 21.12.2023, 10:50 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

2016
устроит?


А ларчик просто открывался!
ОГРОМНОЕ СПАСИБО!!!
hands
 
Ответить
Сообщение
устроит?


А ларчик просто открывался!
ОГРОМНОЕ СПАСИБО!!!
hands

Автор - amirovadi
Дата добавления - 21.12.2023 в 10:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как добавить логику дат и високосного года (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!