Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как подсчитать количество строк отфильтровывая значения? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подсчитать количество строк отфильтровывая значения? (Формулы/Formulas)
Как подсчитать количество строк отфильтровывая значения?
technoir Дата: Воскресенье, 24.12.2023, 19:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день!

Я в Excel пользователь очень начального уровня, поэтому требуется помощь знатоков!
Файл прикрепляю.

Имеется похожая таблица как на Лист2.
На Лист1 надо подсчитывать формулами количество строк отфильтровывая значения на Лист2.
Допустим надо подсчитать количество строк с категорией "Категория 1" в столбце A и риском Риск1 в столбцах C,D,E

Я попытался сделать через СЧЕТЕСЛИМН,но получил ЗНАЧ. Как я понял надо чтобы размеры диапазонов совпадали, но у меня в одном условии 1 столбец, а в другом 3.
Возможно здесь можно обойтись без СЧЕТЕСЛИМН?

Подскажите пожалуйста как правильно сделать? Спасибо заранее!
К сообщению приложен файл: text_excel1.xlsx (10.4 Kb)


Сообщение отредактировал technoir - Воскресенье, 24.12.2023, 19:32
 
Ответить
СообщениеДобрый день!

Я в Excel пользователь очень начального уровня, поэтому требуется помощь знатоков!
Файл прикрепляю.

Имеется похожая таблица как на Лист2.
На Лист1 надо подсчитывать формулами количество строк отфильтровывая значения на Лист2.
Допустим надо подсчитать количество строк с категорией "Категория 1" в столбце A и риском Риск1 в столбцах C,D,E

Я попытался сделать через СЧЕТЕСЛИМН,но получил ЗНАЧ. Как я понял надо чтобы размеры диапазонов совпадали, но у меня в одном условии 1 столбец, а в другом 3.
Возможно здесь можно обойтись без СЧЕТЕСЛИМН?

Подскажите пожалуйста как правильно сделать? Спасибо заранее!

Автор - technoir
Дата добавления - 24.12.2023 в 19:28
bigor Дата: Воскресенье, 24.12.2023, 19:32 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
technoir, здравствуйте. Нет файла
 
Ответить
Сообщениеtechnoir, здравствуйте. Нет файла

Автор - bigor
Дата добавления - 24.12.2023 в 19:32
technoir Дата: Воскресенье, 24.12.2023, 19:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
bigor, Добрый день! Извиняюсь, прикрепил снова
 
Ответить
Сообщениеbigor, Добрый день! Извиняюсь, прикрепил снова

Автор - technoir
Дата добавления - 24.12.2023 в 19:33
bigor Дата: Воскресенье, 24.12.2023, 20:11 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
technoir,
Код
=SUMPRODUCT(($Лист2!A2:A7=B1)*($Лист2!C2:E7=A2))
 
Ответить
Сообщениеtechnoir,
Код
=SUMPRODUCT(($Лист2!A2:A7=B1)*($Лист2!C2:E7=A2))

Автор - bigor
Дата добавления - 24.12.2023 в 20:11
technoir Дата: Воскресенье, 24.12.2023, 20:22 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
bigor, Ошибка

Можно в двух словах обьяснить что делает формула?

Спасибо заранее
К сообщению приложен файл: 8740992.png (14.1 Kb)
 
Ответить
Сообщениеbigor, Ошибка

Можно в двух словах обьяснить что делает формула?

Спасибо заранее

Автор - technoir
Дата добавления - 24.12.2023 в 20:22
_Boroda_ Дата: Воскресенье, 24.12.2023, 20:27 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16627
Репутация: 6470 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Формула правильная. Вы приложите файл, в котором она, формула, ошибку дает. Тогда можно будет уже что-то конкретное сказать


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФормула правильная. Вы приложите файл, в котором она, формула, ошибку дает. Тогда можно будет уже что-то конкретное сказать

Автор - _Boroda_
Дата добавления - 24.12.2023 в 20:27
cmivadwot Дата: Воскресенье, 24.12.2023, 21:49 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 409
Репутация: 83 ±
Замечаний: 0% ±

365
у меня тоже так же ошибку выдает... а вот так сработало
Код
=СУММПРОИЗВ((Лист2!$A$2:$A$7=B$1)*(Лист2!$C$2:$E$7=$A2))
не вникал правильно работает или нет..
К сообщению приложен файл: 3964093.xlsx (11.2 Kb)
 
Ответить
Сообщениеу меня тоже так же ошибку выдает... а вот так сработало
Код
=СУММПРОИЗВ((Лист2!$A$2:$A$7=B$1)*(Лист2!$C$2:$E$7=$A2))
не вникал правильно работает или нет..

Автор - cmivadwot
Дата добавления - 24.12.2023 в 21:49
bigor Дата: Понедельник, 25.12.2023, 08:46 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 195 ±
Замечаний: 0% ±

нет
technoir, уберите знаки доллара перед названием листов. Для перетаскивания по ячейкам лучше использовать ссылки как у cmivadwot, В своей я просто скопировал из вашей формулы. Она считает количество ячеек в диапазоне Лист2!$C$2:$E$7 равных $A2, находящихся в строках для которых в столбце А равны B$1
 
Ответить
Сообщениеtechnoir, уберите знаки доллара перед названием листов. Для перетаскивания по ячейкам лучше использовать ссылки как у cmivadwot, В своей я просто скопировал из вашей формулы. Она считает количество ячеек в диапазоне Лист2!$C$2:$E$7 равных $A2, находящихся в строках для которых в столбце А равны B$1

Автор - bigor
Дата добавления - 25.12.2023 в 08:46
technoir Дата: Понедельник, 25.12.2023, 17:59 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
bigor, Спасибо большое! Все отлично!
 
Ответить
Сообщениеbigor, Спасибо большое! Все отлично!

Автор - technoir
Дата добавления - 25.12.2023 в 17:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подсчитать количество строк отфильтровывая значения? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!