Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР не находит дату - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР не находит дату
ВПР не находит дату
praitex123 Дата: Понедельник, 08.01.2024, 15:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Всем привет!
Всех с праздниками.
С нового года перестала работать формула ВПР. До НГ вся нумерация проставлялась, теперь #НД...
Не могу понять причину сбоя.
Буду очень признателен за помощь. Файл прикрепил.
К сообщению приложен файл: schjot_ts.xlsx (16.1 Kb)
 
Ответить
СообщениеВсем привет!
Всех с праздниками.
С нового года перестала работать формула ВПР. До НГ вся нумерация проставлялась, теперь #НД...
Не могу понять причину сбоя.
Буду очень признателен за помощь. Файл прикрепил.

Автор - praitex123
Дата добавления - 08.01.2024 в 15:04
Pelena Дата: Понедельник, 08.01.2024, 16:39 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19137
Репутация: 4409 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
Дело в том, что в столбце АР месяц задаётся двумя цифрами, для января 01.01.2024. А формула даёт одну цифру 01.1.2024
Можно так
Код
=ВПР("01."&ТЕКСТ(МЕСЯЦ($AO$1);"00")&"."&ГОД($AO$1);$AP$1:$AQ$27;2;0)

А если даты в столбце AP сделать датами, а не текстом, то можно короче
Код
=ВПР(КОНМЕСЯЦА($AO$1;-1)+1;$AP$1:$AQ$27;2;0)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Дело в том, что в столбце АР месяц задаётся двумя цифрами, для января 01.01.2024. А формула даёт одну цифру 01.1.2024
Можно так
Код
=ВПР("01."&ТЕКСТ(МЕСЯЦ($AO$1);"00")&"."&ГОД($AO$1);$AP$1:$AQ$27;2;0)

А если даты в столбце AP сделать датами, а не текстом, то можно короче
Код
=ВПР(КОНМЕСЯЦА($AO$1;-1)+1;$AP$1:$AQ$27;2;0)

Автор - Pelena
Дата добавления - 08.01.2024 в 16:39
Gustav Дата: Понедельник, 08.01.2024, 17:41 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2649
Репутация: 1114 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Можно так еще:
Код
=ВПР(ТЕКСТ($AO$1;"\0\1.ММ.ГГГ");$AP$1:$AQ$27;2;0)
Трёх "Г" уже хватает для полного значения года.

Либо совсем коротенькая формула массива (ввод по Ctrl+Shift+Enter):
Код
=ВПР($AO$1;--$AP$1:$AQ$27;2)


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Понедельник, 08.01.2024, 17:48
 
Ответить
СообщениеМожно так еще:
Код
=ВПР(ТЕКСТ($AO$1;"\0\1.ММ.ГГГ");$AP$1:$AQ$27;2;0)
Трёх "Г" уже хватает для полного значения года.

Либо совсем коротенькая формула массива (ввод по Ctrl+Shift+Enter):
Код
=ВПР($AO$1;--$AP$1:$AQ$27;2)

Автор - Gustav
Дата добавления - 08.01.2024 в 17:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР не находит дату
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!