Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Распределение данных по столбцам в csv-файле - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение данных по столбцам в csv-файле (Формулы/Formulas)
Распределение данных по столбцам в csv-файле
Dalm Дата: Вторник, 05.03.2024, 06:31 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день.
помогите разобраться с вопросом.
Есть csv-файл, в котором табличные данные записаны в одну строку и разделены запятой.
То есть все данные записаны в один столбец А
Как формулой - разложить из него данные по столбцам таблицы (для построения графика) ?
К сообщению приложен файл: 7803261.rar (0.8 Kb)
 
Ответить
СообщениеДобрый день.
помогите разобраться с вопросом.
Есть csv-файл, в котором табличные данные записаны в одну строку и разделены запятой.
То есть все данные записаны в один столбец А
Как формулой - разложить из него данные по столбцам таблицы (для построения графика) ?

Автор - Dalm
Дата добавления - 05.03.2024 в 06:31
and_evg Дата: Вторник, 05.03.2024, 06:42 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 452
Репутация: 78 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Разбить по столбцам, разделитель запятая, а потом в нужных столбцах точку заменить на запятую
 
Ответить
СообщениеДобрый день.
Разбить по столбцам, разделитель запятая, а потом в нужных столбцах точку заменить на запятую

Автор - and_evg
Дата добавления - 05.03.2024 в 06:42
Dalm Дата: Вторник, 05.03.2024, 07:07 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
and_evg, я спрашивал про формулу.
 
Ответить
Сообщениеand_evg, я спрашивал про формулу.

Автор - Dalm
Дата добавления - 05.03.2024 в 07:07
Pelena Дата: Вторник, 05.03.2024, 07:49 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 19182
Репутация: 4420 ±
Замечаний: ±

Excel 365 & Mac Excel
спрашивал про формулу

для 2019 должна подойти
Код
=ЕСЛИОШИБКА(--ТЕКСТРАЗД(A1;",");--ПОДСТАВИТЬ(ТЕКСТРАЗД(A1;",");".";","))

для более старых версий
Код
=ЕСЛИОШИБКА(--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($A1;",";ПОВТОР(" ";100));100*СТОЛБЕЦ(A:A)-99;99));--ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($A1;",";ПОВТОР(" ";100));100*СТОЛБЕЦ(A:A)-99;99));".";","))
К сообщению приложен файл: 0300506.csv (6.6 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
спрашивал про формулу

для 2019 должна подойти
Код
=ЕСЛИОШИБКА(--ТЕКСТРАЗД(A1;",");--ПОДСТАВИТЬ(ТЕКСТРАЗД(A1;",");".";","))

для более старых версий
Код
=ЕСЛИОШИБКА(--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($A1;",";ПОВТОР(" ";100));100*СТОЛБЕЦ(A:A)-99;99));--ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ($A1;",";ПОВТОР(" ";100));100*СТОЛБЕЦ(A:A)-99;99));".";","))

Автор - Pelena
Дата добавления - 05.03.2024 в 07:49
Dalm Дата: Вторник, 05.03.2024, 11:30 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, спасибо, но куда это ставить ?
Формат csv вообще не сохраняет формулы.

Вы можете приложить xls файл с этой формулой ?
 
Ответить
СообщениеPelena, спасибо, но куда это ставить ?
Формат csv вообще не сохраняет формулы.

Вы можете приложить xls файл с этой формулой ?

Автор - Dalm
Дата добавления - 05.03.2024 в 11:30
Pelena Дата: Вторник, 05.03.2024, 11:46 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 19182
Репутация: 4420 ±
Замечаний: ±

Excel 365 & Mac Excel
сорри, не обратила внимание, какой файл прицепился
К сообщению приложен файл: 111.xlsx (19.2 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщениесорри, не обратила внимание, какой файл прицепился

Автор - Pelena
Дата добавления - 05.03.2024 в 11:46
Dalm Дата: Вторник, 05.03.2024, 20:12 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, спасибо
 
Ответить
СообщениеPelena, спасибо

Автор - Dalm
Дата добавления - 05.03.2024 в 20:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение данных по столбцам в csv-файле (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!