Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выбор определенных позиций во интервалам даты и времени - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор определенных позиций во интервалам даты и времени (Формулы/Formulas)
выбор определенных позиций во интервалам даты и времени
aid4724 Дата: Понедельник, 11.03.2024, 17:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2010
Доброго дня, прошу помощи от знающих людей.
Мне необходимо сделать выборку товарных позиций за исключением некоторых из них в определенный интервал времени по дням.
То есть необходимо суммировать количество проданных товаров с 9:00 одного дня до 9:00 следующего, при этом исключить товары находящиеся в отдельном списке которые не нужно учитывать.
Выбор между датами освоил, но никак не получается впихнуть время.
При этом месяц и год в формуле должен меняться ссылаясь на ячейку в которой будет указываться за какой месяц выгрузка массива данных.
За ранее благодарю.
К сообщению приложен файл: 6718051.xlsx (57.7 Kb)
 
Ответить
СообщениеДоброго дня, прошу помощи от знающих людей.
Мне необходимо сделать выборку товарных позиций за исключением некоторых из них в определенный интервал времени по дням.
То есть необходимо суммировать количество проданных товаров с 9:00 одного дня до 9:00 следующего, при этом исключить товары находящиеся в отдельном списке которые не нужно учитывать.
Выбор между датами освоил, но никак не получается впихнуть время.
При этом месяц и год в формуле должен меняться ссылаясь на ячейку в которой будет указываться за какой месяц выгрузка массива данных.
За ранее благодарю.

Автор - aid4724
Дата добавления - 11.03.2024 в 17:56
AlexM Дата: Понедельник, 11.03.2024, 19:17 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4490
Репутация: 1115 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММЕСЛИМН(E5:E22;B5:B22;">="&B2;B5:B22;"<="&B3;C5:C22;"<>"&N5;C5:C22;"<>"&N6)
К сообщению приложен файл: 6718051_1.xlsx (56.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММЕСЛИМН(E5:E22;B5:B22;">="&B2;B5:B22;"<="&B3;C5:C22;"<>"&N5;C5:C22;"<>"&N6)

Автор - AlexM
Дата добавления - 11.03.2024 в 19:17
aid4724 Дата: Вторник, 12.03.2024, 06:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2010
AlexM, не совсем та меня поняли.
пРАВЕЕ основной таблицы есть даты месяца, под каждой датой нужно рассчитать сколько услуг было оказано в каждый из дней месяца(для примера я указал несколько дат с 15 по 20 февраля. пРИ ЭТОМ В КАЖДУЮ ИЗ ДАТ НУЖНО ИСКЛЮЧИТЬ товары таблички под названием исключить. сейчас там две позиции.
и еще , при выгрузке данных за следующий месяц, формулы диапазона дат тоде должны автоматически поменяться
 
Ответить
СообщениеAlexM, не совсем та меня поняли.
пРАВЕЕ основной таблицы есть даты месяца, под каждой датой нужно рассчитать сколько услуг было оказано в каждый из дней месяца(для примера я указал несколько дат с 15 по 20 февраля. пРИ ЭТОМ В КАЖДУЮ ИЗ ДАТ НУЖНО ИСКЛЮЧИТЬ товары таблички под названием исключить. сейчас там две позиции.
и еще , при выгрузке данных за следующий месяц, формулы диапазона дат тоде должны автоматически поменяться

Автор - aid4724
Дата добавления - 12.03.2024 в 06:51
AlexM Дата: Вторник, 12.03.2024, 11:01 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4490
Репутация: 1115 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММЕСЛИМН($E5:$E99;$B5:$B99;">="&I12+9/24;$B5:$B99;"<="&I12+1+9/24;$C5:$C99;"<>"&$N5;$C5:$C99;"<>"&$N6)
К сообщению приложен файл: 6718051_2.xlsx (56.2 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММЕСЛИМН($E5:$E99;$B5:$B99;">="&I12+9/24;$B5:$B99;"<="&I12+1+9/24;$C5:$C99;"<>"&$N5;$C5:$C99;"<>"&$N6)

Автор - AlexM
Дата добавления - 12.03.2024 в 11:01
aid4724 Дата: Вторник, 12.03.2024, 17:37 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2010
AlexM, спасибо!
 
Ответить
СообщениеAlexM, спасибо!

Автор - aid4724
Дата добавления - 12.03.2024 в 17:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор определенных позиций во интервалам даты и времени (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!