Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула для сортировки данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
формула для сортировки данных
dubinaksenya Дата: Понедельник, 11.03.2024, 23:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2023
Привет,
подскажите. пожалуйста, во вкладке итог в столбцы вес и объем нужно подтянуть данные со второй вкладки из столбца С. Грубо говоря, чтобы подтягивались данные ко всем артикулам их вес и объем из каталога.
Понимаю, что надо использовать ВПР, но как привязаться отдельно к каждому измерению не очень понятно.
К сообщению приложен файл: vopros.xlsx (13.1 Kb)
 
Ответить
СообщениеПривет,
подскажите. пожалуйста, во вкладке итог в столбцы вес и объем нужно подтянуть данные со второй вкладки из столбца С. Грубо говоря, чтобы подтягивались данные ко всем артикулам их вес и объем из каталога.
Понимаю, что надо использовать ВПР, но как привязаться отдельно к каждому измерению не очень понятно.

Автор - dubinaksenya
Дата добавления - 11.03.2024 в 23:04
DrMini Дата: Вторник, 12.03.2024, 07:16 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1754
Репутация: 243 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте dubinaksenya,
Если правильно понял.
UPD увидел у Nic70y откуда надо брать ID
Код
=ЕСЛИ(ЕСЛИОШИБКА(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК("объ";ВПР($A2;исходник!$A$2:$C$9;2;);1)=1;"Объём");ЕСЛИ(ПОИСК("вес";ВПР($A2;исходник!$A$2:$C$9;2;);1)=1;"Вес"));"")=ЛЕВБ(J$1;НАЙТИ(",";J$1)-1);ВПР($A2;исходник!$A$2:$C$9;3;);"")

Но... получилось очень громоздко.
:(
К сообщению приложен файл: vopros_1.xlsx (14.0 Kb)


Сообщение отредактировал DrMini - Вторник, 12.03.2024, 09:27
 
Ответить
СообщениеЗдравствуйте dubinaksenya,
Если правильно понял.
UPD увидел у Nic70y откуда надо брать ID
Код
=ЕСЛИ(ЕСЛИОШИБКА(ЕСЛИОШИБКА(ЕСЛИ(ПОИСК("объ";ВПР($A2;исходник!$A$2:$C$9;2;);1)=1;"Объём");ЕСЛИ(ПОИСК("вес";ВПР($A2;исходник!$A$2:$C$9;2;);1)=1;"Вес"));"")=ЛЕВБ(J$1;НАЙТИ(",";J$1)-1);ВПР($A2;исходник!$A$2:$C$9;3;);"")

Но... получилось очень громоздко.
:(

Автор - DrMini
Дата добавления - 12.03.2024 в 07:16
Nic70y Дата: Вторник, 12.03.2024, 07:46 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 8857
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
Если правильно понял
аналогично
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(ПОДСТАВИТЬ(ВПР($A2;исходник!$A:$B;2;);"ё";"е");J$1));ВПР($A2;исходник!$A:$C;3;);"")
К сообщению приложен файл: 22.xlsx (13.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Если правильно понял
аналогично
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(ПОДСТАВИТЬ(ВПР($A2;исходник!$A:$B;2;);"ё";"е");J$1));ВПР($A2;исходник!$A:$C;3;);"")

Автор - Nic70y
Дата добавления - 12.03.2024 в 07:46
dubinaksenya Дата: Вторник, 12.03.2024, 21:07 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2023
Большое спасибо за помощь DrMini, Nic70y !
 
Ответить
СообщениеБольшое спасибо за помощь DrMini, Nic70y !

Автор - dubinaksenya
Дата добавления - 12.03.2024 в 21:07
dubinaksenya Дата: Вторник, 19.03.2024, 18:15 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2023
Nic70y, добрый вечер.

объясните, пожалуйста, какой скрытый смысл в формуле имеют в кавычках буквы "ё";"е". никак не разберу(
 
Ответить
СообщениеNic70y, добрый вечер.

объясните, пожалуйста, какой скрытый смысл в формуле имеют в кавычках буквы "ё";"е". никак не разберу(

Автор - dubinaksenya
Дата добавления - 19.03.2024 в 18:15
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!