Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор и собрать на другои лист по критерию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор и собрать на другои лист по критерию (Формулы/Formulas)
Выбор и собрать на другои лист по критерию
a20168456 Дата: Четверг, 21.03.2024, 20:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2019
Здравствуите, подскажите как решить задачку: в листа2 необхобимо выбрать зчачение (всю строчку желтое) по критерию из листа1 - красное значкние А1:А5. Спасибо
К сообщению приложен файл: 5415237.xlsx (11.9 Kb)
 
Ответить
СообщениеЗдравствуите, подскажите как решить задачку: в листа2 необхобимо выбрать зчачение (всю строчку желтое) по критерию из листа1 - красное значкние А1:А5. Спасибо

Автор - a20168456
Дата добавления - 21.03.2024 в 20:57
bigor Дата: Четверг, 21.03.2024, 21:04 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1100
Репутация: 210 ±
Замечаний: 0% ±

нет
a20168456, в b1 и протянуть вниз вправо
Код
=INDEX('1'!$B$4:$C$23;$A1;COLUMN(A1))
 
Ответить
Сообщениеa20168456, в b1 и протянуть вниз вправо
Код
=INDEX('1'!$B$4:$C$23;$A1;COLUMN(A1))

Автор - bigor
Дата добавления - 21.03.2024 в 21:04
DrMini Дата: Четверг, 21.03.2024, 21:31 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Как вариант:
Код
=ПЕЧСИМВ(ВПР($A1;'1'!$A$4:$C$23;СТОЛБЕЦ(B1);))
К сообщению приложен файл: 9332335.xlsx (12.2 Kb)
 
Ответить
СообщениеКак вариант:
Код
=ПЕЧСИМВ(ВПР($A1;'1'!$A$4:$C$23;СТОЛБЕЦ(B1);))

Автор - DrMini
Дата добавления - 21.03.2024 в 21:31
a20168456 Дата: Четверг, 21.03.2024, 22:21 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

2019
Спасибо, не поиму что с форматом, этот фаил из CVS формата, должно получься двух значное число и в листе1 А столбец формат непонятен. Спасибо
К сообщению приложен файл: 5131482.xlsx (465.1 Kb)
 
Ответить
СообщениеСпасибо, не поиму что с форматом, этот фаил из CVS формата, должно получься двух значное число и в листе1 А столбец формат непонятен. Спасибо

Автор - a20168456
Дата добавления - 21.03.2024 в 22:21
DrMini Дата: Пятница, 22.03.2024, 05:53 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
должно получься двух значное число

У Вас не целые значения в столбце A на листе 1 после 10 строки. По этому нужно округлить или заменить числа на целые при помощи Прогрессии. А то больше 35 выдаётся ошибка.
исправим на такое:
Код
=ПЕЧСИМВ(ВПР($A1;ОКРУГЛ('1'!$A$4:$AC$1444;);СТОЛБЕЦ(B1);))

ПЕЧСИМВ добавил для того, что бы не отображался 0 если нет данных.
Ну, а судя по Вашей таблице можно и ПЕЧСИМВ убрать
Код
=ВПР($A1;ОКРУГЛ('1'!$A$4:$AC$1444;);СТОЛБЕЦ(B1);)
К сообщению приложен файл: 5131482_2.xlsx (479.0 Kb)


Сообщение отредактировал DrMini - Пятница, 22.03.2024, 06:47
 
Ответить
Сообщение
должно получься двух значное число

У Вас не целые значения в столбце A на листе 1 после 10 строки. По этому нужно округлить или заменить числа на целые при помощи Прогрессии. А то больше 35 выдаётся ошибка.
исправим на такое:
Код
=ПЕЧСИМВ(ВПР($A1;ОКРУГЛ('1'!$A$4:$AC$1444;);СТОЛБЕЦ(B1);))

ПЕЧСИМВ добавил для того, что бы не отображался 0 если нет данных.
Ну, а судя по Вашей таблице можно и ПЕЧСИМВ убрать
Код
=ВПР($A1;ОКРУГЛ('1'!$A$4:$AC$1444;);СТОЛБЕЦ(B1);)

Автор - DrMini
Дата добавления - 22.03.2024 в 05:53
DrMini Дата: Пятница, 22.03.2024, 06:57 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Ну, или так:
Код
=ИНДЕКС('1'!B$4:B$1444;ПОИСКПОЗ($A1;ОКРУГЛ('1'!$A$4:$A$1444;);0))


Сообщение отредактировал DrMini - Пятница, 22.03.2024, 07:14
 
Ответить
СообщениеНу, или так:
Код
=ИНДЕКС('1'!B$4:B$1444;ПОИСКПОЗ($A1;ОКРУГЛ('1'!$A$4:$A$1444;);0))

Автор - DrMini
Дата добавления - 22.03.2024 в 06:57
Nic70y Дата: Пятница, 22.03.2024, 07:35 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
вдруг правильно
Код
=ВПР($A1+0,9;'1'!$A:B;СТОЛБЕЦ())
К сообщению приложен файл: 541.xlsb (393.8 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Пятница, 22.03.2024, 07:36
 
Ответить
Сообщениевдруг правильно
Код
=ВПР($A1+0,9;'1'!$A:B;СТОЛБЕЦ())

Автор - Nic70y
Дата добавления - 22.03.2024 в 07:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор и собрать на другои лист по критерию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!