Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск ближайшего значения по нескольким условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ближайшего значения по нескольким условиям (Формулы/Formulas)
Поиск ближайшего значения по нескольким условиям
pkokmz Дата: Понедельник, 01.04.2024, 19:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте. Нужно найти значение столбца по ближайшим значениям в шести столбцах.
Пробовал
Код
=ИНДЕКС($G$1:$G$40;ПОИСКПОЗ(1;(МИН(ABS($A$1:$A$40-K2))=ABS($A$1:$A$40-K2))*(МИН(ABS($B$1:$B$40-L2))=ABS($B$1:$B$40-L2))*(МИН(ABS($C$1:$C$40-M2))=ABS($C$1:$C$40-M2))*(МИН(ABS($D$1:$D$40-N2))=ABS($D$1:$D$40-N2))*(МИН(ABS($E$1:$E$40-O2))=ABS($E$1:$E$40-O2))*(МИН(ABS($F$1:$F$40-P2))=ABS($F$1:$F$40-P2));0))

и
Код
=СУММ($G$1:$G$40*(ABS($A$1:$A$40-K2)=МИН(ABS($A$1:$A$40-K2)))*(ABS($B$1:$B$40-L2)=МИН(ABS($B$1:$B$40-L2)))*(ABS($C$1:$C$40-M2)=МИН(ABS($C$1:$C$40-M2)))*(ABS($D$1:$D$40-N2)=МИН(ABS($D$1:$D$40-N2)))*(ABS($E$1:$E$40-O2)=МИН(ABS($E$1:$E$40-O2)))*(ABS($F$1:$F$40-P2)=МИН(ABS($F$1:$F$40-P2))))

Больше ни чего в голову не приходит. Помогите кто чем может)))
К сообщению приложен файл: primer.xlsx (11.5 Kb)
 
Ответить
СообщениеЗдравствуйте. Нужно найти значение столбца по ближайшим значениям в шести столбцах.
Пробовал
Код
=ИНДЕКС($G$1:$G$40;ПОИСКПОЗ(1;(МИН(ABS($A$1:$A$40-K2))=ABS($A$1:$A$40-K2))*(МИН(ABS($B$1:$B$40-L2))=ABS($B$1:$B$40-L2))*(МИН(ABS($C$1:$C$40-M2))=ABS($C$1:$C$40-M2))*(МИН(ABS($D$1:$D$40-N2))=ABS($D$1:$D$40-N2))*(МИН(ABS($E$1:$E$40-O2))=ABS($E$1:$E$40-O2))*(МИН(ABS($F$1:$F$40-P2))=ABS($F$1:$F$40-P2));0))

и
Код
=СУММ($G$1:$G$40*(ABS($A$1:$A$40-K2)=МИН(ABS($A$1:$A$40-K2)))*(ABS($B$1:$B$40-L2)=МИН(ABS($B$1:$B$40-L2)))*(ABS($C$1:$C$40-M2)=МИН(ABS($C$1:$C$40-M2)))*(ABS($D$1:$D$40-N2)=МИН(ABS($D$1:$D$40-N2)))*(ABS($E$1:$E$40-O2)=МИН(ABS($E$1:$E$40-O2)))*(ABS($F$1:$F$40-P2)=МИН(ABS($F$1:$F$40-P2))))

Больше ни чего в голову не приходит. Помогите кто чем может)))

Автор - pkokmz
Дата добавления - 01.04.2024 в 19:42
Светлый Дата: Понедельник, 01.04.2024, 21:16 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1829
Репутация: 510 ±
Замечаний: 0% ±

Excel 2013, 2016
Находит номер строки в таблице, в которой самые близкие значения к заданным в K2:P2
Код
=ПОИСКПОЗ(МИН(МУМНОЖ((K2:P2-A1:F40)^2;СТРОКА(1:6)^0));МУМНОЖ((K2:P2-A1:F40)^2;СТРОКА(1:6)^0);)
А что Вы хотели, абсолютно не понял.
*Второй вариант даёт другую строку
Код
=ПОИСКПОЗ(МИН(МУМНОЖ(ABS(K2:P2-A1:F40);СТРОКА(1:6)^0));МУМНОЖ(ABS(K2:P2-A1:F40);СТРОКА(1:6)^0);)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 01.04.2024, 21:47
 
Ответить
СообщениеНаходит номер строки в таблице, в которой самые близкие значения к заданным в K2:P2
Код
=ПОИСКПОЗ(МИН(МУМНОЖ((K2:P2-A1:F40)^2;СТРОКА(1:6)^0));МУМНОЖ((K2:P2-A1:F40)^2;СТРОКА(1:6)^0);)
А что Вы хотели, абсолютно не понял.
*Второй вариант даёт другую строку
Код
=ПОИСКПОЗ(МИН(МУМНОЖ(ABS(K2:P2-A1:F40);СТРОКА(1:6)^0));МУМНОЖ(ABS(K2:P2-A1:F40);СТРОКА(1:6)^0);)

Автор - Светлый
Дата добавления - 01.04.2024 в 21:16
AlexM Дата: Понедельник, 01.04.2024, 21:16 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4490
Репутация: 1115 ±
Замечаний: 0% ±

Excel 2003
Не совсем понятно, что хотите получить. В одной строке ближайшие значения маловероятны.
Может быть нужна строка с ближайшей суммой?
Код
=ИНДЕКС(G1:G40;ПОИСКПОЗ(1;--(МИН(ABS(МУМНОЖ(A1:F40;{1:1:1:1:1:1})-СУММ(K2:P2)))=ABS(МУМНОЖ(A1:F40;{1:1:1:1:1:1})-СУММ(K2:P2)));))

или
Код
=ПРОСМОТР(2;1/(МИН(ABS(МУМНОЖ(A1:F40;{1:1:1:1:1:1})-СУММ(K2:P2)))=ABS(МУМНОЖ(A1:F40;{1:1:1:1:1:1})-СУММ(K2:P2)));G1:G40)
К сообщению приложен файл: primer_1.xlsx (11.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНе совсем понятно, что хотите получить. В одной строке ближайшие значения маловероятны.
Может быть нужна строка с ближайшей суммой?
Код
=ИНДЕКС(G1:G40;ПОИСКПОЗ(1;--(МИН(ABS(МУМНОЖ(A1:F40;{1:1:1:1:1:1})-СУММ(K2:P2)))=ABS(МУМНОЖ(A1:F40;{1:1:1:1:1:1})-СУММ(K2:P2)));))

или
Код
=ПРОСМОТР(2;1/(МИН(ABS(МУМНОЖ(A1:F40;{1:1:1:1:1:1})-СУММ(K2:P2)))=ABS(МУМНОЖ(A1:F40;{1:1:1:1:1:1})-СУММ(K2:P2)));G1:G40)

Автор - AlexM
Дата добавления - 01.04.2024 в 21:16
pkokmz Дата: Понедельник, 01.04.2024, 21:59 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Светлый, огромное спасибо, это то что мне и требовалось
 
Ответить
СообщениеСветлый, огромное спасибо, это то что мне и требовалось

Автор - pkokmz
Дата добавления - 01.04.2024 в 21:59
Светлый Дата: Понедельник, 01.04.2024, 23:34 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1829
Репутация: 510 ±
Замечаний: 0% ±

Excel 2013, 2016
Немного упростил
Код
=ОСТАТ(МИН(МУМНОЖ((K2:P2-A1:F40)^2;СТРОКА(1:6)^0)*10^6+СТРОКА(1:40));100)
Код
=ОСТАТ(МИН(МУМНОЖ(ABS(K2:P2-A1:F40);СТРОКА(1:6)^0)*10^6+СТРОКА(1:40));100)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеНемного упростил
Код
=ОСТАТ(МИН(МУМНОЖ((K2:P2-A1:F40)^2;СТРОКА(1:6)^0)*10^6+СТРОКА(1:40));100)
Код
=ОСТАТ(МИН(МУМНОЖ(ABS(K2:P2-A1:F40);СТРОКА(1:6)^0)*10^6+СТРОКА(1:40));100)

Автор - Светлый
Дата добавления - 01.04.2024 в 23:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ближайшего значения по нескольким условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!