Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/построить числовой отрезок с заданным началом, концом и шаго - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » построить числовой отрезок с заданным началом, концом и шаго (Формулы/Formulas)
построить числовой отрезок с заданным началом, концом и шаго
Vetchman Дата: Пятница, 26.04.2024, 08:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Постараюсь объяснить вкратце.

Нужно построить числовой отрезок с определёнными началом, концом и шагом.
В одну ячейку записывается начало, во вторую ячейку — конец, а в третью — шаг.
Затем в строке x автоматически строится нужный нам отрезок.

Например, в ячейку E4 записано 0, в ячейку E5 записано 2 и в ячейку E6 записано 0,1.
Затем строка, начинающаяся с B8, заполняется числами: 0; 0,1; 0,2; 0,3; … 1,8; 1,9; 2.

Никак не могу сообразить, как такое реализовать.


Сообщение отредактировал Vetchman - Пятница, 26.04.2024, 08:40
 
Ответить
СообщениеПостараюсь объяснить вкратце.

Нужно построить числовой отрезок с определёнными началом, концом и шагом.
В одну ячейку записывается начало, во вторую ячейку — конец, а в третью — шаг.
Затем в строке x автоматически строится нужный нам отрезок.

Например, в ячейку E4 записано 0, в ячейку E5 записано 2 и в ячейку E6 записано 0,1.
Затем строка, начинающаяся с B8, заполняется числами: 0; 0,1; 0,2; 0,3; … 1,8; 1,9; 2.

Никак не могу сообразить, как такое реализовать.

Автор - Vetchman
Дата добавления - 26.04.2024 в 08:39
gling Дата: Пятница, 26.04.2024, 08:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2525
Репутация: 678 ±
Замечаний: 0% ±

2010
Код
=ЕСЛИ(($E$4+(СТРОКА(B1)-1)*$E$6)<=$E$5;$E$4+(СТРОКА(B1)-1)*$E$6;"")
Так?


ЯД-41001506838083
 
Ответить
Сообщение
Код
=ЕСЛИ(($E$4+(СТРОКА(B1)-1)*$E$6)<=$E$5;$E$4+(СТРОКА(B1)-1)*$E$6;"")
Так?

Автор - gling
Дата добавления - 26.04.2024 в 08:54
Pelena Дата: Пятница, 26.04.2024, 10:36 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 19201
Репутация: 4423 ±
Замечаний: ±

Excel 365 & Mac Excel
Vetchman, дайте теме более конкретное название, отражающее суть задачи, в соответствии с Правилами форума


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеVetchman, дайте теме более конкретное название, отражающее суть задачи, в соответствии с Правилами форума

Автор - Pelena
Дата добавления - 26.04.2024 в 10:36
elovkov Дата: Четверг, 02.05.2024, 10:31 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 380
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013

Ну судя по

Затем строка, начинающаяся с B8, заполняется числами

автору правильнее так
Код
=ЕСЛИ(($E$4+(СТОЛБЕЦ(A1)-1)*$E$6)<=$E$5;$E$4+(СТОЛБЕЦ(A1)-1)*$E$6;"")

и протянуть от В8 вправо


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
Сообщение
Ну судя по

Затем строка, начинающаяся с B8, заполняется числами

автору правильнее так
Код
=ЕСЛИ(($E$4+(СТОЛБЕЦ(A1)-1)*$E$6)<=$E$5;$E$4+(СТОЛБЕЦ(A1)-1)*$E$6;"")

и протянуть от В8 вправо

Автор - elovkov
Дата добавления - 02.05.2024 в 10:31
DrMini Дата: Четверг, 02.05.2024, 12:18 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Ну, раз уж стали отвечать, да и время много прошло.
Как вариант:
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(B8+$E$6>$E$5;B8+$E$6<$E$4);"";B8+$E$6);"")
К сообщению приложен файл: progressija.xlsx (9.2 Kb)
 
Ответить
СообщениеНу, раз уж стали отвечать, да и время много прошло.
Как вариант:
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(B8+$E$6>$E$5;B8+$E$6<$E$4);"";B8+$E$6);"")

Автор - DrMini
Дата добавления - 02.05.2024 в 12:18
AlexM Дата: Четверг, 02.05.2024, 17:59 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4513
Репутация: 1128 ±
Замечаний: 0% ±

Excel 2003
Код
=ЕСЛИ(СТРОКА(A1)-1>E$5/E$6;"";E$4+(СТРОКА(A1)-1)*E$6)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ЕСЛИ(СТРОКА(A1)-1>E$5/E$6;"";E$4+(СТРОКА(A1)-1)*E$6)

Автор - AlexM
Дата добавления - 02.05.2024 в 17:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » построить числовой отрезок с заданным началом, концом и шаго (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!