Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод данных во 2й лист Книги по заданным условиям в первом - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Вывод данных во 2й лист Книги по заданным условиям в первом
BBC Дата: Четверг, 16.05.2024, 12:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC
Доброго времени суток. Книга СПИСОК ЛИЦ, в первом листе в алфавитном порядке список всех сотрудников ООО (более 50 чел).
Как сделать, чтобы отмечая в ячейках столбца G первого листа(зеленый), во втором листе С ОРУЖИЕМ (красный) формировался
список отмеченных лиц ?
К сообщению приложен файл: spisok_lic.xlsx (22.3 Kb)
 
Ответить
СообщениеДоброго времени суток. Книга СПИСОК ЛИЦ, в первом листе в алфавитном порядке список всех сотрудников ООО (более 50 чел).
Как сделать, чтобы отмечая в ячейках столбца G первого листа(зеленый), во втором листе С ОРУЖИЕМ (красный) формировался
список отмеченных лиц ?

Автор - BBC
Дата добавления - 16.05.2024 в 12:22
Nic70y Дата: Четверг, 16.05.2024, 12:42 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8857
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
фильтр не устаивает?
К сообщению приложен файл: 65.xlsx (13.9 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениефильтр не устаивает?

Автор - Nic70y
Дата добавления - 16.05.2024 в 12:42
китин Дата: Четверг, 16.05.2024, 12:44 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 7020
Репутация: 1075 ±
Замечаний: 0% ±

Excel 2007;2010;2016
может правильно)
Код
=ЕСЛИОШИБКА(ИНДЕКС(список!B$16:B$31;НАИМЕНЬШИЙ(ЕСЛИ(список!$G$16:$G$31<>"";СТРОКА(список!$B$16:$B$31)-15);СТРОКА(A1)));"")

формула массива. вводится Ctrl Shift Enter
К сообщению приложен файл: BBC.xlsx (18.0 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеможет правильно)
Код
=ЕСЛИОШИБКА(ИНДЕКС(список!B$16:B$31;НАИМЕНЬШИЙ(ЕСЛИ(список!$G$16:$G$31<>"";СТРОКА(список!$B$16:$B$31)-15);СТРОКА(A1)));"")

формула массива. вводится Ctrl Shift Enter

Автор - китин
Дата добавления - 16.05.2024 в 12:44
BBC Дата: Четверг, 16.05.2024, 12:53 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC
пробую все варианты
 
Ответить
Сообщениепробую все варианты

Автор - BBC
Дата добавления - 16.05.2024 в 12:53
BBC Дата: Четверг, 16.05.2024, 13:02 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC
фильтр не устаивает?

Работает, но тогда вручную название списка нужно менять.
 
Ответить
Сообщение
фильтр не устаивает?

Работает, но тогда вручную название списка нужно менять.

Автор - BBC
Дата добавления - 16.05.2024 в 13:02
BBC Дата: Четверг, 16.05.2024, 13:04 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC
может правильно)

Добавляю сотрудников не первом листе, на втором ничего не меняется. Закрывал файл, открыл, ничего не изменилось. Может, что не так делаю?
 
Ответить
Сообщение
может правильно)

Добавляю сотрудников не первом листе, на втором ничего не меняется. Закрывал файл, открыл, ничего не изменилось. Может, что не так делаю?

Автор - BBC
Дата добавления - 16.05.2024 в 13:04
Nic70y Дата: Четверг, 16.05.2024, 14:22 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 8857
Репутация: 2308 ±
Замечаний: 0% ±

Excel 2010
для выпадающего списка
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("a11")) Is Nothing Then
        a = Right(Target.Value, 1)
        b = Cells(Rows.Count, "f").End(xlUp).Row
        If a = "е" Then
            Range("g15:g" & b).AutoFilter Field:=1, Criteria1:="<>"
        Else
            Range("g15:g" & b).AutoFilter Field:=1
        End If
    End If
End Sub
[/vba]
К сообщению приложен файл: 69.xlsm (20.0 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Четверг, 16.05.2024, 14:29
 
Ответить
Сообщениедля выпадающего списка
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("a11")) Is Nothing Then
        a = Right(Target.Value, 1)
        b = Cells(Rows.Count, "f").End(xlUp).Row
        If a = "е" Then
            Range("g15:g" & b).AutoFilter Field:=1, Criteria1:="<>"
        Else
            Range("g15:g" & b).AutoFilter Field:=1
        End If
    End If
End Sub
[/vba]

Автор - Nic70y
Дата добавления - 16.05.2024 в 14:22
BBC Дата: Четверг, 16.05.2024, 15:12 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel LTSC
для выпадающего списка


О, то что надо. Спасибо.
 
Ответить
Сообщение
для выпадающего списка


О, то что надо. Спасибо.

Автор - BBC
Дата добавления - 16.05.2024 в 15:12
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!