Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР с диапазоном значений: <Х1=Y1;отX2доХ3=Y2;... - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
ВПР с диапазоном значений: <Х1=Y1;отX2доХ3=Y2;...
comman01 Дата: Среда, 29.05.2024, 21:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Привет, форумчанам!
Не раз выручали меня. Надеюсь и на этот раз получится.
Как правильно заполнить таблицу с данными?
Какая формула подойдет для этой задачи?
К сообщению приложен файл: zadacha_s_kommentom.xlsx (124.2 Kb)
 
Ответить
СообщениеПривет, форумчанам!
Не раз выручали меня. Надеюсь и на этот раз получится.
Как правильно заполнить таблицу с данными?
Какая формула подойдет для этой задачи?

Автор - comman01
Дата добавления - 29.05.2024 в 21:11
i691198 Дата: Среда, 29.05.2024, 22:32 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 237
Репутация: 88 ±
Замечаний: 0% ±

Добрый вечер. Посмотрите такой вариант. Изменил структуру таблицы - сделал ее плоской и подправил диапазоны интервалов, у вас там были пропуски.
К сообщению приложен файл: zadacha_2.xlsx (123.7 Kb)
 
Ответить
СообщениеДобрый вечер. Посмотрите такой вариант. Изменил структуру таблицы - сделал ее плоской и подправил диапазоны интервалов, у вас там были пропуски.

Автор - i691198
Дата добавления - 29.05.2024 в 22:32
comman01 Дата: Четверг, 30.05.2024, 06:15 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Огромнейшее спасибо и респект!
2 дня убил на задачу.
Вопрос закрыт.
 
Ответить
СообщениеОгромнейшее спасибо и респект!
2 дня убил на задачу.
Вопрос закрыт.

Автор - comman01
Дата добавления - 30.05.2024 в 06:15
comman01 Дата: Четверг, 30.05.2024, 22:42 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

i691198,
Рано обрадовался(
150 раз проверил, все как Вы дали.
Не работает >(
К сообщению приложен файл: zadacha_3.xlsx (122.4 Kb)
 
Ответить
Сообщениеi691198,
Рано обрадовался(
150 раз проверил, все как Вы дали.
Не работает >(

Автор - comman01
Дата добавления - 30.05.2024 в 22:42
bigor Дата: Четверг, 30.05.2024, 23:02 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1138
Репутация: 216 ±
Замечаний: 0% ±

нет
150 раз проверил

Да даже с первого раза без очков вижу, что много чего не так. Второй параметр ПОИСКПОЗ должен быть в фигурных скобках (массив как никак). Откуда там взялись слова не понятно. Должны быть перечислены только диапазоны, как в шапке b2:h2 c 0 и до 5000
 
Ответить
Сообщение
150 раз проверил

Да даже с первого раза без очков вижу, что много чего не так. Второй параметр ПОИСКПОЗ должен быть в фигурных скобках (массив как никак). Откуда там взялись слова не понятно. Должны быть перечислены только диапазоны, как в шапке b2:h2 c 0 и до 5000

Автор - bigor
Дата добавления - 30.05.2024 в 23:02
Pelena Дата: Пятница, 31.05.2024, 09:36 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 19242
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
Не работает

Дык, структура таблицы совсем другая >(
Я бы так сделала
Код
=ВПР(C3;Данные!$A$3:$H$18;ПОИСКПОЗ(I3;Данные!$A$2:$H$2);0)

и немного изменила шапку таблицы на листе Данные
К сообщению приложен файл: 2113782.xlsx (123.9 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
Не работает

Дык, структура таблицы совсем другая >(
Я бы так сделала
Код
=ВПР(C3;Данные!$A$3:$H$18;ПОИСКПОЗ(I3;Данные!$A$2:$H$2);0)

и немного изменила шапку таблицы на листе Данные

Автор - Pelena
Дата добавления - 31.05.2024 в 09:36
i691198 Дата: Пятница, 31.05.2024, 21:00 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 237
Репутация: 88 ±
Замечаний: 0% ±

150 раз проверил, все как Вы дали.
Не работает
Я такого не давал, вы сами какую то ненужную дрянь напихали в формулу. Для вашего примера это должно быть так
Код
=ВПР(C3;Данные!A3:H18;ПОИСКПОЗ(I3;{0;50;100;300;500;1500;3000;5000})+1;0)


Сообщение отредактировал i691198 - Пятница, 31.05.2024, 21:01
 
Ответить
Сообщение
150 раз проверил, все как Вы дали.
Не работает
Я такого не давал, вы сами какую то ненужную дрянь напихали в формулу. Для вашего примера это должно быть так
Код
=ВПР(C3;Данные!A3:H18;ПОИСКПОЗ(I3;{0;50;100;300;500;1500;3000;5000})+1;0)

Автор - i691198
Дата добавления - 31.05.2024 в 21:00
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!