Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка по диапазону с подстановкой значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка по диапазону с подстановкой значения (Формулы)
Проверка по диапазону с подстановкой значения
efanoff Дата: Суббота, 27.07.2013, 16:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет!

Есть диапазон "продукты" (столбец Е), по которому должен проверяться "список" (столбец А).

Если в ячейках "списка" есть вхождение из "продуктов", то в соседнюю ячейку "проверки" (столбец В) вписать имя диапазона, ну или просто слово "продукты". Если вхождение не подтверждается, оставить ячейку пустой.

Моя формула некорректно работает:
Код
=ЕСЛИ(И(ЕОШ(НАЙТИ(продукты;A2)));"продукты";)

Здесь был предложен вариант исправления:
Код
=ЕСЛИ(НЕ(ЕОШИБКА(НАЙТИ(продукты;A3)));"продукты"

Но у меня снова получился некорректный результат

Пожалуйста, помогите исправить.
К сообщению приложен файл: 7205409.xls(29.0 Kb)


may the Force be with you..

Сообщение отредактировал efanoff - Суббота, 27.07.2013, 16:35
 
Ответить
СообщениеВсем привет!

Есть диапазон "продукты" (столбец Е), по которому должен проверяться "список" (столбец А).

Если в ячейках "списка" есть вхождение из "продуктов", то в соседнюю ячейку "проверки" (столбец В) вписать имя диапазона, ну или просто слово "продукты". Если вхождение не подтверждается, оставить ячейку пустой.

Моя формула некорректно работает:
Код
=ЕСЛИ(И(ЕОШ(НАЙТИ(продукты;A2)));"продукты";)

Здесь был предложен вариант исправления:
Код
=ЕСЛИ(НЕ(ЕОШИБКА(НАЙТИ(продукты;A3)));"продукты"

Но у меня снова получился некорректный результат

Пожалуйста, помогите исправить.

Автор - efanoff
Дата добавления - 27.07.2013 в 16:31
_Boroda_ Дата: Суббота, 27.07.2013, 16:41 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15946
Репутация: 6201 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИ(СУММПРОИЗВ(-ЕЧИСЛО(ПОИСК(продукты;A2)));"Продукты";"")
К сообщению приложен файл: 7205409_1.xls(29.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИ(СУММПРОИЗВ(-ЕЧИСЛО(ПОИСК(продукты;A2)));"Продукты";"")

Автор - _Boroda_
Дата добавления - 27.07.2013 в 16:41
efanoff Дата: Суббота, 27.07.2013, 16:49 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Большое спасибо, _Boroda_!
hands


may the Force be with you..
 
Ответить
СообщениеБольшое спасибо, _Boroda_!
hands

Автор - efanoff
Дата добавления - 27.07.2013 в 16:49
vikttur Дата: Суббота, 27.07.2013, 16:54 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2925
Репутация: 525 ±
Замечаний: 0% ±

Попробуйте ввести свой вариант как формулу массива.
(что это такое? Поищите, упоминаний много. Нажимаем три клавиши...)
После этого будет видно, что Ваша формула видит все "наоборот". Изменить - переставить ";"

Правка: немного не то. Нужно сразу поставить ";", где нужно:
Код
=ЕСЛИ(И(ЕОШ(НАЙТИ(продукты;A2)));;"продукты")


Сообщение отредактировал vikttur - Суббота, 27.07.2013, 17:18
 
Ответить
СообщениеПопробуйте ввести свой вариант как формулу массива.
(что это такое? Поищите, упоминаний много. Нажимаем три клавиши...)
После этого будет видно, что Ваша формула видит все "наоборот". Изменить - переставить ";"

Правка: немного не то. Нужно сразу поставить ";", где нужно:
Код
=ЕСЛИ(И(ЕОШ(НАЙТИ(продукты;A2)));;"продукты")

Автор - vikttur
Дата добавления - 27.07.2013 в 16:54
Dimon0 Дата: Вторник, 30.07.2013, 06:06 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А можно определить какой из продуктов был найден?
 
Ответить
СообщениеА можно определить какой из продуктов был найден?

Автор - Dimon0
Дата добавления - 30.07.2013 в 06:06
_Boroda_ Дата: Вторник, 30.07.2013, 07:20 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15946
Репутация: 6201 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИОШИБКА(ИНДЕКС(продукты;СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(продукты;A2))*(СТРОКА(продукты)-1)));"")
К сообщению приложен файл: 7205409_2.xls(29.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(продукты;СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(продукты;A2))*(СТРОКА(продукты)-1)));"")

Автор - _Boroda_
Дата добавления - 30.07.2013 в 07:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка по диапазону с подстановкой значения (Формулы)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!