Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сцепить дату и название дня недели - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » сцепить дату и название дня недели (Формулы/Formulas)
сцепить дату и название дня недели
aleksandr-1205 Дата: Пятница, 19.02.2016, 15:31 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
Подскажите, пжл, как решить такую небольшую задачу:
в столбце А находятся данные с датой (формат ячейки всегда будет "дата"), в столбце В находится название дня недели. Как можно написать формулу, чтоб в итоге получить такой результат :

04.01.2016 / Monday

файл с примером :
https://docs.google.com/spreads....t#gid=0
 
Ответить
СообщениеПодскажите, пжл, как решить такую небольшую задачу:
в столбце А находятся данные с датой (формат ячейки всегда будет "дата"), в столбце В находится название дня недели. Как можно написать формулу, чтоб в итоге получить такой результат :

04.01.2016 / Monday

файл с примером :
https://docs.google.com/spreads....t#gid=0

Автор - aleksandr-1205
Дата добавления - 19.02.2016 в 15:31
китин Дата: Пятница, 19.02.2016, 15:39 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3433
Репутация: 544 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
может так?
Код
=ТЕКСТ(A2;"dd.mm.yyyy")&"/"&ТЕКСТ(A2;"dddd")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеможет так?
Код
=ТЕКСТ(A2;"dd.mm.yyyy")&"/"&ТЕКСТ(A2;"dddd")

Автор - китин
Дата добавления - 19.02.2016 в 15:39
_Boroda_ Дата: Пятница, 19.02.2016, 15:41 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ТЕКСТ(A2;"ДД.ММ.ГГГГ/ДДДД")

Или вообще форматом
ДД.ММ.ГГГГ/ДДДД

А столбец В не нужен
К сообщению приложен файл: 45249786567.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ТЕКСТ(A2;"ДД.ММ.ГГГГ/ДДДД")

Или вообще форматом
ДД.ММ.ГГГГ/ДДДД

А столбец В не нужен

Автор - _Boroda_
Дата добавления - 19.02.2016 в 15:41
aleksandr-1205 Дата: Суббота, 20.02.2016, 14:14 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
решил использовать эту формулу
Код
=ТЕКСТ(A10;"dd.mm")&" / "&ТЕКСТ(A10;"ddd")

но заметил такой нюанс - если исходная ячейка с датой пустая, то ячейка результат выдает дату 30.12 / сб (в файле выделил красным). Можно ли поправить формулу, чтоб если исходная ячейка с датой пустая, то и ячейка с результатом пустая?
[moder]Формулы нужно оформлять тегами![/moder]


Сообщение отредактировал aleksandr-1205 - Суббота, 20.02.2016, 14:34
 
Ответить
Сообщениерешил использовать эту формулу
Код
=ТЕКСТ(A10;"dd.mm")&" / "&ТЕКСТ(A10;"ddd")

но заметил такой нюанс - если исходная ячейка с датой пустая, то ячейка результат выдает дату 30.12 / сб (в файле выделил красным). Можно ли поправить формулу, чтоб если исходная ячейка с датой пустая, то и ячейка с результатом пустая?
[moder]Формулы нужно оформлять тегами![/moder]

Автор - aleksandr-1205
Дата добавления - 20.02.2016 в 14:14
TimSha Дата: Суббота, 20.02.2016, 14:34 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 456
Репутация: 73 ±
Замечаний: 0% ±

Excel 2013 Pro +
если исходная ячейка с датой пустая, то и ячейка с результатом пустая

Так для того и создана функции =ЕСЛИ(), чем не устраивает?!


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
если исходная ячейка с датой пустая, то и ячейка с результатом пустая

Так для того и создана функции =ЕСЛИ(), чем не устраивает?!

Автор - TimSha
Дата добавления - 20.02.2016 в 14:34
_Boroda_ Дата: Суббота, 20.02.2016, 14:37 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно и без ЕСЛИ
Код
=ТЕКСТ(A3;"ДД.ММ.ГГГ/поне\дельник;;")

см. ячейку С3
К сообщению приложен файл: 45249786567_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно и без ЕСЛИ
Код
=ТЕКСТ(A3;"ДД.ММ.ГГГ/поне\дельник;;")

см. ячейку С3

Автор - _Boroda_
Дата добавления - 20.02.2016 в 14:37
aleksandr-1205 Дата: Суббота, 20.02.2016, 14:47 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
я уже просто настроил все под формулу
Код
=ТЕКСТ(A10;"dd.mm")&" / "&ТЕКСТ(A10;"ddd")


вы не могли бы подсказать формулу для этого примера (чтоб если исходная ячейка с датой пустая, то и ячейка с результатом пустая):

https://docs.google.com/spreads....6405927 (лист 2)
 
Ответить
Сообщениея уже просто настроил все под формулу
Код
=ТЕКСТ(A10;"dd.mm")&" / "&ТЕКСТ(A10;"ddd")


вы не могли бы подсказать формулу для этого примера (чтоб если исходная ячейка с датой пустая, то и ячейка с результатом пустая):

https://docs.google.com/spreads....6405927 (лист 2)

Автор - aleksandr-1205
Дата добавления - 20.02.2016 в 14:47
_Boroda_ Дата: Суббота, 20.02.2016, 15:06 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
все аналогично
Код
=ТЕКСТ(A10;"dd.mm;;")&" / "&ТЕКСТ(A10;"ddd;;")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениевсе аналогично
Код
=ТЕКСТ(A10;"dd.mm;;")&" / "&ТЕКСТ(A10;"ddd;;")

Автор - _Boroda_
Дата добавления - 20.02.2016 в 15:06
aleksandr-1205 Дата: Суббота, 20.02.2016, 15:11 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
только при этой формуле слеш остается https://docs.google.com/spreads....6405927
 
Ответить
Сообщениетолько при этой формуле слеш остается https://docs.google.com/spreads....6405927

Автор - aleksandr-1205
Дата добавления - 20.02.2016 в 15:11
_Boroda_ Дата: Суббота, 20.02.2016, 15:14 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ТЕКСТ(A10;"dd.mm;;")&ТЕКСТ(A10;" \/ddd;;")

Код
=ТЕКСТ(A2;"dd.mm/;;")&ТЕКСТ(A2;"ddd;;")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ТЕКСТ(A10;"dd.mm;;")&ТЕКСТ(A10;" \/ddd;;")

Код
=ТЕКСТ(A2;"dd.mm/;;")&ТЕКСТ(A2;"ddd;;")

Автор - _Boroda_
Дата добавления - 20.02.2016 в 15:14
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » сцепить дату и название дня недели (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!