Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных из строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Выборка данных из строк (Формулы/Formulas)
Выборка данных из строк
ManUkr Дата: Воскресенье, 03.03.2019, 01:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени, уважаемые.

Подскажите, пожалуйста, с таким вопросом. Есть таблица с указанием Пациентов и процедурами, которые были для них выполнены. Как собрать все процедуры подряд, оду за одной, пропуская дня, когда ничего не было.
Со столбцами это сделать было не сложно, а вот со строками, подвис.

Собрать нужно только первые три строчки у каждого Пациента. Это делается для того, чтобы потом можно было быстро посчитать з.п., зная стоимость продуктов.

Пример таблицы тут - https://docs.google.com/spreads....t#gid=0

Благодарю очень.
 
Ответить
СообщениеДоброго времени, уважаемые.

Подскажите, пожалуйста, с таким вопросом. Есть таблица с указанием Пациентов и процедурами, которые были для них выполнены. Как собрать все процедуры подряд, оду за одной, пропуская дня, когда ничего не было.
Со столбцами это сделать было не сложно, а вот со строками, подвис.

Собрать нужно только первые три строчки у каждого Пациента. Это делается для того, чтобы потом можно было быстро посчитать з.п., зная стоимость продуктов.

Пример таблицы тут - https://docs.google.com/spreads....t#gid=0

Благодарю очень.

Автор - ManUkr
Дата добавления - 03.03.2019 в 01:36
Pelena Дата: Воскресенье, 03.03.2019, 07:35 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13767
Репутация: 3025 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Если просто посчитать з.п., может достаточно формулы
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B8:I15;I18:I21);J18:J21)
К сообщению приложен файл: __.xlsx(10.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если просто посчитать з.п., может достаточно формулы
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B8:I15;I18:I21);J18:J21)

Автор - Pelena
Дата добавления - 03.03.2019 в 07:35
krosav4ig Дата: Воскресенье, 03.03.2019, 07:58 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1982
Репутация: 840 ±
Замечаний: 0% ±

Excel 2007,2010,2013
[vba]
Код
=ArrayFormula(QUERY(SPLIT(TRANSPOSE(SPLIT(TEXTJOIN("|",1,If(ROW(A8:A15)-LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),ROW(A8:A15))<3,if(B8:I15<>"",LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),A8:A15)&":"&IFERROR(VLOOKUP(B8:I15,I18:J22,2,),),""),"")),"|")),":"),"select Col1,sum(Col2) group by Col1 label Col1 'Пациент', sum(Col2) 'Сумма'",0))
[/vba]или[vba]
Код
=ArrayFormula(QUERY(SPLIT(TRANSPOSE(SPLIT(TEXTJOIN("|",1,If(ROW(A8:A15)-LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),ROW(A8:A15))<3,if(B8:I15<>"",LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),A8:A15)&":"&B8:I15,""),"")),"|")),":"),"select Col1,Col2,count(Col2) group by Col1,Col2 label Col1 'Пациент', Col2 'Процедура', count(Col2) 'Количество'",0))
[/vba]или сводная по формуле[vba]
Код
=ArrayFormula({{"Пациент","Процедура","Стоимость"};SPLIT(TRANSPOSE(SPLIT(TEXTJOIN("|",1,If(ROW(A8:A15)-LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),ROW(A8:A15))<3,if(B8:I15<>"",LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),A8:A15)&":"&B8:I15&":"&VLOOKUP(B8:I15,I18:J22,2,),""),"")),"|")),":")})
[/vba]


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460

Сообщение отредактировал krosav4ig - Воскресенье, 03.03.2019, 08:06
 
Ответить
Сообщение[vba]
Код
=ArrayFormula(QUERY(SPLIT(TRANSPOSE(SPLIT(TEXTJOIN("|",1,If(ROW(A8:A15)-LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),ROW(A8:A15))<3,if(B8:I15<>"",LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),A8:A15)&":"&IFERROR(VLOOKUP(B8:I15,I18:J22,2,),),""),"")),"|")),":"),"select Col1,sum(Col2) group by Col1 label Col1 'Пациент', sum(Col2) 'Сумма'",0))
[/vba]или[vba]
Код
=ArrayFormula(QUERY(SPLIT(TRANSPOSE(SPLIT(TEXTJOIN("|",1,If(ROW(A8:A15)-LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),ROW(A8:A15))<3,if(B8:I15<>"",LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),A8:A15)&":"&B8:I15,""),"")),"|")),":"),"select Col1,Col2,count(Col2) group by Col1,Col2 label Col1 'Пациент', Col2 'Процедура', count(Col2) 'Количество'",0))
[/vba]или сводная по формуле[vba]
Код
=ArrayFormula({{"Пациент","Процедура","Стоимость"};SPLIT(TRANSPOSE(SPLIT(TEXTJOIN("|",1,If(ROW(A8:A15)-LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),ROW(A8:A15))<3,if(B8:I15<>"",LOOKUP(ROW(A8:A15),IF(A8:A15<>"",ROW(A8:A15)),A8:A15)&":"&B8:I15&":"&VLOOKUP(B8:I15,I18:J22,2,),""),"")),"|")),":")})
[/vba]

Автор - krosav4ig
Дата добавления - 03.03.2019 в 07:58
ManUkr Дата: Воскресенье, 03.03.2019, 20:13 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, krosav4ig,
даже нет слов, чтобы поблагодарить! мега-круто. Есть куда думать и думать.
Благодарю очень
 
Ответить
СообщениеPelena, krosav4ig,
даже нет слов, чтобы поблагодарить! мега-круто. Есть куда думать и думать.
Благодарю очень

Автор - ManUkr
Дата добавления - 03.03.2019 в 20:13
Мир MS Excel » Вопросы и решения » Excel и другие приложения » Google Docs » Выборка данных из строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!