Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/"Отзеркалить" (сместить) массив ячеек. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » "Отзеркалить" (сместить) массив ячеек. (Макросы/Sub)
"Отзеркалить" (сместить) массив ячеек.
shlackbaum Дата: Суббота, 13.10.2018, 20:55 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.
Помогите решить задачку. Искал поиском - не нашел чего-либо подобного.
Пользуюсь инструментом "Текст по столбцам" и понадобился инструмент, который сможет "отзеркалить" данные его работы.
Если стандартно после результата его работы получается массив ячеек разделенных заранее выбранным разделителем с "выравниванием" по "левому" краю, то нужен результат с "выравниванием" результатов по "правому" краю.
Как я вижу задача бы идеально решилась если через CTRL+G > Выделение пустых ячеек в "стандартном массиве" > Удалить ячейки со сдвигом "вправо", но к сожалению сдвига вправо не существует =(
Может есть какой-то простой метод кроме описанного удаления со сдвигом вправо?
К сообщению приложен файл: 5691589.xlsx(9.4 Kb)
 
Ответить
СообщениеЗдравствуйте.
Помогите решить задачку. Искал поиском - не нашел чего-либо подобного.
Пользуюсь инструментом "Текст по столбцам" и понадобился инструмент, который сможет "отзеркалить" данные его работы.
Если стандартно после результата его работы получается массив ячеек разделенных заранее выбранным разделителем с "выравниванием" по "левому" краю, то нужен результат с "выравниванием" результатов по "правому" краю.
Как я вижу задача бы идеально решилась если через CTRL+G > Выделение пустых ячеек в "стандартном массиве" > Удалить ячейки со сдвигом "вправо", но к сожалению сдвига вправо не существует =(
Может есть какой-то простой метод кроме описанного удаления со сдвигом вправо?

Автор - shlackbaum
Дата добавления - 13.10.2018 в 20:55
_Boroda_ Дата: Суббота, 13.10.2018, 22:28 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно вот такой формулой
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(";"&$A2;";";ПОВТОР(" ";99));(ДЛСТР($A2)-ДЛСТР(ПОДСТАВИТЬ($A2;";";))-МАКС(ИНДЕКС(ДЛСТР($A$2:$A$7)-ДЛСТР(ПОДСТАВИТЬ($A$2:$A$7;";";));))+(ПРАВБ($A2)<>";")+СТОЛБЕЦ(A2))*99;99));"")

Если данные, как у Вас в примере, состоят из одного символа между ";", то формула значительно упростится
К сообщению приложен файл: 5691589_1.xlsx(10.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно вот такой формулой
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(";"&$A2;";";ПОВТОР(" ";99));(ДЛСТР($A2)-ДЛСТР(ПОДСТАВИТЬ($A2;";";))-МАКС(ИНДЕКС(ДЛСТР($A$2:$A$7)-ДЛСТР(ПОДСТАВИТЬ($A$2:$A$7;";";));))+(ПРАВБ($A2)<>";")+СТОЛБЕЦ(A2))*99;99));"")

Если данные, как у Вас в примере, состоят из одного символа между ";", то формула значительно упростится

Автор - _Boroda_
Дата добавления - 13.10.2018 в 22:28
shlackbaum Дата: Суббота, 13.10.2018, 22:55 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, ого, формулочка...
Мои разделители это слеши в URL.
И строк у меня 67530
Попробовал заменить ";" на "/" и $A$7 на $A$67530 - результат пустой
К сообщению приложен файл: ____2.xlsx(14.0 Kb)
 
Ответить
Сообщение_Boroda_, ого, формулочка...
Мои разделители это слеши в URL.
И строк у меня 67530
Попробовал заменить ";" на "/" и $A$7 на $A$67530 - результат пустой

Автор - shlackbaum
Дата добавления - 13.10.2018 в 22:55
_Boroda_ Дата: Воскресенье, 14.10.2018, 02:24 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы наверное где-то недоперепоменяли
На 70000 лучше расчет максимального количества папок вынести в допячейку. Она же будет показывать количество столбцов, на которое нужно растянуть форумы вправо
В ней такая формула
Код
=МАКС(ИНДЕКС(ДЛСТР($A$2:$A$70000)-ДЛСТР(ПОДСТАВИТЬ($A$2:$A$70000;"/";));))

А в основных ячейках такая
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ("/"&$A2;"/";ПОВТОР(" ";255));(ДЛСТР($A2)-ДЛСТР(ПОДСТАВИТЬ($A2;"/";))-$B$1+СТОЛБЕЦ(A2))*255;255));"")
К сообщению приложен файл: _2_1.xlsx(16.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВы наверное где-то недоперепоменяли
На 70000 лучше расчет максимального количества папок вынести в допячейку. Она же будет показывать количество столбцов, на которое нужно растянуть форумы вправо
В ней такая формула
Код
=МАКС(ИНДЕКС(ДЛСТР($A$2:$A$70000)-ДЛСТР(ПОДСТАВИТЬ($A$2:$A$70000;"/";));))

А в основных ячейках такая
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ("/"&$A2;"/";ПОВТОР(" ";255));(ДЛСТР($A2)-ДЛСТР(ПОДСТАВИТЬ($A2;"/";))-$B$1+СТОЛБЕЦ(A2))*255;255));"")

Автор - _Boroda_
Дата добавления - 14.10.2018 в 02:24
Мир MS Excel » Вопросы и решения » Вопросы по VBA » "Отзеркалить" (сместить) массив ячеек. (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!