Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти идентичные данные и скопировать соседние ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Найти идентичные данные и скопировать соседние ячейки (Макросы/Sub)
Найти идентичные данные и скопировать соседние ячейки
Yar4i Дата: Вторник, 22.10.2019, 17:50 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер дамы и господа :D
До судорог в пальцах второй день пытаюсь прописать формулой популярную для анализа задачу.
Однако при подстановке иных баз (с различной величиной массива) формулу нужно протягивать, изменять и она периодически показывает #НД, нули и прочую малоинформативную аббревиатуру.

Как можно реализовать данное решение в VBA?
Лист база содержит КОДЫ (или КОДА), ЦВЕТ, ВЕС
Лист поле содержит КОД, и нужен соответствующий цвет и вес из соседних ячеек справа листа БАЗа (Цвет и Вес)

Однако в Базе попадаются иногда несколько кодов, соответствующих разным цветам (весам соответственно тоже разным). И формула упирается в это несовершенство.

Данные я попытался вписать в лист Желаемое поле... И ничего лучше как повторяющиеся коды вписать чуть ниже основного.
Например код K3-01BCEB1 соответствует трем значениям цвета и веса в Базе. Но я то этого не знаю изначально, что их много и как быть не знаю
К сообщению приложен файл: 22102019.xlsx(86.3 Kb)
 
Ответить
СообщениеДобрый вечер дамы и господа :D
До судорог в пальцах второй день пытаюсь прописать формулой популярную для анализа задачу.
Однако при подстановке иных баз (с различной величиной массива) формулу нужно протягивать, изменять и она периодически показывает #НД, нули и прочую малоинформативную аббревиатуру.

Как можно реализовать данное решение в VBA?
Лист база содержит КОДЫ (или КОДА), ЦВЕТ, ВЕС
Лист поле содержит КОД, и нужен соответствующий цвет и вес из соседних ячеек справа листа БАЗа (Цвет и Вес)

Однако в Базе попадаются иногда несколько кодов, соответствующих разным цветам (весам соответственно тоже разным). И формула упирается в это несовершенство.

Данные я попытался вписать в лист Желаемое поле... И ничего лучше как повторяющиеся коды вписать чуть ниже основного.
Например код K3-01BCEB1 соответствует трем значениям цвета и веса в Базе. Но я то этого не знаю изначально, что их много и как быть не знаю

Автор - Yar4i
Дата добавления - 22.10.2019 в 17:50
Pelena Дата: Вторник, 22.10.2019, 18:40 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14761
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Сводная не вариант?
К сообщению приложен файл: 1342519.xlsx(95.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Сводная не вариант?

Автор - Pelena
Дата добавления - 22.10.2019 в 18:40
Kuzmich Дата: Вторник, 22.10.2019, 19:32 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 411
Репутация: 82 ±
Замечаний: 0% ±

Excel 2003
Цитата
Однако в Базе попадаются иногда несколько кодов, соответствующих разным цветам

Только код K3-01BCEB1 соответствует трем значениям цвета и веса в Базе, все остальные уникальные
 
Ответить
Сообщение
Цитата
Однако в Базе попадаются иногда несколько кодов, соответствующих разным цветам

Только код K3-01BCEB1 соответствует трем значениям цвета и веса в Базе, все остальные уникальные

Автор - Kuzmich
Дата добавления - 22.10.2019 в 19:32
Yar4i Дата: Суббота, 26.10.2019, 16:45 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Сводная

Спасибо, это то что нужно
K3-01BCEB1 соответствует трем

Да, я сам его затроил, т.к. для примера нужны были плохие условия.
И я не удержался и создал клона на стороннем сайте. (извинить просим).

Рад, что с хостингом разрешилось.


Сообщение отредактировал Yar4i - Суббота, 26.10.2019, 16:53
 
Ответить
Сообщение
Сводная

Спасибо, это то что нужно
K3-01BCEB1 соответствует трем

Да, я сам его затроил, т.к. для примера нужны были плохие условия.
И я не удержался и создал клона на стороннем сайте. (извинить просим).

Рад, что с хостингом разрешилось.

Автор - Yar4i
Дата добавления - 26.10.2019 в 16:45
Yar4i Дата: Понедельник, 28.10.2019, 17:05 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 118
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Сводная

Пробовал свои данные вставить в сводную не выходит.
Вероятно я не правильно что-то делаю...
Создавал новую сводную, однако она берет данные только из одного листа, игнорируя второй лист.

***

Сводные не осилил.
Формулой решил и двойной раскладкой через формулу
Код
=ЕСЛИОШИБКА(НЕ(ПОИСКПОЗ($B2&$C2;Фамилия&Зарплата;0));ИСТИНА)


Сводные давно хотел испробовать (обязательно научусь, мне нужно).
спасибо вам +++
К сообщению приложен файл: 2222222.xlsx(24.8 Kb)


Сообщение отредактировал Yar4i - Вторник, 29.10.2019, 08:43
 
Ответить
Сообщение
Сводная

Пробовал свои данные вставить в сводную не выходит.
Вероятно я не правильно что-то делаю...
Создавал новую сводную, однако она берет данные только из одного листа, игнорируя второй лист.

***

Сводные не осилил.
Формулой решил и двойной раскладкой через формулу
Код
=ЕСЛИОШИБКА(НЕ(ПОИСКПОЗ($B2&$C2;Фамилия&Зарплата;0));ИСТИНА)


Сводные давно хотел испробовать (обязательно научусь, мне нужно).
спасибо вам +++

Автор - Yar4i
Дата добавления - 28.10.2019 в 17:05
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Найти идентичные данные и скопировать соседние ячейки (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!