Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Операции с видео таймкодом - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Операции с видео таймкодом (Формулы/Formulas)
Операции с видео таймкодом
dim34rus Дата: Понедельник, 23.01.2017, 23:55 | Сообщение № 21
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 10 ±
Замечаний: 0% ±

Excel 2007 - 2013
На примере 10-ой строки

Вместо всех A10 поставить
Код
ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""))

Вместо B10 соответственно
Код
ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""))


см. вложение
Для сложения
Код
=ТЕКСТ(ВРЕМЗНАЧ(ТЕКСТ(ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""))/100);"#0"":""00"":""00"))+ЕСЛИ(ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)>24;ВРЕМЗНАЧ("0:00:01");0)+ВРЕМЗНАЧ(ТЕКСТ(ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""))/100);"#0"":""00"":""00"));"чммсс")*100+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ЕСЛИ(ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)>24;25;0)


и для вычитания
Код
=ЕСЛИ(И((ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""))/100)-ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""))/100))=1;(ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100))<0);0;ТЕКСТ(ВРЕМЗНАЧ(ТЕКСТ(ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""))/100);"#0"":""00"":""00"))-ЕСЛИ(ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)<0;ВРЕМЗНАЧ("0:00:01");0)-ВРЕМЗНАЧ(ТЕКСТ(ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""))/100);"#0"":""00"":""00"));"чммсс")*100)+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)+ЕСЛИ((ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100))<0;25;0)


Правда, "колбаса" немного выросла
К сообщению приложен файл: 0855519.xlsx(12.6 Kb)


Извращение - это писать формулы в Word'овских таблицах.
ЯД 410014340958327


Сообщение отредактировал dim34rus - Вторник, 24.01.2017, 00:05
 
Ответить
СообщениеНа примере 10-ой строки

Вместо всех A10 поставить
Код
ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""))

Вместо B10 соответственно
Код
ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""))


см. вложение
Для сложения
Код
=ТЕКСТ(ВРЕМЗНАЧ(ТЕКСТ(ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""))/100);"#0"":""00"":""00"))+ЕСЛИ(ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)>24;ВРЕМЗНАЧ("0:00:01");0)+ВРЕМЗНАЧ(ТЕКСТ(ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""))/100);"#0"":""00"":""00"));"чммсс")*100+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ЕСЛИ(ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)>24;25;0)


и для вычитания
Код
=ЕСЛИ(И((ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""))/100)-ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""))/100))=1;(ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100))<0);0;ТЕКСТ(ВРЕМЗНАЧ(ТЕКСТ(ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""))/100);"#0"":""00"":""00"))-ЕСЛИ(ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)<0;ВРЕМЗНАЧ("0:00:01");0)-ВРЕМЗНАЧ(ТЕКСТ(ЦЕЛОЕ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""))/100);"#0"":""00"":""00"));"чммсс")*100)+ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100)+ЕСЛИ((ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(B10;":";""));100)-ОСТАТ(ЗНАЧЕН(ПОДСТАВИТЬ(A10;":";""));100))<0;25;0)


Правда, "колбаса" немного выросла

Автор - dim34rus
Дата добавления - 23.01.2017 в 23:55
krosav4ig Дата: Вторник, 24.01.2017, 03:03 | Сообщение № 22
Группа: Друзья
Ранг: Старожил
Сообщений: 2053
Репутация: 854 ±
Замечаний: 0% ±

Excel 2007,2010,2013
для разнобразия
сложение
Код
=ТЕКСТ(СУММ(ОСТАТ(ОТБР(ОСТАТ(ОТБР(СУММПРОИЗВ(ТЕКСТ(ПОДСТАВИТЬ(ТЕКСТ(A10:B10;"00\:00\:00\,00");":";",";3);"[с]")*25+ПРАВБ(A10:B10;2))/25^{1;1;1;0})/60^{2;1;0;0};60))*10^{6;4;2;0};9^9^{1;1;1;0}*25));"00\:00\:00\:00")

вычитание
Код
=ТЕКСТ(СУММ(ОСТАТ(ОТБР(ОСТАТ(ОТБР(СУММПРОИЗВ(ТЕКСТ(ПОДСТАВИТЬ(ТЕКСТ(A10:B10;"00\:00\:00\,00");":";",";3);"[с]")*25+ПРАВБ(A10:B10;2);{-1;1})/25^{1;1;1;0})/60^{2;1;0;0};9^9^{0;0;0;1}*60))*10^{6;4;2;0};9^9^{1;1;1;0}*25));"00\:00\:00\:00")
К сообщению приложен файл: 0233677.xlsx(12.1 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460

Сообщение отредактировал krosav4ig - Вторник, 24.01.2017, 03:09
 
Ответить
Сообщениедля разнобразия
сложение
Код
=ТЕКСТ(СУММ(ОСТАТ(ОТБР(ОСТАТ(ОТБР(СУММПРОИЗВ(ТЕКСТ(ПОДСТАВИТЬ(ТЕКСТ(A10:B10;"00\:00\:00\,00");":";",";3);"[с]")*25+ПРАВБ(A10:B10;2))/25^{1;1;1;0})/60^{2;1;0;0};60))*10^{6;4;2;0};9^9^{1;1;1;0}*25));"00\:00\:00\:00")

вычитание
Код
=ТЕКСТ(СУММ(ОСТАТ(ОТБР(ОСТАТ(ОТБР(СУММПРОИЗВ(ТЕКСТ(ПОДСТАВИТЬ(ТЕКСТ(A10:B10;"00\:00\:00\,00");":";",";3);"[с]")*25+ПРАВБ(A10:B10;2);{-1;1})/25^{1;1;1;0})/60^{2;1;0;0};9^9^{0;0;0;1}*60))*10^{6;4;2;0};9^9^{1;1;1;0}*25));"00\:00\:00\:00")

Автор - krosav4ig
Дата добавления - 24.01.2017 в 03:03
rybn1kov Дата: Суббота, 22.12.2018, 14:01 | Сообщение № 23
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Помогите, пожалуйста, решить задачу.

В таблице есть временной тайм код видео в формате (номер часа:минуты:секунды:кадры). То есть 01:36:33:15 = 0 часов 36 минут 33 секунды 15 кадров, а 02:21:14:01 = 1 час 21 минута 14 секунд 01 кадр.
Данные даны на скорости 25 кадров в секунду
Нужно пересчитать всё в 24 кадра в секунду. То есть получить точно такие же значения (номер часа:минуты:секунды:кадры) только на скорости 24 к/с.

Как мне кажется, решение тут в следующем: нужно придумать формулу, которая переведет 25-кадровый таймкод в кадры, разделит на 24 и переведет в исходный формат.

В таблице 2 столбца с таймкодами. Нужно пересчитать оба (но не меняя строчки)

Заранее спасибо!
К сообщению приложен файл: 4123275.xlsx(34.6 Kb)


Сообщение отредактировал rybn1kov - Суббота, 22.12.2018, 14:02
 
Ответить
СообщениеЗдравствуйте!
Помогите, пожалуйста, решить задачу.

В таблице есть временной тайм код видео в формате (номер часа:минуты:секунды:кадры). То есть 01:36:33:15 = 0 часов 36 минут 33 секунды 15 кадров, а 02:21:14:01 = 1 час 21 минута 14 секунд 01 кадр.
Данные даны на скорости 25 кадров в секунду
Нужно пересчитать всё в 24 кадра в секунду. То есть получить точно такие же значения (номер часа:минуты:секунды:кадры) только на скорости 24 к/с.

Как мне кажется, решение тут в следующем: нужно придумать формулу, которая переведет 25-кадровый таймкод в кадры, разделит на 24 и переведет в исходный формат.

В таблице 2 столбца с таймкодами. Нужно пересчитать оба (но не меняя строчки)

Заранее спасибо!

Автор - rybn1kov
Дата добавления - 22.12.2018 в 14:01
Pelena Дата: Суббота, 22.12.2018, 17:01 | Сообщение № 24
Группа: Админы
Ранг: Местный житель
Сообщений: 14009
Репутация: 3066 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
rybn1kov, прочитайте Правила форума и создайте свою тему. Тем более это раздел для Mac Excel


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеrybn1kov, прочитайте Правила форума и создайте свою тему. Тем более это раздел для Mac Excel

Автор - Pelena
Дата добавления - 22.12.2018 в 17:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Операции с видео таймкодом (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!