Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоподстановка данных со смещением - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Автоподстановка данных со смещением
Автоподстановка данных со смещением
Нович Дата: Среда, 06.12.2017, 21:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 4 ±
Замечаний: 0% ±

Здравствуйте профи.
Нуждаюсь в вашей помощи.
Есть книга с двумя листами. В первом листе бланк с данными, во втором сами данные в виде списка.
Нужно вставить данные в бланки (порядка 100 бланков)
в первые два бланка вставил по формуле (=Лист2!B2) и так заполнил полностью всю карточку. Вопрос, как создать автоподстановку данных со смещением по строкам? Так как простым перетаскиванием не получится, данные со второго листа должны переместиться на 17 строк ниже в следующем бланке. Чтоб было наглядно, приложил файл.
К сообщению приложен файл: 4790151.xlsx(33Kb)
 
Ответить
СообщениеЗдравствуйте профи.
Нуждаюсь в вашей помощи.
Есть книга с двумя листами. В первом листе бланк с данными, во втором сами данные в виде списка.
Нужно вставить данные в бланки (порядка 100 бланков)
в первые два бланка вставил по формуле (=Лист2!B2) и так заполнил полностью всю карточку. Вопрос, как создать автоподстановку данных со смещением по строкам? Так как простым перетаскиванием не получится, данные со второго листа должны переместиться на 17 строк ниже в следующем бланке. Чтоб было наглядно, приложил файл.

Автор - Нович
Дата добавления - 06.12.2017 в 21:24
_Boroda_ Дата: Среда, 06.12.2017, 21:39 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Пишете в каждую ячейку с формулой-ссылкой вот так
Код
=ИНДЕКС(Лист2!B:B;СЧЁТЕСЛИ($L$1:$L6;"*")+1)

Меняете только столбец у ИДЕКСа. Затем копируете весь блок и вставляете на сколько нужно вниз
К сообщению приложен файл: 4790151_14.xlsx(19Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПишете в каждую ячейку с формулой-ссылкой вот так
Код
=ИНДЕКС(Лист2!B:B;СЧЁТЕСЛИ($L$1:$L6;"*")+1)

Меняете только столбец у ИДЕКСа. Затем копируете весь блок и вставляете на сколько нужно вниз

Автор - _Boroda_
Дата добавления - 06.12.2017 в 21:39
Нович Дата: Среда, 06.12.2017, 21:55 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 4 ±
Замечаний: 0% ±

а во втором бланке, тот что рядом, нужна подстановка данных с первого бланка. Провожу по той же формуле?
 
Ответить
Сообщениеа во втором бланке, тот что рядом, нужна подстановка данных с первого бланка. Провожу по той же формуле?

Автор - Нович
Дата добавления - 06.12.2017 в 21:55
Нович Дата: Среда, 06.12.2017, 21:59 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 4 ±
Замечаний: 0% ±

что то не совсем понял как работает ваша формула?
Мне нужно вставлять данные с листа 2 в лист 1 с постоянным смещением в несколько строк, плюс копировать некоторые значения в соседнюю карту.
Можно по подробнее? Извиняюсь за непонятливость.
К сообщению приложен файл: 1651621.xlsx(16Kb)


Сообщение отредактировал Нович - Среда, 06.12.2017, 22:09
 
Ответить
Сообщениечто то не совсем понял как работает ваша формула?
Мне нужно вставлять данные с листа 2 в лист 1 с постоянным смещением в несколько строк, плюс копировать некоторые значения в соседнюю карту.
Можно по подробнее? Извиняюсь за непонятливость.

Автор - Нович
Дата добавления - 06.12.2017 в 21:59
_Igor_61 Дата: Среда, 06.12.2017, 23:03 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 238
Репутация: 44 ±
Замечаний: 20% ±

Excel 2007
Затем копируете весь блок и вставляете на сколько нужно вниз

1. Выделяете строки со 2-й по 17
2. CTRL+C
3. Выделяете строку 19
4. CTRL+V
5. Выделяете строку 36
6. см. п.4
и т.д.
К сообщению приложен файл: 4665831.xlsx(14Kb)
 
Ответить
Сообщение
Затем копируете весь блок и вставляете на сколько нужно вниз

1. Выделяете строки со 2-й по 17
2. CTRL+C
3. Выделяете строку 19
4. CTRL+V
5. Выделяете строку 36
6. см. п.4
и т.д.

Автор - _Igor_61
Дата добавления - 06.12.2017 в 23:03
_Boroda_ Дата: Среда, 06.12.2017, 23:11 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
_Igor_61, спасибо
Да, именно это я и имел в виду
Затем копируете весь блок и вставляете на сколько нужно вниз

Можно выделить (Контрл +С или Контрл + Инсерт) ячейки А3:О19, выделить 17*n ячеек вниз (n - количество предполагаемых блоков) и вставить (Контрл + V или Шифт + Инсерт)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение_Igor_61, спасибо
Да, именно это я и имел в виду
Затем копируете весь блок и вставляете на сколько нужно вниз

Можно выделить (Контрл +С или Контрл + Инсерт) ячейки А3:О19, выделить 17*n ячеек вниз (n - количество предполагаемых блоков) и вставить (Контрл + V или Шифт + Инсерт)

Автор - _Boroda_
Дата добавления - 06.12.2017 в 23:11
Нович Дата: Четверг, 07.12.2017, 01:08 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 4 ±
Замечаний: 0% ±

Всем спасибо, теперь разобрался полностью.
 
Ответить
СообщениеВсем спасибо, теперь разобрался полностью.

Автор - Нович
Дата добавления - 07.12.2017 в 01:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Автоподстановка данных со смещением
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!