Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Среднее значение разницы двух чисел за период - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее значение разницы двух чисел за период (Формулы/Formulas)
Среднее значение разницы двух чисел за период
Black-Cat Дата: Вторник, 29.12.2015, 02:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, уважаемые. Подскажите пжлст как правильно решить такой вопрос:
необходимо посчитать среднее значение разницы двух чисел за период указываемый пользователем.
Пробовал ваять формулу, но где-то ошибка.
К сообщению приложен файл: DiffAverage.xlsx(9.3 Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые. Подскажите пжлст как правильно решить такой вопрос:
необходимо посчитать среднее значение разницы двух чисел за период указываемый пользователем.
Пробовал ваять формулу, но где-то ошибка.

Автор - Black-Cat
Дата добавления - 29.12.2015 в 02:45
krosav4ig Дата: Вторник, 29.12.2015, 03:33 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2323
Репутация: 976 ±
Замечаний: 0% ±

Excel 2007,2010,2013
так нужно?
Код
=СРЗНАЧ(МУМНОЖ(СМЕЩ(A9:B9;;;D6);{1:-1}))


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениетак нужно?
Код
=СРЗНАЧ(МУМНОЖ(СМЕЩ(A9:B9;;;D6);{1:-1}))

Автор - krosav4ig
Дата добавления - 29.12.2015 в 03:33
_Boroda_ Дата: Вторник, 29.12.2015, 09:32 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Немассивная, нелетучая, с пустыми ячейками работает как с нулями
Код
=СУММПРОИЗВ((A9:ИНДЕКС(B9:B34;D6))*{1;-1})/D6
К сообщению приложен файл: DiffAverage_1.xlsx(10.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНемассивная, нелетучая, с пустыми ячейками работает как с нулями
Код
=СУММПРОИЗВ((A9:ИНДЕКС(B9:B34;D6))*{1;-1})/D6

Автор - _Boroda_
Дата добавления - 29.12.2015 в 09:32
Black-Cat Дата: Вторник, 29.12.2015, 12:16 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Великолепно. Спасибо вам, повелители екселя.
 
Ответить
СообщениеВеликолепно. Спасибо вам, повелители екселя.

Автор - Black-Cat
Дата добавления - 29.12.2015 в 12:16
Udik Дата: Вторник, 29.12.2015, 12:35 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 192 ±
Замечаний: 0% ±

Excel 2016 х 64
Летучка :)
Код
=СУММПРОИЗВ(СМЕЩ(A9;;;D6)-СМЕЩ(B9;;;D6))/D6
К сообщению приложен файл: 7491138.xlsx(11.7 Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеЛетучка :)
Код
=СУММПРОИЗВ(СМЕЩ(A9;;;D6)-СМЕЩ(B9;;;D6))/D6

Автор - Udik
Дата добавления - 29.12.2015 в 12:35
Black-Cat Дата: Среда, 30.12.2015, 02:32 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Господа. На сколько я понял, то формула считает среднее по следующим значениеям вниз от текущего (по наростанию строк). А мне нужно наоборот: что бы от текущего считала среднее в обратную сторону - вверх (по убыванию строк). Т.е к примеру D6=4, то F15= среднее значение от F15 до F12. для F16= среднее значение от F16 до F14.
Сори, что не уточнил этот момент изначально.
 
Ответить
СообщениеГоспода. На сколько я понял, то формула считает среднее по следующим значениеям вниз от текущего (по наростанию строк). А мне нужно наоборот: что бы от текущего считала среднее в обратную сторону - вверх (по убыванию строк). Т.е к примеру D6=4, то F15= среднее значение от F15 до F12. для F16= среднее значение от F16 до F14.
Сори, что не уточнил этот момент изначально.

Автор - Black-Cat
Дата добавления - 30.12.2015 в 02:32
ex Дата: Среда, 30.12.2015, 06:11 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Работаю в экселе несколько лет, сейчас появилась необходимость изучить программу глубже, и я понял, что мои знания очень скромны.( Пытаюсь разобрать формулы, предложенные для решения задачи, для этого разделяю их на части. У меня появилось несколько вопросов:
1) Почему у меня формула СУММПРОИЗВ считает не сумму произведений, а просто общую сумму диапазона?
2) Что дает умножение на {1;-1}?
Другие вопросы с вашего позволения задам позже.
К сообщению приложен файл: 8150530.xlsx(9.9 Kb)
 
Ответить
СообщениеДобрый день! Работаю в экселе несколько лет, сейчас появилась необходимость изучить программу глубже, и я понял, что мои знания очень скромны.( Пытаюсь разобрать формулы, предложенные для решения задачи, для этого разделяю их на части. У меня появилось несколько вопросов:
1) Почему у меня формула СУММПРОИЗВ считает не сумму произведений, а просто общую сумму диапазона?
2) Что дает умножение на {1;-1}?
Другие вопросы с вашего позволения задам позже.

Автор - ex
Дата добавления - 30.12.2015 в 06:11
_Boroda_ Дата: Среда, 30.12.2015, 07:49 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
1. Формулу =СУММПРОИЗВ(A9:ИНДЕКС(B9:B34;D6)) можно переписать как =СУММПРОИЗВ(A9:B15), а поскольку внутри СУММПРОИЗВ просто ссылки на ячейки, причем они в одном аргументе СУММПРОИЗВ, то она и складывает их.
2. {1;-1} умножает диапазон A9:B15 на 1 и -1. Первый столбец (А) на 1, а второй столбец (В) - на минус 1. Это нужно для того, что по условию задачи у нас "среднее значение разницы двух чисел". Если без этого, то получится сумма (см. п.1).
СУММПРОИЗВ с одним аргументом работает точно так, как обычная СУММ, но дело в том, что если бы мы написали СУММ(A9:B15*{1;-1}), то нам пришлось бы вводить эту формулу как формулу массива - одновременным нажатием Контрл Шифт Ентер, а с использованием СУММПРОИЗВ массивный ввод в данном случае не нужен.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение1. Формулу =СУММПРОИЗВ(A9:ИНДЕКС(B9:B34;D6)) можно переписать как =СУММПРОИЗВ(A9:B15), а поскольку внутри СУММПРОИЗВ просто ссылки на ячейки, причем они в одном аргументе СУММПРОИЗВ, то она и складывает их.
2. {1;-1} умножает диапазон A9:B15 на 1 и -1. Первый столбец (А) на 1, а второй столбец (В) - на минус 1. Это нужно для того, что по условию задачи у нас "среднее значение разницы двух чисел". Если без этого, то получится сумма (см. п.1).
СУММПРОИЗВ с одним аргументом работает точно так, как обычная СУММ, но дело в том, что если бы мы написали СУММ(A9:B15*{1;-1}), то нам пришлось бы вводить эту формулу как формулу массива - одновременным нажатием Контрл Шифт Ентер, а с использованием СУММПРОИЗВ массивный ввод в данном случае не нужен.

Автор - _Boroda_
Дата добавления - 30.12.2015 в 07:49
Udik Дата: Среда, 30.12.2015, 13:38 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 192 ±
Замечаний: 0% ±

Excel 2016 х 64
формула считает среднее по следующим значениеям вниз от текущего (

Моя берет от начала диапазона (А9) указанное количество строк (D6), подсчитывает разность в каждой строке, складывает их и делит на количество строк. Никакого текущего значения не используется.


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщение
формула считает среднее по следующим значениеям вниз от текущего (

Моя берет от начала диапазона (А9) указанное количество строк (D6), подсчитывает разность в каждой строке, складывает их и делит на количество строк. Никакого текущего значения не используется.

Автор - Udik
Дата добавления - 30.12.2015 в 13:38
_Boroda_ Дата: Среда, 30.12.2015, 13:50 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
F15= среднее значение от F15 до F12. для F16= среднее значение от F16 до F14.

Давайте определимся - для 16 считать нужно до 14 или до 13 строки? Если до 13, то так
Код
=ЕСЛИ(СЧЁТ(A$9:A9)<D$6;"";СУММПРОИЗВ((A9:ИНДЕКС(B$9:B9;СЧЁТ(B$9:B9)-D$6+1))*{1;-1})/D$6)

Опять немассивная и нелетучая (что для теперешнего Вашего случая может быть важно - строк-то может быть много)
Сори, что не уточнил этот момент изначально.

Еще Вы, если я правильно понял пост №6, не указали изначально, что нужно не просто в отдельной ячейке посчитать, а для каждой строки должен быть свой подсчет - это существенно.
К сообщению приложен файл: DiffAverage_1_1.xlsx(10.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
F15= среднее значение от F15 до F12. для F16= среднее значение от F16 до F14.

Давайте определимся - для 16 считать нужно до 14 или до 13 строки? Если до 13, то так
Код
=ЕСЛИ(СЧЁТ(A$9:A9)<D$6;"";СУММПРОИЗВ((A9:ИНДЕКС(B$9:B9;СЧЁТ(B$9:B9)-D$6+1))*{1;-1})/D$6)

Опять немассивная и нелетучая (что для теперешнего Вашего случая может быть важно - строк-то может быть много)
Сори, что не уточнил этот момент изначально.

Еще Вы, если я правильно понял пост №6, не указали изначально, что нужно не просто в отдельной ячейке посчитать, а для каждой строки должен быть свой подсчет - это существенно.

Автор - _Boroda_
Дата добавления - 30.12.2015 в 13:50
Udik Дата: Среда, 30.12.2015, 15:02 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 192 ±
Замечаний: 0% ±

Excel 2016 х 64
если для каждой строки вывод нужен

Код
=ЕСЛИ(СТРОКА()-8<$D$6;"";СУММПРОИЗВ(СМЕЩ(A9;;;-$D$6)-СМЕЩ(B9;;;-$D$6))/$D$6)
К сообщению приложен файл: 6885473.xlsx(13.0 Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеесли для каждой строки вывод нужен

Код
=ЕСЛИ(СТРОКА()-8<$D$6;"";СУММПРОИЗВ(СМЕЩ(A9;;;-$D$6)-СМЕЩ(B9;;;-$D$6))/$D$6)

Автор - Udik
Дата добавления - 30.12.2015 в 15:02
Black-Cat Дата: Среда, 30.12.2015, 17:54 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Еще Вы, если я правильно понял пост №6, не указали изначально, что нужно не просто в отдельной ячейке посчитать, а для каждой строки должен быть свой подсчет - это существенно.


Да, вы правы. Для каждой строки должен быть свой подсчет.
Все равно у меня не сходится с расчетами руками (выделил салатовым) и результатами в формуле. (
К сообщению приложен файл: DiffAverage_1_2.xlsx(12.0 Kb)
 
Ответить
Сообщение
Еще Вы, если я правильно понял пост №6, не указали изначально, что нужно не просто в отдельной ячейке посчитать, а для каждой строки должен быть свой подсчет - это существенно.


Да, вы правы. Для каждой строки должен быть свой подсчет.
Все равно у меня не сходится с расчетами руками (выделил салатовым) и результатами в формуле. (

Автор - Black-Cat
Дата добавления - 30.12.2015 в 17:54
Udik Дата: Среда, 30.12.2015, 18:05 | Сообщение № 13
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 192 ±
Замечаний: 0% ±

Excel 2016 х 64
Вы берете 4 пустые/текстовые строки, 1 с числовыми данными вычисляете среднее арифметическое и делите его на 2 %)
Код
=СРЗНАЧ(F5:F9)/2


я не понимаю чего вы хотите получить
К сообщению приложен файл: 3098732.jpg(29.8 Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Среда, 30.12.2015, 18:12
 
Ответить
СообщениеВы берете 4 пустые/текстовые строки, 1 с числовыми данными вычисляете среднее арифметическое и делите его на 2 %)
Код
=СРЗНАЧ(F5:F9)/2


я не понимаю чего вы хотите получить

Автор - Udik
Дата добавления - 30.12.2015 в 18:05
_Boroda_ Дата: Среда, 30.12.2015, 18:13 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И мою формулу переделали зачем-то. Вот так нужно
К сообщению приложен файл: 5210444.xlsx(11.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ мою формулу переделали зачем-то. Вот так нужно

Автор - _Boroda_
Дата добавления - 30.12.2015 в 18:13
Black-Cat Дата: Среда, 30.12.2015, 20:52 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Вы берете 4 пустые/текстовые строки, 1 с числовыми данными вычисляете среднее арифметическое и делите его на 2


Спешил. Там, вы все верно подметили, нужно начинать отсчет со строки 13. )

И мою формулу переделали зачем-то. Вот так нужно

Думал, что в конце формулы вы перепутали и поделили на D6, а в условии надо поделить на 2. Теперь добавил еще деление в виде коефициента.
Все работает как и задумано.

Спасибо уважаемым участникам форума.
 
Ответить
Сообщение
Вы берете 4 пустые/текстовые строки, 1 с числовыми данными вычисляете среднее арифметическое и делите его на 2


Спешил. Там, вы все верно подметили, нужно начинать отсчет со строки 13. )

И мою формулу переделали зачем-то. Вот так нужно

Думал, что в конце формулы вы перепутали и поделили на D6, а в условии надо поделить на 2. Теперь добавил еще деление в виде коефициента.
Все работает как и задумано.

Спасибо уважаемым участникам форума.

Автор - Black-Cat
Дата добавления - 30.12.2015 в 20:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее значение разницы двух чисел за период (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!