Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Два условия, при достижении которых, проверка прекращается - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Два условия, при достижении которых, проверка прекращается (Формулы/Formulas)
Два условия, при достижении которых, проверка прекращается
skr Дата: Вторник, 05.01.2016, 23:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Возможно ли решить задачку без макросов.
Идет проверка 2 отдельных столбцов на соответствие определенных условий.
При первом достижении соответствия одновременно обоих условий, проставляется значение 0 в столбце результатов
В дальнейшем проверка нижележащих строк не актуальна и в столбце результатов проставляется нули
К сообщению приложен файл: 1054433.xls(26Kb)
 
Ответить
СообщениеЗдравствуйте!
Возможно ли решить задачку без макросов.
Идет проверка 2 отдельных столбцов на соответствие определенных условий.
При первом достижении соответствия одновременно обоих условий, проставляется значение 0 в столбце результатов
В дальнейшем проверка нижележащих строк не актуальна и в столбце результатов проставляется нули

Автор - skr
Дата добавления - 05.01.2016 в 23:19
Michael_S Дата: Вторник, 05.01.2016, 23:37 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1831
Репутация: 343 ±
Замечаний: 0% ±

Excel2016
как вариант:
К сообщению приложен файл: skr.xls(28Kb)


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщениекак вариант:

Автор - Michael_S
Дата добавления - 05.01.2016 в 23:37
SLAVICK Дата: Вторник, 05.01.2016, 23:43 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 2002
Репутация: 673 ±
Замечаний: 0% ±

2007,2010,2013,2016
Так?:
Код
=ЕСЛИ(D2=0;0;ЕСЛИ(A3<0,12;ЕСЛИ(B3<7;"x"&СТРОКА(A2);0);"x"&СТРОКА(A2)))
К сообщению приложен файл: 2358120.xls(27Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеТак?:
Код
=ЕСЛИ(D2=0;0;ЕСЛИ(A3<0,12;ЕСЛИ(B3<7;"x"&СТРОКА(A2);0);"x"&СТРОКА(A2)))

Автор - SLAVICK
Дата добавления - 05.01.2016 в 23:43
Ant12345 Дата: Вторник, 05.01.2016, 23:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(C1<>0;ЕСЛИ(И(A2<0,12;B2>7);0;"x");0)


Сообщение отредактировал Ant12345 - Вторник, 05.01.2016, 23:50
 
Ответить
Сообщение
Код
=ЕСЛИ(C1<>0;ЕСЛИ(И(A2<0,12;B2>7);0;"x");0)

Автор - Ant12345
Дата добавления - 05.01.2016 в 23:48
_Boroda_ Дата: Среда, 06.01.2016, 05:30 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11297
Репутация: 4661 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А почему не учитывается вариант, когда сразу же (во второй строке) выполняются оба условия?
Предлагаю такие варианты:
Для простановки просто "х" -
Код
=((A2>=0,12)+(B2<=7))*(C1&""<>"0")
и формат ячеек "х";;0
Или с обычным форматом
Код
=ЕСЛИ(((A2>=0,12)+(B2<=7))*(C1&""<>"0");"х";)

Для нумерации иксов
Код
=ЕСЛИ(((A2>=0,12)+(B2<=7))*(C1&""<>"0");"х"&СТРОКА(E1);)
К сообщению приложен файл: 1054433_1.xls(32Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА почему не учитывается вариант, когда сразу же (во второй строке) выполняются оба условия?
Предлагаю такие варианты:
Для простановки просто "х" -
Код
=((A2>=0,12)+(B2<=7))*(C1&""<>"0")
и формат ячеек "х";;0
Или с обычным форматом
Код
=ЕСЛИ(((A2>=0,12)+(B2<=7))*(C1&""<>"0");"х";)

Для нумерации иксов
Код
=ЕСЛИ(((A2>=0,12)+(B2<=7))*(C1&""<>"0");"х"&СТРОКА(E1);)

Автор - _Boroda_
Дата добавления - 06.01.2016 в 05:30
skr Дата: Среда, 06.01.2016, 09:00 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо светлым головам за оперативность.
 
Ответить
СообщениеСпасибо светлым головам за оперативность.

Автор - skr
Дата добавления - 06.01.2016 в 09:00
skr Дата: Среда, 06.01.2016, 10:34 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Похоже не совсем правильно поставил условия задачи.
Потому выдрал кусок из реальной задачи, прикрепленный снизу
Не могу избавится от значений после достижения условий.
Поправьте где не так.
К сообщению приложен файл: -2.xls(32Kb)
 
Ответить
СообщениеПохоже не совсем правильно поставил условия задачи.
Потому выдрал кусок из реальной задачи, прикрепленный снизу
Не могу избавится от значений после достижения условий.
Поправьте где не так.

Автор - skr
Дата добавления - 06.01.2016 в 10:34
mathiax90 Дата: Среда, 06.01.2016, 10:50 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 173
Репутация: 20 ±
Замечаний: 20% ±

Excel 2007
Предлагаю добавить еще одно условие на проверку предыдущего значения. Т.е. если выщележащая ячейка О равна нулю, то и эта равна нулю.
Это лучше сделать это первым условием, чтобы уменьшить затраты на холостые операции.


webmoney: R242692021885
ЯД:410013877261817


Сообщение отредактировал mathiax90 - Среда, 06.01.2016, 11:13
 
Ответить
СообщениеПредлагаю добавить еще одно условие на проверку предыдущего значения. Т.е. если выщележащая ячейка О равна нулю, то и эта равна нулю.
Это лучше сделать это первым условием, чтобы уменьшить затраты на холостые операции.

Автор - mathiax90
Дата добавления - 06.01.2016 в 10:50
mathiax90 Дата: Среда, 06.01.2016, 10:59 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 173
Репутация: 20 ±
Замечаний: 20% ±

Excel 2007
Пример в приложении.
Минусы:
- название столбца с формулой должно быть цифра (у меня в примере там стоит единица)
или
- формула для первой ячейки отличается от остальных (убирается условие проверки предыдущего результата):
Код
=ЕСЛИ(C2<0,12;ЕСЛИ(D2>7;0;B2);A2)
К сообщению приложен файл: 4280672.xls(21Kb)


webmoney: R242692021885
ЯД:410013877261817


Сообщение отредактировал mathiax90 - Среда, 06.01.2016, 10:59
 
Ответить
СообщениеПример в приложении.
Минусы:
- название столбца с формулой должно быть цифра (у меня в примере там стоит единица)
или
- формула для первой ячейки отличается от остальных (убирается условие проверки предыдущего результата):
Код
=ЕСЛИ(C2<0,12;ЕСЛИ(D2>7;0;B2);A2)

Автор - mathiax90
Дата добавления - 06.01.2016 в 10:59
skr Дата: Среда, 06.01.2016, 11:32 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо наконец разобрался
 
Ответить
СообщениеСпасибо наконец разобрался

Автор - skr
Дата добавления - 06.01.2016 в 11:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Два условия, при достижении которых, проверка прекращается (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!