Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и подсчет по текстовому значению в ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подсчет по текстовому значению в ячейке (Формулы/Formulas)
Поиск и подсчет по текстовому значению в ячейке
blackfox980 Дата: Понедельник, 11.01.2016, 11:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
День добрый. Столкнулся со следующей проблемой. Есть таблица, в которой есть два важных поля Тип дела и Код организации. В поле Тип дела содержатся несколько текстовых значений , которые нужно сортировать для каждой организации, то есть например Код орг.001 - Тип дела 1 = 200 записей, Тип дела 2 =100 записей. Я делал это через фильтр, выбирая нужный тип и код фирмы и как бы устраивало, по времени не очень долго. Но хотелось бы,чтобы значения при открытии считались на отдельном листе. О поиске и подсчете одинаковых значений в столбе я читал, но как связать это с выборкой по определенной фирме не соображу. Пример вложил.
К сообщению приложен файл: 9297317.xls(28Kb)


Сообщение отредактировал blackfox980 - Понедельник, 11.01.2016, 11:43
 
Ответить
СообщениеДень добрый. Столкнулся со следующей проблемой. Есть таблица, в которой есть два важных поля Тип дела и Код организации. В поле Тип дела содержатся несколько текстовых значений , которые нужно сортировать для каждой организации, то есть например Код орг.001 - Тип дела 1 = 200 записей, Тип дела 2 =100 записей. Я делал это через фильтр, выбирая нужный тип и код фирмы и как бы устраивало, по времени не очень долго. Но хотелось бы,чтобы значения при открытии считались на отдельном листе. О поиске и подсчете одинаковых значений в столбе я читал, но как связать это с выборкой по определенной фирме не соображу. Пример вложил.

Автор - blackfox980
Дата добавления - 11.01.2016 в 11:32
Pelena Дата: Понедельник, 11.01.2016, 11:36 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10468
Репутация: 2362 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
По описанию задачка для сводной таблицы. Подробнее при наличии файла с примером


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
По описанию задачка для сводной таблицы. Подробнее при наличии файла с примером

Автор - Pelena
Дата добавления - 11.01.2016 в 11:36
SLAVICK Дата: Понедельник, 11.01.2016, 11:49 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1926
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
Как сказала Pelena, сводная в помощь.

Перевложил файл.
К сообщению приложен файл: 6480101.xls(26Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеКак сказала Pelena, сводная в помощь.

Перевложил файл.

Автор - SLAVICK
Дата добавления - 11.01.2016 в 11:49
_Boroda_ Дата: Понедельник, 11.01.2016, 11:52 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9834
Репутация: 4152 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Или сводной, как Лена уже сказала, или формулой
Код
=СЧЁТЕСЛИМН(Данные!$A$2:$A$999;$A2;Данные!$C$2:$C$999;B$1)

Оба варианта в файле
К сообщению приложен файл: 9297317_1.xls(52Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИли сводной, как Лена уже сказала, или формулой
Код
=СЧЁТЕСЛИМН(Данные!$A$2:$A$999;$A2;Данные!$C$2:$C$999;B$1)

Оба варианта в файле

Автор - _Boroda_
Дата добавления - 11.01.2016 в 11:52
Russel Дата: Понедельник, 11.01.2016, 11:55 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1252
Репутация: 284 ±
Замечаний: 0% ±

Excel 2010
Еще вариант:
Код
=СУММПРОИЗВ((Данные!$A$2:$A$999=$A2)*(Данные!$C$2:$C$999=B$1))


QIWI 9173973973
 
Ответить
СообщениеЕще вариант:
Код
=СУММПРОИЗВ((Данные!$A$2:$A$999=$A2)*(Данные!$C$2:$C$999=B$1))

Автор - Russel
Дата добавления - 11.01.2016 в 11:55
blackfox980 Дата: Понедельник, 11.01.2016, 11:58 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Блин, все гениальное просто, спасибо всем. hands
 
Ответить
СообщениеБлин, все гениальное просто, спасибо всем. hands

Автор - blackfox980
Дата добавления - 11.01.2016 в 11:58
китин Дата: Понедельник, 11.01.2016, 12:03 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3731
Репутация: 590 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или так можно
Код
=СУММПРОИЗВ(ЕТЕКСТ(Данные!$A$2:$A$99)*(Данные!$A$2:$A$99=Итоги!$A2)*(Итоги!B$1=Данные!$C$2:$C$99))

[p.s.]перемудрил, правда :'(
К сообщению приложен файл: blackfox980.xls(32Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 11.01.2016, 12:04
 
Ответить
Сообщениеили так можно
Код
=СУММПРОИЗВ(ЕТЕКСТ(Данные!$A$2:$A$99)*(Данные!$A$2:$A$99=Итоги!$A2)*(Итоги!B$1=Данные!$C$2:$C$99))

[p.s.]перемудрил, правда :'(

Автор - китин
Дата добавления - 11.01.2016 в 12:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подсчет по текстовому значению в ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!