Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание динамического списка клиентов по месяцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание динамического списка клиентов по месяцам (Формулы/Formulas)
Создание динамического списка клиентов по месяцам
zzbear Дата: Вторник, 12.01.2016, 11:25 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 89
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день.

Есть уникальный список клиентов (вкладка Список клиентов)

Есть список месяцев (вкладка Список месяцев)

Необходимо создать динамический список по примеру на вкладке (Отчет) который будет сводить Список клиентов со Списком месяцев посредством формулы т.к возможно в дальнейшем изменение списка клиентов и необходимые для отчета месяцы.

Спасибо
К сообщению приложен файл: ___.xlsx(12Kb)
 
Ответить
СообщениеДобрый день.

Есть уникальный список клиентов (вкладка Список клиентов)

Есть список месяцев (вкладка Список месяцев)

Необходимо создать динамический список по примеру на вкладке (Отчет) который будет сводить Список клиентов со Списком месяцев посредством формулы т.к возможно в дальнейшем изменение списка клиентов и необходимые для отчета месяцы.

Спасибо

Автор - zzbear
Дата добавления - 12.01.2016 в 11:25
_Boroda_ Дата: Вторник, 12.01.2016, 11:41 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Клиенты
Код
=ИНДЕКС('Список клиентов'!A:A;(СТРОКА()-2)/СЧЁТЗ('Список месяцев'!B:B)+2)

Периоды
Код
=ИНДЕКС('Список месяцев'!A:A;СЧЁТЕСЛИ($E$2:$E2;$E2))

Условное форматирование для жирных
Код
=ПОИСК("Итого";$G2)
К сообщению приложен файл: 267529.xlsx(17Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Клиенты
Код
=ИНДЕКС('Список клиентов'!A:A;(СТРОКА()-2)/СЧЁТЗ('Список месяцев'!B:B)+2)

Периоды
Код
=ИНДЕКС('Список месяцев'!A:A;СЧЁТЕСЛИ($E$2:$E2;$E2))

Условное форматирование для жирных
Код
=ПОИСК("Итого";$G2)

Автор - _Boroda_
Дата добавления - 12.01.2016 в 11:41
Udik Дата: Вторник, 12.01.2016, 11:47 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1589
Репутация: 192 ±
Замечаний: 0% ±

Excel 2016 х 64
а зачем список месяцев?
можно же ДАТАМЕС() задействовать, или аналог, если эта функция отсутствует


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеа зачем список месяцев?
можно же ДАТАМЕС() задействовать, или аналог, если эта функция отсутствует

Автор - Udik
Дата добавления - 12.01.2016 в 11:47
китин Дата: Вторник, 12.01.2016, 12:17 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4351
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
почти так же как и у Саши _Boroda_,
Код
=ИНДЕКС('Список клиентов'!$A$2:$A$10000;ЦЕЛОЕ((СТРОКА(A1)-1)/СЧЁТЗ('Список месяцев'!$B:$B))+1)
К сообщению приложен файл: zzbear.xlsx(88Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениепочти так же как и у Саши _Boroda_,
Код
=ИНДЕКС('Список клиентов'!$A$2:$A$10000;ЦЕЛОЕ((СТРОКА(A1)-1)/СЧЁТЗ('Список месяцев'!$B:$B))+1)

Автор - китин
Дата добавления - 12.01.2016 в 12:17
zzbear Дата: Вторник, 12.01.2016, 12:45 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 89
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо всем!
 
Ответить
СообщениеСпасибо всем!

Автор - zzbear
Дата добавления - 12.01.2016 в 12:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание динамического списка клиентов по месяцам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!