Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округление в заданном ряде данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление в заданном ряде данных (Формулы/Formulas)
Округление в заданном ряде данных
sashhv Дата: Четверг, 14.01.2016, 14:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

Прошу подсказать формулу которая будет находить диапазон, в котором находится число и округлять его согласно принципу округления "к ближайшему целому".
В приложенном файле дополнительное описание.

Спасибо.
К сообщению приложен файл: 6378562.xlsx(10Kb)
 
Ответить
СообщениеДобрый день!

Прошу подсказать формулу которая будет находить диапазон, в котором находится число и округлять его согласно принципу округления "к ближайшему целому".
В приложенном файле дополнительное описание.

Спасибо.

Автор - sashhv
Дата добавления - 14.01.2016 в 14:54
Nic70y Дата: Четверг, 14.01.2016, 15:09 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3656
Репутация: 752 ±
Замечаний: 0% ±

Excel 2013
{формула массива вводится одновременным нажатием Ctrl Shift Enter}
Код
=ИНДЕКС(D$3:D$24;ПОИСКПОЗ(МИН(ABS(D$3:D$24-A3));ABS(D$3:D$24-A3);))
К сообщению приложен файл: 3566746.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение{формула массива вводится одновременным нажатием Ctrl Shift Enter}
Код
=ИНДЕКС(D$3:D$24;ПОИСКПОЗ(МИН(ABS(D$3:D$24-A3));ABS(D$3:D$24-A3);))

Автор - Nic70y
Дата добавления - 14.01.2016 в 15:09
Udik Дата: Четверг, 14.01.2016, 15:28 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1293
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
у меня такое получилось
Код
=ЕСЛИ(A5>=(ОКРВВЕРХ(A5;D5)- D5/2);ОКРВВЕРХ(A5;D5);ОКРВВЕРХ(A5;D5)-D5)


округление по математическим правилам: меньше середины - вниз, больше - вверх.

Поэтому не совпадает с авторским. Например для 456,3792828 и 7, ближайшие числа 455 и 462, середина 458,5
число меньше середины, значит вниз округляем (до 455). В файле округляют до 540, может я не так понял задание.
==
да чёт я совсем не то сделал
К сообщению приложен файл: 9475727.xlsx(12Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Четверг, 14.01.2016, 15:59
 
Ответить
Сообщениеу меня такое получилось
Код
=ЕСЛИ(A5>=(ОКРВВЕРХ(A5;D5)- D5/2);ОКРВВЕРХ(A5;D5);ОКРВВЕРХ(A5;D5)-D5)


округление по математическим правилам: меньше середины - вниз, больше - вверх.

Поэтому не совпадает с авторским. Например для 456,3792828 и 7, ближайшие числа 455 и 462, середина 458,5
число меньше середины, значит вниз округляем (до 455). В файле округляют до 540, может я не так понял задание.
==
да чёт я совсем не то сделал

Автор - Udik
Дата добавления - 14.01.2016 в 15:28
_Boroda_ Дата: Четверг, 14.01.2016, 16:04 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9795
Репутация: 4138 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А у меня так
Код
=ИНДЕКС(D$2:D$24;ПОИСКПОЗ(A3;(D$3:D$24+ТЕКСТ(D$2:D$23;"0;;;\0"))/2)+1)

Тоже формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Правильно считает 45 дней, но дает ошибку если меньше 7
К сообщению приложен файл: 6378562_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА у меня так
Код
=ИНДЕКС(D$2:D$24;ПОИСКПОЗ(A3;(D$3:D$24+ТЕКСТ(D$2:D$23;"0;;;\0"))/2)+1)

Тоже формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Правильно считает 45 дней, но дает ошибку если меньше 7

Автор - _Boroda_
Дата добавления - 14.01.2016 в 16:04
Udik Дата: Четверг, 14.01.2016, 19:14 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1293
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
попробовал немассивку наваять
Код
=ЕСЛИ(A3<=$D$3;$D$3;ИНДЕКС(d3_;СУММПРОИЗВ((A3>=d3_)*(A3<d4_);СТРОКА(d3_)-2)+(A3>=СУММПРОИЗВ((d3_+d4_)/2;(A3>=d3_)*(A3<d4_)))))

имеется пара именованных диапазонов и добавочная ячейка
К сообщению приложен файл: 2530607.xlsx(12Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениепопробовал немассивку наваять
Код
=ЕСЛИ(A3<=$D$3;$D$3;ИНДЕКС(d3_;СУММПРОИЗВ((A3>=d3_)*(A3<d4_);СТРОКА(d3_)-2)+(A3>=СУММПРОИЗВ((d3_+d4_)/2;(A3>=d3_)*(A3<d4_)))))

имеется пара именованных диапазонов и добавочная ячейка

Автор - Udik
Дата добавления - 14.01.2016 в 19:14
Gustav Дата: Четверг, 14.01.2016, 19:55 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1249
Репутация: 490 ±
Замечаний: 0% ±

начинал с Excel 4.0...
А я пришпандорил слева от столбца "Дни" столбец с полусуммами соседних значений и ищу по нему при помощи ВПР - получилось простенько и прозрачненько:


Код
=ВПР(A3;$D$3:$E$25;2)
К сообщению приложен файл: sash_vpr.xlsx(11Kb)


Мой tip box - яд 41001663842605

Сообщение отредактировал Gustav - Четверг, 14.01.2016, 19:57
 
Ответить
СообщениеА я пришпандорил слева от столбца "Дни" столбец с полусуммами соседних значений и ищу по нему при помощи ВПР - получилось простенько и прозрачненько:


Код
=ВПР(A3;$D$3:$E$25;2)

Автор - Gustav
Дата добавления - 14.01.2016 в 19:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление в заданном ряде данных (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!