Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/динамический счетчик только видимых строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » динамический счетчик только видимых строк (Формулы/Formulas)
динамический счетчик только видимых строк
Совес Дата: Среда, 20.01.2016, 12:52 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 3 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте многоуважаемые!

Вводная:
Есть три группы курьеров: пешеходы, собственные машины, привлеченные машины (см.пример)
Новые сотрудники добавляются в конец списка своей категории в специально обозначенные ячейки.
Чистить строки нельзя, они являются источником данных для других листов.

Дано:
Прикрепленная страница - используется как бланк, есть необходимость скрывать от печати да и от глаз,те строки в которых сотрудники уволены
Есть два элементарных счетчика в ограниченном диапазоне: кол-во курьеров в каждой категории и кол-во курьеров всего

Задача:
Сделать оба счетчика таким образом, чтоб они не считали скрытые ячейки (это в которых статус сотрудника "уволен" или "Заполнять на стр. Список курьеров").
т.е. Сотрудник проставил статус курьера "уволен", скрыл строку или добавил в заготовленную строку нового курьера - счетчик обновился пересчитав видимые строки.

Мои запросы вообще реальны?
Надеюсь внятно описал что мне нужно. Заранее спасибо всем кто не прошел мимо темы.
К сообщению приложен файл: 0603458.xlsx(97Kb)
 
Ответить
СообщениеЗдравствуйте многоуважаемые!

Вводная:
Есть три группы курьеров: пешеходы, собственные машины, привлеченные машины (см.пример)
Новые сотрудники добавляются в конец списка своей категории в специально обозначенные ячейки.
Чистить строки нельзя, они являются источником данных для других листов.

Дано:
Прикрепленная страница - используется как бланк, есть необходимость скрывать от печати да и от глаз,те строки в которых сотрудники уволены
Есть два элементарных счетчика в ограниченном диапазоне: кол-во курьеров в каждой категории и кол-во курьеров всего

Задача:
Сделать оба счетчика таким образом, чтоб они не считали скрытые ячейки (это в которых статус сотрудника "уволен" или "Заполнять на стр. Список курьеров").
т.е. Сотрудник проставил статус курьера "уволен", скрыл строку или добавил в заготовленную строку нового курьера - счетчик обновился пересчитав видимые строки.

Мои запросы вообще реальны?
Надеюсь внятно описал что мне нужно. Заранее спасибо всем кто не прошел мимо темы.

Автор - Совес
Дата добавления - 20.01.2016 в 12:52
buchlotnik Дата: Среда, 20.01.2016, 12:59 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3120
Репутация: 853 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
счётчики не нашёл в примере. Думаю вам нужно что-то вроде
Код
=АГРЕГАТ(3;5;C3:C73)
К сообщению приложен файл: 5467317.xlsx(97Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениесчётчики не нашёл в примере. Думаю вам нужно что-то вроде
Код
=АГРЕГАТ(3;5;C3:C73)

Автор - buchlotnik
Дата добавления - 20.01.2016 в 12:59
YouGreed Дата: Среда, 20.01.2016, 12:59 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
Совес, Попробуйте покрутить функцию "Промежуточные.Итоги", первый аргумент - 3.
 
Ответить
СообщениеСовес, Попробуйте покрутить функцию "Промежуточные.Итоги", первый аргумент - 3.

Автор - YouGreed
Дата добавления - 20.01.2016 в 12:59
_Boroda_ Дата: Среда, 20.01.2016, 13:01 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Есть два элементарных счетчика

Где?
Без понимания что-откуда-куда-почему могу посоветовать только использовать или
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;диапазон)

или
Код
=счёт(A9:A18)-счётесли(H9:H18;"уволен")-счётесли(H9:H18;"Заполнять на стр. Список курьеров")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Есть два элементарных счетчика

Где?
Без понимания что-откуда-куда-почему могу посоветовать только использовать или
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;диапазон)

или
Код
=счёт(A9:A18)-счётесли(H9:H18;"уволен")-счётесли(H9:H18;"Заполнять на стр. Список курьеров")

Автор - _Boroda_
Дата добавления - 20.01.2016 в 13:01
Совес Дата: Среда, 20.01.2016, 13:04 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 3 ±
Замечаний: 0% ±

Excel 2010
То что я назвал счетчиками, находится в колонках A и B
 
Ответить
СообщениеТо что я назвал счетчиками, находится в колонках A и B

Автор - Совес
Дата добавления - 20.01.2016 в 13:04
Совес Дата: Среда, 20.01.2016, 13:22 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 3 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, судя по вашей реакции, то что я назвал счетчиками, называется как то иначе. И находится это в колонках A и B

Извините мое косноязычие и не правильную формулировку задачи.

Мне нужно чтоб отображалась нумерация видимых строк
 
Ответить
Сообщение_Boroda_, судя по вашей реакции, то что я назвал счетчиками, называется как то иначе. И находится это в колонках A и B

Извините мое косноязычие и не правильную формулировку задачи.

Мне нужно чтоб отображалась нумерация видимых строк

Автор - Совес
Дата добавления - 20.01.2016 в 13:22
buchlotnik Дата: Среда, 20.01.2016, 13:23 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3120
Репутация: 853 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно так: общий
Код
=АГРЕГАТ(3;5;$C$3:C3)
в группе
Код
=ЕСЛИ(B2="";1;B2+1)
с группой как-то мудрёно вышло :(
Код
=АГРЕГАТ(3;5;ДВССЫЛ("c"&ПРОСМОТР(1;1/($C$1:C2="");СТРОКА($C$1:C2))+1&":C"&СТРОКА()))
К сообщению приложен файл: 0603458-1-.xlsx(99Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 20.01.2016, 13:36
 
Ответить
Сообщениеможно так: общий
Код
=АГРЕГАТ(3;5;$C$3:C3)
в группе
Код
=ЕСЛИ(B2="";1;B2+1)
с группой как-то мудрёно вышло :(
Код
=АГРЕГАТ(3;5;ДВССЫЛ("c"&ПРОСМОТР(1;1/($C$1:C2="");СТРОКА($C$1:C2))+1&":C"&СТРОКА()))

Автор - buchlotnik
Дата добавления - 20.01.2016 в 13:23
Совес Дата: Среда, 20.01.2016, 13:30 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 3 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, спасибо большое - это то что нужно.
 
Ответить
Сообщениеbuchlotnik, спасибо большое - это то что нужно.

Автор - Совес
Дата добавления - 20.01.2016 в 13:30
Pelena Дата: Среда, 20.01.2016, 13:34 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11604
Репутация: 2573 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Ещё вариант
К сообщению приложен файл: 9940624.xlsx(99Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант

Автор - Pelena
Дата добавления - 20.01.2016 в 13:34
_Boroda_ Дата: Среда, 20.01.2016, 13:39 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А я бы вот так написал
Код
=ЕСЛИ(C3<>"Заполнять на стр. Список курьеров";АГРЕГАТ(4;7;A$1:A2)+1;"")

и
Код
=ЕСЛИ(C3<>"Заполнять на стр. Список курьеров";АГРЕГАТ(4;7;B2:ИНДЕКС(B$1:B2;ПРОСМОТР(;-1/(B$1:B2="");СТРОКА(B$1:B2))))+1;"")
К сообщению приложен файл: 0603458_1.xlsx(99Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА я бы вот так написал
Код
=ЕСЛИ(C3<>"Заполнять на стр. Список курьеров";АГРЕГАТ(4;7;A$1:A2)+1;"")

и
Код
=ЕСЛИ(C3<>"Заполнять на стр. Список курьеров";АГРЕГАТ(4;7;B2:ИНДЕКС(B$1:B2;ПРОСМОТР(;-1/(B$1:B2="");СТРОКА(B$1:B2))))+1;"")

Автор - _Boroda_
Дата добавления - 20.01.2016 в 13:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » динамический счетчик только видимых строк (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!