Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма/максимальное по условию(в условии содержится текст) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма/максимальное по условию(в условии содержится текст) (Формулы/Formulas)
Сумма/максимальное по условию(в условии содержится текст)
lFJl Дата: Среда, 20.01.2016, 13:56 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 214
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
Доброго времени суток!
Подскажите пожалуйста, всю голову уже сломал, а задача вроде простецкая...
Есть таблица в заголовке даты, ниже день недели, еще ниже данные за каждый день.
Нужно сумму, максимальное по заданному диапазону
И сумму и максимальное по дням недели
В таблице периодически присутствует текст, как в датах, так и в значениях.
Пример приложил, в нем все описал.
Спасибо заранее! :)
К сообщению приложен файл: ___.xlsx(13Kb)
 
Ответить
СообщениеДоброго времени суток!
Подскажите пожалуйста, всю голову уже сломал, а задача вроде простецкая...
Есть таблица в заголовке даты, ниже день недели, еще ниже данные за каждый день.
Нужно сумму, максимальное по заданному диапазону
И сумму и максимальное по дням недели
В таблице периодически присутствует текст, как в датах, так и в значениях.
Пример приложил, в нем все описал.
Спасибо заранее! :)

Автор - lFJl
Дата добавления - 20.01.2016 в 13:56
_Boroda_ Дата: Среда, 20.01.2016, 14:11 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Там все разные формулы, поэтому сюда не пишу. Формулы массива. Вводятся одновременным нажатием Контрл Шифт Ентер
Ячейки В6 и В7 по-моему считаются неверно.

Да, Славик прав, вторая ЕСЛИОШИБКА лишняя
К сообщению приложен файл: -2-1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Там все разные формулы, поэтому сюда не пишу. Формулы массива. Вводятся одновременным нажатием Контрл Шифт Ентер
Ячейки В6 и В7 по-моему считаются неверно.

Да, Славик прав, вторая ЕСЛИОШИБКА лишняя

Автор - _Boroda_
Дата добавления - 20.01.2016 в 14:11
YouGreed Дата: Среда, 20.01.2016, 14:11 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
lFJl, ПРобуйте. Если установите условия >= и <=, результат по идее станет как у Саши.
Извиняюсь.
Код
=НАИБОЛЬШИЙ(ЕСЛИОШИБКА((--Таблица1[#Заголовки]>=$A$1)*(--Таблица1[#Заголовки]<=$B$1)*Таблица1[#Эта строка];);1)
так будет корректнее отображать.
Для суммы так.
Код
=СУММ(ЕСЛИОШИБКА((--$C$1:$K$1>=$A$1)*(--$C$1:$K$1<=$B$1)*$C$3:$K$3;))
К сообщению приложен файл: ______.xlsx(13Kb)


Сообщение отредактировал YouGreed - Среда, 20.01.2016, 14:20
 
Ответить
СообщениеlFJl, ПРобуйте. Если установите условия >= и <=, результат по идее станет как у Саши.
Извиняюсь.
Код
=НАИБОЛЬШИЙ(ЕСЛИОШИБКА((--Таблица1[#Заголовки]>=$A$1)*(--Таблица1[#Заголовки]<=$B$1)*Таблица1[#Эта строка];);1)
так будет корректнее отображать.
Для суммы так.
Код
=СУММ(ЕСЛИОШИБКА((--$C$1:$K$1>=$A$1)*(--$C$1:$K$1<=$B$1)*$C$3:$K$3;))

Автор - YouGreed
Дата добавления - 20.01.2016 в 14:11
SLAVICK Дата: Среда, 20.01.2016, 14:16 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1924
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
Так? - формулы массива:
Код
=МАКС(ЕСЛИ(ЕСЛИОШИБКА((--C1:K1>=A1)*(--C1:K1<=B1);0);ЕСЛИОШИБКА(--C3:K3;0);0))

Код
=СУММ(ЕСЛИ(ЕСЛИОШИБКА((--C1:K1>=A1)*(--C1:K1<=B1);0);ЕСЛИОШИБКА(--C3:K3;0);0))
К сообщению приложен файл: 6638600.xlsx(13Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеТак? - формулы массива:
Код
=МАКС(ЕСЛИ(ЕСЛИОШИБКА((--C1:K1>=A1)*(--C1:K1<=B1);0);ЕСЛИОШИБКА(--C3:K3;0);0))

Код
=СУММ(ЕСЛИ(ЕСЛИОШИБКА((--C1:K1>=A1)*(--C1:K1<=B1);0);ЕСЛИОШИБКА(--C3:K3;0);0))

Автор - SLAVICK
Дата добавления - 20.01.2016 в 14:16
lFJl Дата: Понедельник, 25.01.2016, 11:25 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 214
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
Спасибо большее!
А можете еще подсказать как среднее только по заполненным(чтоб пустые не учитывались) посчитать тут?
Я думал аналогично сумме будет, но ошибся видимо, не получается...
И еще можете сказать, что значит "--" в формуле? Может уже писалось где?
 
Ответить
СообщениеСпасибо большее!
А можете еще подсказать как среднее только по заполненным(чтоб пустые не учитывались) посчитать тут?
Я думал аналогично сумме будет, но ошибся видимо, не получается...
И еще можете сказать, что значит "--" в формуле? Может уже писалось где?

Автор - lFJl
Дата добавления - 25.01.2016 в 11:25
китин Дата: Понедельник, 25.01.2016, 11:49 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3724
Репутация: 587 ±
Замечаний: 0% ±

Excel 2007;Excel 2010


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 25.01.2016, 11:50
 
Ответить
СообщениеЧто такое -- или как превратить ИСТИНА в 1, а ЛОЖЬ в 0?

Автор - китин
Дата добавления - 25.01.2016 в 11:49
lFJl Дата: Понедельник, 25.01.2016, 13:08 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 214
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
О, спасибо! Сегодня день познаний у меня! :)
А что на счет:
А можете еще подсказать как среднее только по заполненным(чтоб пустые не учитывались) посчитать тут?
 
Ответить
СообщениеО, спасибо! Сегодня день познаний у меня! :)
А что на счет:
А можете еще подсказать как среднее только по заполненным(чтоб пустые не учитывались) посчитать тут?

Автор - lFJl
Дата добавления - 25.01.2016 в 13:08
lFJl Дата: Вторник, 26.01.2016, 06:02 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 214
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
Может кому пригодится:
Среднее
Код
=ЕСЛИОШИБКА(СРЗНАЧ($C$3:$K$3);0)

По дню недели
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН($C$3:$K$3;$C$2:$K$2;$A$2);0)

Спасибо всем за ответы! :)
[moder]Формулы обрамляйте тегами - кнопка fx. Поправил Вам.


Сообщение отредактировал _Boroda_ - Вторник, 26.01.2016, 07:06
 
Ответить
СообщениеМожет кому пригодится:
Среднее
Код
=ЕСЛИОШИБКА(СРЗНАЧ($C$3:$K$3);0)

По дню недели
Код
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН($C$3:$K$3;$C$2:$K$2;$A$2);0)

Спасибо всем за ответы! :)
[moder]Формулы обрамляйте тегами - кнопка fx. Поправил Вам.

Автор - lFJl
Дата добавления - 26.01.2016 в 06:02
lFJl Дата: Среда, 27.01.2016, 14:26 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 214
Репутация: 5 ±
Замечаний: 0% ±

Excel 2007
Снова ломаю голову, как среднее высчитать, по дню недели и в промежутке, между датами?
Конкретно мне интересно, среднее по средам за последние 3 недели. Ну голову сломал уже... Помогите пожалуйста! :)
[moder]1. Не нужно все средние складывать в одну тему.
2. Файл нормальный приложите.[/moder]

Понял, создам новую тему! :)


Сообщение отредактировал lFJl - Четверг, 28.01.2016, 06:52
 
Ответить
СообщениеСнова ломаю голову, как среднее высчитать, по дню недели и в промежутке, между датами?
Конкретно мне интересно, среднее по средам за последние 3 недели. Ну голову сломал уже... Помогите пожалуйста! :)
[moder]1. Не нужно все средние складывать в одну тему.
2. Файл нормальный приложите.[/moder]

Понял, создам новую тему! :)

Автор - lFJl
Дата добавления - 27.01.2016 в 14:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма/максимальное по условию(в условии содержится текст) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!