Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Дублирование массива n кол-во раз, сцепка с другим массивом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дублирование массива n кол-во раз, сцепка с другим массивом (Формулы/Formulas)
Дублирование массива n кол-во раз, сцепка с другим массивом
martyr Дата: Вторник, 26.01.2016, 11:05 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день,
подскажите пож., как можно свести в один массив данные по условию
торговая точка - категория,
необходимо задублировать значения категории n-ое(лист массив 1) кол-во раз и присвоить ей магазин в порядке очереди с листа "массив 2".
Пример как надо во вложении.
Заранее большое спасибо!
К сообщению приложен файл: 7741799.xlsx(9Kb)
 
Ответить
СообщениеДобрый день,
подскажите пож., как можно свести в один массив данные по условию
торговая точка - категория,
необходимо задублировать значения категории n-ое(лист массив 1) кол-во раз и присвоить ей магазин в порядке очереди с листа "массив 2".
Пример как надо во вложении.
Заранее большое спасибо!

Автор - martyr
Дата добавления - 26.01.2016 в 11:05
_Boroda_ Дата: Вторник, 26.01.2016, 11:11 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для удобства все на один лист засунул
Для конкретных количеств
Код
=ИНДЕКС(C$2:C$5;(СТРОКА()-2)/5+1)

Код
=ИНДЕКС(A$2:A$6;СЧЁТЕСЛИ(F$1:F2;F2))

Для общего случая сейчас допишу сюда же

вот, дописываю для любого количества (можно добавлять-убирать значения)
Код
=ИНДЕКС(C$2:ИНДЕКС(C:C;СЧЁТЗ(C:C));(СТРОКА()-2)/(СЧЁТЗ(A:A)-1)+1)

Код
=ИНДЕКС(A$2:ИНДЕКС(A:A;СЧЁТЗ(A:A));СЧЁТЕСЛИ(F$1:F2;F2))

Код
ИНДЕКС(A$2:ИНДЕКС(A:A;СЧЁТЗ(A:A));ОСТАТ(СТРОКА(K1)-1;СЧЁТЗ(A:A)-1)+1)

И с уходом от ошибок варианты в файле
К сообщению приложен файл: 7741799_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля удобства все на один лист засунул
Для конкретных количеств
Код
=ИНДЕКС(C$2:C$5;(СТРОКА()-2)/5+1)

Код
=ИНДЕКС(A$2:A$6;СЧЁТЕСЛИ(F$1:F2;F2))

Для общего случая сейчас допишу сюда же

вот, дописываю для любого количества (можно добавлять-убирать значения)
Код
=ИНДЕКС(C$2:ИНДЕКС(C:C;СЧЁТЗ(C:C));(СТРОКА()-2)/(СЧЁТЗ(A:A)-1)+1)

Код
=ИНДЕКС(A$2:ИНДЕКС(A:A;СЧЁТЗ(A:A));СЧЁТЕСЛИ(F$1:F2;F2))

Код
ИНДЕКС(A$2:ИНДЕКС(A:A;СЧЁТЗ(A:A));ОСТАТ(СТРОКА(K1)-1;СЧЁТЗ(A:A)-1)+1)

И с уходом от ошибок варианты в файле

Автор - _Boroda_
Дата добавления - 26.01.2016 в 11:11
китин Дата: Вторник, 26.01.2016, 11:22 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3723
Репутация: 587 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
для магазина
Код
=ЕСЛИОШИБКА(ИНДЕКС(СМЕЩ('массив 2'!$A$2;;;СЧЁТЗ('массив 2'!$A:$A)-1);ЦЕЛОЕ((СТРОКА(A1)-1)/(СЧЁТЗ('массив 1'!$A:$A)-1))+1);"")

для товара
Код
=ЕСЛИ(D2="";"";ИНДЕКС(СМЕЩ('массив 1'!$A$2;;;СЧЁТЗ('массив 1'!$A:$A)-1);ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('массив 1'!$A:$A)-1)+1))
К сообщению приложен файл: martyr.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениедля магазина
Код
=ЕСЛИОШИБКА(ИНДЕКС(СМЕЩ('массив 2'!$A$2;;;СЧЁТЗ('массив 2'!$A:$A)-1);ЦЕЛОЕ((СТРОКА(A1)-1)/(СЧЁТЗ('массив 1'!$A:$A)-1))+1);"")

для товара
Код
=ЕСЛИ(D2="";"";ИНДЕКС(СМЕЩ('массив 1'!$A$2;;;СЧЁТЗ('массив 1'!$A:$A)-1);ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ('массив 1'!$A:$A)-1)+1))

Автор - китин
Дата добавления - 26.01.2016 в 11:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дублирование массива n кол-во раз, сцепка с другим массивом (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!