Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет задолженности - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет задолженности (Формулы/Formulas)
Расчет задолженности
vitos Дата: Среда, 27.01.2016, 11:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день. У меня вопрос следующего плана: в приложенном файле на вкладке "дата прихода" ставится фактическая сумма товара, который пришел в данный день. На вкладке "дата платежа" уже считается, когда именно надо платить поставщику с учетом отсрочки платежа. Вопрос в следующем - оплаты могут производится только во вторник, среду и четверг, а на вкладке "дата платежа" платеж может выпадать и на понедельник, и на субботы, и на воскресенье. Можно как-то сделать, чтобы платеж, который попадает на воскресенье и понедельник, автоматически переходил на вторник, сумма с пятницы и субботы переходила на четверг.
К сообщению приложен файл: 111111.xlsx(23Kb)
 
Ответить
СообщениеДобрый день. У меня вопрос следующего плана: в приложенном файле на вкладке "дата прихода" ставится фактическая сумма товара, который пришел в данный день. На вкладке "дата платежа" уже считается, когда именно надо платить поставщику с учетом отсрочки платежа. Вопрос в следующем - оплаты могут производится только во вторник, среду и четверг, а на вкладке "дата платежа" платеж может выпадать и на понедельник, и на субботы, и на воскресенье. Можно как-то сделать, чтобы платеж, который попадает на воскресенье и понедельник, автоматически переходил на вторник, сумма с пятницы и субботы переходила на четверг.

Автор - vitos
Дата добавления - 27.01.2016 в 11:11
YouGreed Дата: Среда, 27.01.2016, 11:54 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
vitos, Так?
Код
=$B$3+C$2+ПРОСМОТР(ДЕНЬНЕД(C$2+$B$3;2);{1;2;3;4;5;6;7};{1;0;0;0;-1;-2;2})


В 1-ой строке, протяните формулу. Изменил также Вашу, чтобы искало мои значения из 1-ой строки. Для отчетности, 1-ую строку можно скрыть.
К сообщению приложен файл: 8693183.xlsx(23Kb)


Сообщение отредактировал YouGreed - Среда, 27.01.2016, 11:57
 
Ответить
Сообщениеvitos, Так?
Код
=$B$3+C$2+ПРОСМОТР(ДЕНЬНЕД(C$2+$B$3;2);{1;2;3;4;5;6;7};{1;0;0;0;-1;-2;2})


В 1-ой строке, протяните формулу. Изменил также Вашу, чтобы искало мои значения из 1-ой строки. Для отчетности, 1-ую строку можно скрыть.

Автор - YouGreed
Дата добавления - 27.01.2016 в 11:54
vitos Дата: Среда, 27.01.2016, 13:19 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
YouGreed, можно еще выложить файл с изменениями. В вашем файле формулы остались без изменений.
 
Ответить
СообщениеYouGreed, можно еще выложить файл с изменениями. В вашем файле формулы остались без изменений.

Автор - vitos
Дата добавления - 27.01.2016 в 13:19
_Boroda_ Дата: Среда, 27.01.2016, 13:23 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не, не покатит - значения нужно складывать. Те, который попадают на пт и сб, нужно прибавлять к чт, а вс и пн - к вт.
Предлагаю так
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(ИНДЕКС('Дата прихода'!$C$2:$ND$22;ПОИСКПОЗ($A2;'Дата прихода'!$A$2:$A$22;0);)*('Дата прихода'!$C$1:$ND$1+$B2+ТЕКСТ(ДЕНЬНЕД('Дата прихода'!$C$1:$ND$1+$B2);"[<3]3;[>5]5;0")-ДЕНЬНЕД('Дата прихода'!$C$1:$ND$1+$B2)=C$1));0)
К сообщению приложен файл: 111111_1.xlsx(31Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе, не покатит - значения нужно складывать. Те, который попадают на пт и сб, нужно прибавлять к чт, а вс и пн - к вт.
Предлагаю так
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(ИНДЕКС('Дата прихода'!$C$2:$ND$22;ПОИСКПОЗ($A2;'Дата прихода'!$A$2:$A$22;0);)*('Дата прихода'!$C$1:$ND$1+$B2+ТЕКСТ(ДЕНЬНЕД('Дата прихода'!$C$1:$ND$1+$B2);"[<3]3;[>5]5;0")-ДЕНЬНЕД('Дата прихода'!$C$1:$ND$1+$B2)=C$1));0)

Автор - _Boroda_
Дата добавления - 27.01.2016 в 13:23
YouGreed Дата: Среда, 27.01.2016, 13:24 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
vitos, Почему же) Изменение всего в 2-3-х цифрах.
Код
=ЕСЛИОШИБКА(ИНДЕКС('Дата прихода'!$C$2:$AG$2;ПОИСКПОЗ('Дата платежа'!$A2;'Дата прихода'!$A$2:$A$2;0);ПОИСКПОЗ('Дата платежа'!R$1-$B2;'Дата прихода'!$C$1:$AG$1;0));0)


Код
=ЕСЛИОШИБКА(ИНДЕКС('Дата прихода'!$C$3:$AG$3;ПОИСКПОЗ('Дата платежа'!$A2;'Дата прихода'!$A$3:$A$3;0);ПОИСКПОЗ('Дата платежа'!C$1;'Дата прихода'!$C$1:$AG$1;0));0)
 
Ответить
Сообщениеvitos, Почему же) Изменение всего в 2-3-х цифрах.
Код
=ЕСЛИОШИБКА(ИНДЕКС('Дата прихода'!$C$2:$AG$2;ПОИСКПОЗ('Дата платежа'!$A2;'Дата прихода'!$A$2:$A$2;0);ПОИСКПОЗ('Дата платежа'!R$1-$B2;'Дата прихода'!$C$1:$AG$1;0));0)


Код
=ЕСЛИОШИБКА(ИНДЕКС('Дата прихода'!$C$3:$AG$3;ПОИСКПОЗ('Дата платежа'!$A2;'Дата прихода'!$A$3:$A$3;0);ПОИСКПОЗ('Дата платежа'!C$1;'Дата прихода'!$C$1:$AG$1;0));0)

Автор - YouGreed
Дата добавления - 27.01.2016 в 13:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет задолженности (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!