Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка по содержанию внутри текста - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка по содержанию внутри текста (Формулы/Formulas)
Сортировка по содержанию внутри текста
Мурад Дата: Пятница, 29.01.2016, 10:31 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 412
Репутация: 17 ±
Замечаний: 0% ±

Excel 2007
Добрый день, уважаемые форумчане! Подскажите, как можно отсортировать список в приложенном примере? Вначале бакалавры, потом специалисты, и наконец, магистры? Пробовал создать настраиваемый список через Параметры Excel, но не помогло. Других встроенных инструментов необходимой мне сортировки не знаю.
К сообщению приложен файл: sort.xlsx(12Kb)
 
Ответить
СообщениеДобрый день, уважаемые форумчане! Подскажите, как можно отсортировать список в приложенном примере? Вначале бакалавры, потом специалисты, и наконец, магистры? Пробовал создать настраиваемый список через Параметры Excel, но не помогло. Других встроенных инструментов необходимой мне сортировки не знаю.

Автор - Мурад
Дата добавления - 29.01.2016 в 10:31
SLAVICK Дата: Пятница, 29.01.2016, 10:53 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1922
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
См в приложении два варианта:
1.УФ -- сортировка по цвету ячейки
2.Доп. столбец -- сортировка от а до я
К сообщению приложен файл: 2309560.xlsx(37Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеСм в приложении два варианта:
1.УФ -- сортировка по цвету ячейки
2.Доп. столбец -- сортировка от а до я

Автор - SLAVICK
Дата добавления - 29.01.2016 в 10:53
Pelena Дата: Пятница, 29.01.2016, 10:55 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10385
Репутация: 2353 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Тоже вариант с доп. столбцом и настраиваемой сортировкой
К сообщению приложен файл: ort-1-.xlsx(13Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТоже вариант с доп. столбцом и настраиваемой сортировкой

Автор - Pelena
Дата добавления - 29.01.2016 в 10:55
Manyasha Дата: Пятница, 29.01.2016, 10:56 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
Тоже с доп. столбцом:
Код
=ПРОСМОТР(;-ПОИСК($F$2:$F$4;A2);СТРОКА($A$1:$A$3))
К сообщению приложен файл: sort-1_.xlsx(13Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеТоже с доп. столбцом:
Код
=ПРОСМОТР(;-ПОИСК($F$2:$F$4;A2);СТРОКА($A$1:$A$3))

Автор - Manyasha
Дата добавления - 29.01.2016 в 10:56
YouGreed Дата: Пятница, 29.01.2016, 11:00 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
Pelena, Извиняюсь. Поставил пользовательскую сортировку на Ваш столбец "образование", чтобы результат был как в условии.
К сообщению приложен файл: 7396211.xlsx(13Kb)
 
Ответить
СообщениеPelena, Извиняюсь. Поставил пользовательскую сортировку на Ваш столбец "образование", чтобы результат был как в условии.

Автор - YouGreed
Дата добавления - 29.01.2016 в 11:00
Pelena Дата: Пятница, 29.01.2016, 11:11 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 10385
Репутация: 2353 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
У меня, вроде, такая же была...

А, там надо было звёздочки убрать


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеУ меня, вроде, такая же была...

А, там надо было звёздочки убрать

Автор - Pelena
Дата добавления - 29.01.2016 в 11:11
_Boroda_ Дата: Пятница, 29.01.2016, 11:25 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9786
Репутация: 4135 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Без допстолбцов
Формула массива, конечно же.
Код
=ИНДЕКС(A$1:A$78;--ПРАВБ(НАИМЕНЬШИЙ(--(ЕСЛИ(ЕЧИСЛО(ПОИСК({"(бак";"(спец*)";"(маг"};A$2:A$78));1;9^9)*{1;2;3}&ТЕКСТ(СТРОКА(A$2:A$78);"000"));СТРОКА(D1));3))
К сообщению приложен файл: sort_1.xlsx(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеБез допстолбцов
Формула массива, конечно же.
Код
=ИНДЕКС(A$1:A$78;--ПРАВБ(НАИМЕНЬШИЙ(--(ЕСЛИ(ЕЧИСЛО(ПОИСК({"(бак";"(спец*)";"(маг"};A$2:A$78));1;9^9)*{1;2;3}&ТЕКСТ(СТРОКА(A$2:A$78);"000"));СТРОКА(D1));3))

Автор - _Boroda_
Дата добавления - 29.01.2016 в 11:25
Мурад Дата: Пятница, 29.01.2016, 13:17 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 412
Репутация: 17 ±
Замечаний: 0% ±

Excel 2007
Всем большое спасибо! Вариант с допстолбцом и формула массива позволяют выстроить список в нужном порядке.

P.S. Единственное - в варианте, предложенном Александром, придется использовать формулу ВПР, чтоб подтянуть часы для упорядоченного списка.


Сообщение отредактировал Мурад - Пятница, 29.01.2016, 13:27
 
Ответить
СообщениеВсем большое спасибо! Вариант с допстолбцом и формула массива позволяют выстроить список в нужном порядке.

P.S. Единственное - в варианте, предложенном Александром, придется использовать формулу ВПР, чтоб подтянуть часы для упорядоченного списка.

Автор - Мурад
Дата добавления - 29.01.2016 в 13:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка по содержанию внутри текста (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!