Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос недостающих данных из файла в файл с синхронизацией - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос недостающих данных из файла в файл с синхронизацией (Формулы/Formulas)
Перенос недостающих данных из файла в файл с синхронизацией
Sadiar Дата: Пятница, 29.01.2016, 14:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток! Как выполнить перенос данных их файла А в файл Б, с синхронизацией, если в файле Б имеются только счета и даты, а в файле А, те же счета + ФИО, серия и номер паспорта. Необходимо перенести ФИО и паспортные данные с синхронизацией по счетам
К сообщению приложен файл: __.xls(37Kb) · 5174538.xls(26Kb)


Сообщение отредактировал Sadiar - Пятница, 29.01.2016, 14:29
 
Ответить
СообщениеДоброго времени суток! Как выполнить перенос данных их файла А в файл Б, с синхронизацией, если в файле Б имеются только счета и даты, а в файле А, те же счета + ФИО, серия и номер паспорта. Необходимо перенести ФИО и паспортные данные с синхронизацией по счетам

Автор - Sadiar
Дата добавления - 29.01.2016 в 14:17
SLAVICK Дата: Пятница, 29.01.2016, 14:53 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1923
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
Вот:
Код
=ИНДЕКС('[__.xls]Файл А '!$C$5:$C$20;ПОИСКПОЗ(B3;'[__.xls]Файл А '!$H$5:$H$20;0))

Сделал для имени - и серии - дальше по аналогии сами.
К сообщению приложен файл: 6644419.xls(30Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеВот:
Код
=ИНДЕКС('[__.xls]Файл А '!$C$5:$C$20;ПОИСКПОЗ(B3;'[__.xls]Файл А '!$H$5:$H$20;0))

Сделал для имени - и серии - дальше по аналогии сами.

Автор - SLAVICK
Дата добавления - 29.01.2016 в 14:53
Sadiar Дата: Пятница, 29.01.2016, 16:32 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
SLAVICK, Спасибо большое, на примере все работает. Не могу перенести формулу в рабочий файл. Чайник, блин :((((
Напиши как воспользоваться по шагам!!!! :(((
 
Ответить
СообщениеSLAVICK, Спасибо большое, на примере все работает. Не могу перенести формулу в рабочий файл. Чайник, блин :((((
Напиши как воспользоваться по шагам!!!! :(((

Автор - Sadiar
Дата добавления - 29.01.2016 в 16:32
Sadiar Дата: Пятница, 29.01.2016, 16:35 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
SLAVICK, Рассказываю что и как делал! Взял формулу вставил в нужную ячейку, прописал путь к файлу с информацией, проверил имена столбцов, НЕ РАБОТАЕТ
 
Ответить
СообщениеSLAVICK, Рассказываю что и как делал! Взял формулу вставил в нужную ячейку, прописал путь к файлу с информацией, проверил имена столбцов, НЕ РАБОТАЕТ

Автор - Sadiar
Дата добавления - 29.01.2016 в 16:35
SLAVICK Дата: Пятница, 29.01.2016, 16:43 | Сообщение № 5
Группа: Модераторы
Ранг: Старожил
Сообщений: 1923
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
Рассказываю что и как делал

Лучше покажите на конкретном примере. Пары строк достаточно.


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение
Рассказываю что и как делал

Лучше покажите на конкретном примере. Пары строк достаточно.

Автор - SLAVICK
Дата добавления - 29.01.2016 в 16:43
Sadiar Дата: Пятница, 29.01.2016, 19:34 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А что я покажу на конкретном примере? Как можно показать что копируешь формулу и вставляешь её в необходимую ячейку а формула не работает, как это можно прислать, на пару строк?

вот пример перебитой формулы, что не так
Код
=ИНДЕКС('C:\Users\1\Downloads\[__.xls]Данные'!$C$5:$C$20;ПОИСКПО3(B3;'C:\Users\1\Downloads\[__.xls]Данные'!$H$5:$H$20;0))
,
Эксель пишет №ИМЯ?
[moder]Для оформления формул используйте кнопку fx. Исправила на первый раз[/moder]


Сообщение отредактировал Pelena - Пятница, 29.01.2016, 19:40
 
Ответить
СообщениеА что я покажу на конкретном примере? Как можно показать что копируешь формулу и вставляешь её в необходимую ячейку а формула не работает, как это можно прислать, на пару строк?

вот пример перебитой формулы, что не так
Код
=ИНДЕКС('C:\Users\1\Downloads\[__.xls]Данные'!$C$5:$C$20;ПОИСКПО3(B3;'C:\Users\1\Downloads\[__.xls]Данные'!$H$5:$H$20;0))
,
Эксель пишет №ИМЯ?
[moder]Для оформления формул используйте кнопку fx. Исправила на первый раз[/moder]

Автор - Sadiar
Дата добавления - 29.01.2016 в 19:34
Sadiar Дата: Пятница, 29.01.2016, 19:37 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
SLAVICK, Либо пишет №Н/Д
 
Ответить
СообщениеSLAVICK, Либо пишет №Н/Д

Автор - Sadiar
Дата добавления - 29.01.2016 в 19:37
Pelena Дата: Пятница, 29.01.2016, 19:44 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 10418
Репутация: 2358 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Sadiar, у Вас файл называется __.xls?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеSadiar, у Вас файл называется __.xls?

Автор - Pelena
Дата добавления - 29.01.2016 в 19:44
Sadiar Дата: Пятница, 29.01.2016, 19:54 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Да, я даже файл также назвал как в примере чтоб формула сработало все никак!
 
Ответить
СообщениеPelena, Да, я даже файл также назвал как в примере чтоб формула сработало все никак!

Автор - Sadiar
Дата добавления - 29.01.2016 в 19:54
Sadiar Дата: Пятница, 29.01.2016, 19:59 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Блин, сначала обрадовался, что удалось решить многомесячную проблему. Что долой бессонные ночи и порча зрения, ан нет. Формулу получил еще днем, а ладу ей никак не дам, уже весь на панике!!!!! :'(
 
Ответить
СообщениеPelena, Блин, сначала обрадовался, что удалось решить многомесячную проблему. Что долой бессонные ночи и порча зрения, ан нет. Формулу получил еще днем, а ладу ей никак не дам, уже весь на панике!!!!! :'(

Автор - Sadiar
Дата добавления - 29.01.2016 в 19:59
Sadiar Дата: Пятница, 29.01.2016, 20:07 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Пожалуйста, уважаемые специалисты в области Excel, обратите внимание на мою проблему!!!
[moder]Не надо кричать[/moder]


Сообщение отредактировал Pelena - Пятница, 29.01.2016, 20:09
 
Ответить
СообщениеПожалуйста, уважаемые специалисты в области Excel, обратите внимание на мою проблему!!!
[moder]Не надо кричать[/moder]

Автор - Sadiar
Дата добавления - 29.01.2016 в 20:07
Pelena Дата: Пятница, 29.01.2016, 20:08 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 10418
Репутация: 2358 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
А Вы попробуйте этот путь сформировать автоматически. Откройте оба файла в одном Excel, в одном поставьте = и перейдите в другой, выделите любую ячейку -- Enter. Теперь второй файл закройте и посмотрите, как прописался путь в формуле


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА Вы попробуйте этот путь сформировать автоматически. Откройте оба файла в одном Excel, в одном поставьте = и перейдите в другой, выделите любую ячейку -- Enter. Теперь второй файл закройте и посмотрите, как прописался путь в формуле

Автор - Pelena
Дата добавления - 29.01.2016 в 20:08
Sadiar Дата: Пятница, 29.01.2016, 20:09 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Сей час попробую
 
Ответить
СообщениеPelena, Сей час попробую

Автор - Sadiar
Дата добавления - 29.01.2016 в 20:09
Sadiar Дата: Пятница, 29.01.2016, 20:59 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Перепробывал ВСЕ! Одновременно открывал 2 файла брал ссылку из 2 файла. Не буду описывать какие другие манипуляции я проводил с файлами и формулой, но не работает.
 
Ответить
СообщениеПерепробывал ВСЕ! Одновременно открывал 2 файла брал ссылку из 2 файла. Не буду описывать какие другие манипуляции я проводил с файлами и формулой, но не работает.

Автор - Sadiar
Дата добавления - 29.01.2016 в 20:59
Sadiar Дата: Пятница, 29.01.2016, 21:02 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Работает только, на тех файлах, которые я специально отправлял для примера. Там было ограниченное количество строк, не более 20. Вот там работает. Если это данные до 200 строк выдает ошибку!
 
Ответить
СообщениеРаботает только, на тех файлах, которые я специально отправлял для примера. Там было ограниченное количество строк, не более 20. Вот там работает. Если это данные до 200 строк выдает ошибку!

Автор - Sadiar
Дата добавления - 29.01.2016 в 21:02
Sadiar Дата: Пятница, 29.01.2016, 21:03 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Что посоветуете?
 
Ответить
СообщениеЧто посоветуете?

Автор - Sadiar
Дата добавления - 29.01.2016 в 21:03
SLAVICK Дата: Пятница, 29.01.2016, 21:03 | Сообщение № 17
Группа: Модераторы
Ранг: Старожил
Сообщений: 1923
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
SLAVICK, Либо пишет №Н/Д

А у Вас воригинале тоже всего 20 строк?
Может просто увеличить 20 до 20000 например, чтобы вместо
Код
=ИНДЕКС('[__.xls]Файл А '!$C$5:$C$20;ПОИСКПОЗ(B3;'[__.xls]Файл А '!$H$5:$H$20;0))

стало
Код
=ИНДЕКС('[__.xls]Файл А '!$C$5:$C$20000;ПОИСКПОЗ(B3;'[__.xls]Файл А '!$H$5:$H$20000;0))

если не работает - оставьте в файлах несколько строк киньте их в одну папку, потом в архив, потом сюда на форум.


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение
SLAVICK, Либо пишет №Н/Д

А у Вас воригинале тоже всего 20 строк?
Может просто увеличить 20 до 20000 например, чтобы вместо
Код
=ИНДЕКС('[__.xls]Файл А '!$C$5:$C$20;ПОИСКПОЗ(B3;'[__.xls]Файл А '!$H$5:$H$20;0))

стало
Код
=ИНДЕКС('[__.xls]Файл А '!$C$5:$C$20000;ПОИСКПОЗ(B3;'[__.xls]Файл А '!$H$5:$H$20000;0))

если не работает - оставьте в файлах несколько строк киньте их в одну папку, потом в архив, потом сюда на форум.

Автор - SLAVICK
Дата добавления - 29.01.2016 в 21:03
Sadiar Дата: Пятница, 29.01.2016, 21:31 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем огромное спасибо! Методом проб и ошибок установил истину. УРА!!!! Все работает!!!!
 
Ответить
СообщениеВсем огромное спасибо! Методом проб и ошибок установил истину. УРА!!!! Все работает!!!!

Автор - Sadiar
Дата добавления - 29.01.2016 в 21:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос недостающих данных из файла в файл с синхронизацией (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!