Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск по двум значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по двум значениям (Формулы/Formulas)
Поиск по двум значениям
seldom Дата: Пятница, 29.01.2016, 17:36 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

У меня есть формула массива:
Код
=ЕСЛИ(E928>0;ЕСЛИОШИБКА(ИНДЕКС($X$8:$X$4395;ПОИСКПОЗ(E928&F928;$B$8:$B$4395&$C$8:$C$4395;0));0);0)

Как сделать, чтобы по поиску двух значений отображалось "выполнено", в случае совпадения?


Сообщение отредактировал Manyasha - Пятница, 29.01.2016, 17:57
 
Ответить
СообщениеДобрый день!

У меня есть формула массива:
Код
=ЕСЛИ(E928>0;ЕСЛИОШИБКА(ИНДЕКС($X$8:$X$4395;ПОИСКПОЗ(E928&F928;$B$8:$B$4395&$C$8:$C$4395;0));0);0)

Как сделать, чтобы по поиску двух значений отображалось "выполнено", в случае совпадения?

Автор - seldom
Дата добавления - 29.01.2016 в 17:36
buchlotnik Дата: Пятница, 29.01.2016, 17:46 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2191
Репутация: 646 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Формулу в теги, пример в приложение -
Тогда, наверняка, найдётся решение...

[p.s.]стихи прям B)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 29.01.2016, 18:03
 
Ответить
СообщениеФормулу в теги, пример в приложение -
Тогда, наверняка, найдётся решение...

[p.s.]стихи прям B)

Автор - buchlotnik
Дата добавления - 29.01.2016 в 17:46
gling Дата: Пятница, 29.01.2016, 18:09 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1392
Репутация: 341 ±
Замечаний: 0% ±

2010
Может так подойдет?
Код
=ЕСЛИ(ЕСЛИОШИБКА(ИНДЕКС($X$8:$X$4395;ПОИСКПОЗ(E928&F928;$B$8:$B$4395&$C$8:$C$4395;0));0);"Выполнено";0)
Если не подходит, приложите файл. Кавычку не закрыл. Исправил.


Сообщение отредактировал gling - Пятница, 29.01.2016, 18:11
 
Ответить
СообщениеМожет так подойдет?
Код
=ЕСЛИ(ЕСЛИОШИБКА(ИНДЕКС($X$8:$X$4395;ПОИСКПОЗ(E928&F928;$B$8:$B$4395&$C$8:$C$4395;0));0);"Выполнено";0)
Если не подходит, приложите файл. Кавычку не закрыл. Исправил.

Автор - gling
Дата добавления - 29.01.2016 в 18:09
seldom Дата: Пятница, 29.01.2016, 18:16 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добавил, в желтых ячейках должно быть слово "выполнено", если значения совпадают если стоит 0 то можно поставить "не выполнено"
К сообщению приложен файл: _Microsoft_Exce.xlsx(10Kb)
 
Ответить
СообщениеДобавил, в желтых ячейках должно быть слово "выполнено", если значения совпадают если стоит 0 то можно поставить "не выполнено"

Автор - seldom
Дата добавления - 29.01.2016 в 18:16
gling Дата: Пятница, 29.01.2016, 18:57 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1392
Репутация: 341 ±
Замечаний: 0% ±

2010
А вы что, формулу даже не попробовали применить? На мой взгляд она работает, или что то не так? Формула массива как и у Вас, а точнее Ваша но чуть правленая.
Код
=ЕСЛИ(ЕСЛИОШИБКА(ИНДЕКС(Лист2!$H$8:$H$13;ПОИСКПОЗ(Лист1!$E8&Лист1!$F8;Лист2!$F$8:$F$13&Лист2!$G$8:$G$13;0));0);"Выполнено";"Не выполнено")
К сообщению приложен файл: 9038185.xlsx(10Kb)
 
Ответить
СообщениеА вы что, формулу даже не попробовали применить? На мой взгляд она работает, или что то не так? Формула массива как и у Вас, а точнее Ваша но чуть правленая.
Код
=ЕСЛИ(ЕСЛИОШИБКА(ИНДЕКС(Лист2!$H$8:$H$13;ПОИСКПОЗ(Лист1!$E8&Лист1!$F8;Лист2!$F$8:$F$13&Лист2!$G$8:$G$13;0));0);"Выполнено";"Не выполнено")

Автор - gling
Дата добавления - 29.01.2016 в 18:57
buchlotnik Дата: Пятница, 29.01.2016, 19:31 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2191
Репутация: 646 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
у меня так получилось
Код
=ЕСЛИ(ЕПУСТО(E8);"";ЕСЛИ(ЕОШИБКА(ИНДЕКС(Лист2!$H$8:$H$13;ПОИСКПОЗ(Лист1!$E8&Лист1!$F8;Лист2!$F$8:$F$13&Лист2!$G$8:$G$13;0)));"не выполнено";"выполнено"))
К сообщению приложен файл: 5334036.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеу меня так получилось
Код
=ЕСЛИ(ЕПУСТО(E8);"";ЕСЛИ(ЕОШИБКА(ИНДЕКС(Лист2!$H$8:$H$13;ПОИСКПОЗ(Лист1!$E8&Лист1!$F8;Лист2!$F$8:$F$13&Лист2!$G$8:$G$13;0)));"не выполнено";"выполнено"))

Автор - buchlotnik
Дата добавления - 29.01.2016 в 19:31
jakim Дата: Пятница, 29.01.2016, 20:06 | Сообщение № 7
Группа: Друзья
Ранг: Ветеран
Сообщений: 708
Репутация: 182 ±
Замечаний: 0% ±

У меня такая формула

Код
=IF(ISNUMBER(AGGREGATE(15;6;Лист2!D$8:D$13/(Лист2!B$8:B$13=E8)/(Лист2!C$8:C$13=F8);1));"Выполнено";"Не выполнено")
К сообщению приложен файл: of-Microsoft_Ex.xlsx(10Kb)
 
Ответить
Сообщение
У меня такая формула

Код
=IF(ISNUMBER(AGGREGATE(15;6;Лист2!D$8:D$13/(Лист2!B$8:B$13=E8)/(Лист2!C$8:C$13=F8);1));"Выполнено";"Не выполнено")

Автор - jakim
Дата добавления - 29.01.2016 в 20:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по двум значениям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!