Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение элементов массивов и подсчет количества макс. элем - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение элементов массивов и подсчет количества макс. элем (Формулы/Formulas)
Сравнение элементов массивов и подсчет количества макс. элем
bruno33 Дата: Среда, 03.02.2016, 13:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 6 ±
Замечаний: 0% ±

Excel 2007
Добрый день,
Помогите пожалуйста. не могу понять как решить задачу.

есть массив из трех строк и 30 столбцов A4:AD6.
нужно сравнить эл-ты по столбцам, определить в какой строке макс.значение а потом определить по каждой строке сколько таких макс.значений.

например, в файле по строке 4 таких значений 19; стр5 - 1 зн. и стр6 - 1зн.

при этом в ячейках где нет числового значения содержится знак пробела -- так данные передаются из других таблиц.

как это сделать формулами?

Спасибо!
К сообщению приложен файл: _-..xlsx(9Kb)
 
Ответить
СообщениеДобрый день,
Помогите пожалуйста. не могу понять как решить задачу.

есть массив из трех строк и 30 столбцов A4:AD6.
нужно сравнить эл-ты по столбцам, определить в какой строке макс.значение а потом определить по каждой строке сколько таких макс.значений.

например, в файле по строке 4 таких значений 19; стр5 - 1 зн. и стр6 - 1зн.

при этом в ячейках где нет числового значения содержится знак пробела -- так данные передаются из других таблиц.

как это сделать формулами?

Спасибо!

Автор - bruno33
Дата добавления - 03.02.2016 в 13:17
pabchek Дата: Среда, 03.02.2016, 13:36 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 746
Репутация: 169 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Вот, пока так, с допстрокой
... формулу поправил, файл перезалил
К сообщению приложен файл: 7945285.xlsx(10Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 03.02.2016, 13:39
 
Ответить
СообщениеЗдравствуйте!
Вот, пока так, с допстрокой
... формулу поправил, файл перезалил

Автор - pabchek
Дата добавления - 03.02.2016 в 13:36
bruno33 Дата: Среда, 03.02.2016, 14:15 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 6 ±
Замечаний: 0% ±

Excel 2007
pabchek, спасибо большое за такое решение.

а нет ли возможности упихнуть все в концевые ячейки? этот пример - фрагмент большой таблицы, где данне идут такими 3-х строч. блоками.
у меня к сожалению нет возможности вставить после каждого блока доп.строку.
но Огромное Спасибо за Ваше предложение.
 
Ответить
Сообщениеpabchek, спасибо большое за такое решение.

а нет ли возможности упихнуть все в концевые ячейки? этот пример - фрагмент большой таблицы, где данне идут такими 3-х строч. блоками.
у меня к сожалению нет возможности вставить после каждого блока доп.строку.
но Огромное Спасибо за Ваше предложение.

Автор - bruno33
Дата добавления - 03.02.2016 в 14:15
_Boroda_ Дата: Среда, 03.02.2016, 14:18 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11501
Репутация: 4735 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
а нет ли возможности упихнуть все в концевые ячейки?

Есть. Ловите.
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=СУММ(--(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;СМЕЩ(A$4:A$6;;A$3:AD$3-1;))=A4:AD4))
К сообщению приложен файл: -1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
а нет ли возможности упихнуть все в концевые ячейки?

Есть. Ловите.
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=СУММ(--(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;СМЕЩ(A$4:A$6;;A$3:AD$3-1;))=A4:AD4))

Автор - _Boroda_
Дата добавления - 03.02.2016 в 14:18
krosav4ig Дата: Среда, 03.02.2016, 14:36 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1466
Репутация: 597 ±
Замечаний: 0% ±

Excel 2007, 2013
а у меня немассивная формула
Код
=СЧЁТ(ИНДЕКС(1/(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;СМЕЩ($A$4:$A$6;;$A$3:$AD$3-1;))=$A$4:$AD$6);СТРОКА(AE1);))

или
Код
=СУММПРОИЗВ(Ч(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;СМЕЩ($A$4:$A$6;;$A$3:$AD$3-1;))=$A4:$AD4))
К сообщению приложен файл: 6957685.xlsx(10Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Среда, 03.02.2016, 14:39
 
Ответить
Сообщениеа у меня немассивная формула
Код
=СЧЁТ(ИНДЕКС(1/(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;СМЕЩ($A$4:$A$6;;$A$3:$AD$3-1;))=$A$4:$AD$6);СТРОКА(AE1);))

или
Код
=СУММПРОИЗВ(Ч(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;СМЕЩ($A$4:$A$6;;$A$3:$AD$3-1;))=$A4:$AD4))

Автор - krosav4ig
Дата добавления - 03.02.2016 в 14:36
bruno33 Дата: Среда, 03.02.2016, 14:47 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 6 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, krosav4ig,

Огромное Вам господа спасибо! Вот-так красота!

спасибо!!
 
Ответить
Сообщение_Boroda_, krosav4ig,

Огромное Вам господа спасибо! Вот-так красота!

спасибо!!

Автор - bruno33
Дата добавления - 03.02.2016 в 14:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение элементов массивов и подсчет количества макс. элем (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!