Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как задать цифровую часть координаты ячейки формулой-ссылкой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как задать цифровую часть координаты ячейки формулой-ссылкой (Формулы/Formulas)
как задать цифровую часть координаты ячейки формулой-ссылкой
arhboy Дата: Четверг, 04.02.2016, 11:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
друзья, вопрос:
есть 2 страницы - на одной номера участников (соответствуют номерам строчек), их имена и машины. например:
72 дима бмв
73 катя мерседес
74 юра ягуар

на другой странице результаты за конкретный день заездов, но не всех участников вообще, а только тех, кто ездили. например:
72 дима бмв
74 юра ягуар

сейчас построчно на листе(2) результатов забиты формулой ссылки на тот лист, т.е. в ячейках
=лист1!A72 =лист1!B72 =лист1!C72
=лист1!A74 =лист1!B74 =лист1!C74

то есть, для ввода результатов мне нужно вбивать формулой ячейку ряда A, потом брать за крестик, тянуть всю строчку, тогда по аналогии эксель подхватывает данные имени и машины участника. и так с каждой строчкой вручную

а хотелось бы, чтобы просто вводишь любую цифру и остальные строчки подхватывали данные, относительно этой цифры. т.е. технически столбец А может быть просто цифрами, вводимыми вручную (в ссылке на номер участника смыысла нет), а в столбцах B и C - формула и тогда строчка должна работать так:

72(цифрой) =лист1!B(ЛИСТ2!A1) =лист1!С(ЛИСТ2!A1)

то есть вопрос сводится к тому, как цифровую часть координаты ячейки задать не фиксированной цифрой, а цифрой, подхватываемой из другой ячейки с числовым значением? т.е. допустим не B1, а B(=A1)
понятно, в синтаксисе, как я написал это не работает, описал именно для понятности желаемой логики работы. а как это грамотно прописать?
либо другой способ решения вопроса, подскажите пожалуйста, а то каждую пятницу после соревнований безумно много времени трачу и на самих соревнованиях, во время заездов очень долго колупать таблицу, которую видят зрители, на их глазах, не очень красиво, несмотря на декоративное оформление

если не сложно, ответ пожалуйста на Контакт удален. Нарушение Правил форума
спасибо большое вашему форуму
[moder]Пример файла покажите[/moder]


Сообщение отредактировал Pelena - Четверг, 04.02.2016, 11:29
 
Ответить
Сообщениедрузья, вопрос:
есть 2 страницы - на одной номера участников (соответствуют номерам строчек), их имена и машины. например:
72 дима бмв
73 катя мерседес
74 юра ягуар

на другой странице результаты за конкретный день заездов, но не всех участников вообще, а только тех, кто ездили. например:
72 дима бмв
74 юра ягуар

сейчас построчно на листе(2) результатов забиты формулой ссылки на тот лист, т.е. в ячейках
=лист1!A72 =лист1!B72 =лист1!C72
=лист1!A74 =лист1!B74 =лист1!C74

то есть, для ввода результатов мне нужно вбивать формулой ячейку ряда A, потом брать за крестик, тянуть всю строчку, тогда по аналогии эксель подхватывает данные имени и машины участника. и так с каждой строчкой вручную

а хотелось бы, чтобы просто вводишь любую цифру и остальные строчки подхватывали данные, относительно этой цифры. т.е. технически столбец А может быть просто цифрами, вводимыми вручную (в ссылке на номер участника смыысла нет), а в столбцах B и C - формула и тогда строчка должна работать так:

72(цифрой) =лист1!B(ЛИСТ2!A1) =лист1!С(ЛИСТ2!A1)

то есть вопрос сводится к тому, как цифровую часть координаты ячейки задать не фиксированной цифрой, а цифрой, подхватываемой из другой ячейки с числовым значением? т.е. допустим не B1, а B(=A1)
понятно, в синтаксисе, как я написал это не работает, описал именно для понятности желаемой логики работы. а как это грамотно прописать?
либо другой способ решения вопроса, подскажите пожалуйста, а то каждую пятницу после соревнований безумно много времени трачу и на самих соревнованиях, во время заездов очень долго колупать таблицу, которую видят зрители, на их глазах, не очень красиво, несмотря на декоративное оформление

если не сложно, ответ пожалуйста на Контакт удален. Нарушение Правил форума
спасибо большое вашему форуму
[moder]Пример файла покажите[/moder]

Автор - arhboy
Дата добавления - 04.02.2016 в 11:22
Pelena Дата: Четверг, 04.02.2016, 11:30 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 2454 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Без примера общий ответ - читайте про функцию ВПР()


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеБез примера общий ответ - читайте про функцию ВПР()

Автор - Pelena
Дата добавления - 04.02.2016 в 11:30
arhboy Дата: Четверг, 04.02.2016, 11:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
вот, файл
К сообщению приложен файл: primer1.xls(21Kb)
 
Ответить
Сообщениевот, файл

Автор - arhboy
Дата добавления - 04.02.2016 в 11:46
arhboy Дата: Четверг, 04.02.2016, 11:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
не обижайтесь, пожалуйста, просто уже сил нет

увы, не всем дано понимать "ну это же логические вещи, о них можно догадаться по логике, по инструкции". я разобраться не смог, очень много времени этому посвятил, поэтому максимально описал, к чему пришел в итоге и прошу скорректировать формулу специалиста, а не советов, что почитать. при всем уважении. буу благодарен не за общие советы, а за конкретный ответ на вопрос по конкретной формуле
 
Ответить
Сообщениене обижайтесь, пожалуйста, просто уже сил нет

увы, не всем дано понимать "ну это же логические вещи, о них можно догадаться по логике, по инструкции". я разобраться не смог, очень много времени этому посвятил, поэтому максимально описал, к чему пришел в итоге и прошу скорректировать формулу специалиста, а не советов, что почитать. при всем уважении. буу благодарен не за общие советы, а за конкретный ответ на вопрос по конкретной формуле

Автор - arhboy
Дата добавления - 04.02.2016 в 11:48
Pelena Дата: Четверг, 04.02.2016, 11:52 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10992
Репутация: 2454 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=ВПР($A3;site!$A$2:$E$26;ПОИСКПОЗ(B$2;site!$A$1:$E$1;0);0)
К сообщению приложен файл: primer1-3-.xls(27Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ВПР($A3;site!$A$2:$E$26;ПОИСКПОЗ(B$2;site!$A$1:$E$1;0);0)

Автор - Pelena
Дата добавления - 04.02.2016 в 11:52
китин Дата: Четверг, 04.02.2016, 12:01 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4096
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
в файле поиграйтесь с выпадающим списком столбца А на листе zaead
Код
=ЕСЛИОШИБКА(ИНДЕКС(site!B$1:B$1000;ПОИСКПОЗ(zaezd!$A3;номер;0));"")
К сообщению приложен файл: challenge.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениев файле поиграйтесь с выпадающим списком столбца А на листе zaead
Код
=ЕСЛИОШИБКА(ИНДЕКС(site!B$1:B$1000;ПОИСКПОЗ(zaezd!$A3;номер;0));"")

Автор - китин
Дата добавления - 04.02.2016 в 12:01
Udik Дата: Четверг, 04.02.2016, 13:39 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1368
Репутация: 174 ±
Замечаний: 0% ±

Excel 2016 х 64
или так
Код

=ЕСЛИОШИБКА(ВПР($A3;site!$A$1:$E$19;СТОЛБЕЦ();0);"-")
К сообщению приложен файл: 0t.xls(29Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеили так
Код

=ЕСЛИОШИБКА(ВПР($A3;site!$A$1:$E$19;СТОЛБЕЦ();0);"-")

Автор - Udik
Дата добавления - 04.02.2016 в 13:39
_Boroda_ Дата: Четверг, 04.02.2016, 14:01 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Поскольку База у Вас с первой строки и столбцы совпадают по порядку расположения, то можно просто
Код
=ЕСЛИ(A3="";"";ИНДЕКС(site!B:B;$A3))

В общем случае -
Код
=ЕСЛИ(A3="";"";ИНДЕКС(site!B:B;$A3+n-1))
, где n - номер первой строки базы со значениями.
К сообщению приложен файл: primer1_1.xls(34Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПоскольку База у Вас с первой строки и столбцы совпадают по порядку расположения, то можно просто
Код
=ЕСЛИ(A3="";"";ИНДЕКС(site!B:B;$A3))

В общем случае -
Код
=ЕСЛИ(A3="";"";ИНДЕКС(site!B:B;$A3+n-1))
, где n - номер первой строки базы со значениями.

Автор - _Boroda_
Дата добавления - 04.02.2016 в 14:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как задать цифровую часть координаты ячейки формулой-ссылкой (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!