Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление стажа исходя из уже расчитанных данных. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление стажа исходя из уже расчитанных данных. (Формулы/Formulas)
Вычисление стажа исходя из уже расчитанных данных.
368800 Дата: Четверг, 11.02.2016, 13:48 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 20% ±

На предприятии есть данные с рассчитанным стажем на 01.01.2016 г. А мне нужно посчитать какой стаж был у человека до даты зачисления на наше предприятие.
К сообщению приложен файл: 5210700.xlsx(11Kb)
 
Ответить
СообщениеНа предприятии есть данные с рассчитанным стажем на 01.01.2016 г. А мне нужно посчитать какой стаж был у человека до даты зачисления на наше предприятие.

Автор - 368800
Дата добавления - 11.02.2016 в 13:48
VIDEO56 Дата: Четверг, 11.02.2016, 14:01 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010


Всем удачного дня!
 
Ответить
Сообщениеhttp://www.excelworld.ru/board/excel/formulas/date_minus_date/3-1-0-8
Посмотрите тут!

Автор - VIDEO56
Дата добавления - 11.02.2016 в 14:01
Manyasha Дата: Четверг, 11.02.2016, 14:39 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
368800, так подойдет?
Код
=ЕСЛИОШИБКА(РАЗНДАТ(ДАТА(ГОД(ПСТР($B$3;4;99))-$B5;МЕСЯЦ(ПСТР($B$3;4;99))-$C5;ДЕНЬ(ПСТР($B$3;4;99))-$D5);$E5;"y");"")
К сообщению приложен файл: 5210700-1.xlsx(13Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщение368800, так подойдет?
Код
=ЕСЛИОШИБКА(РАЗНДАТ(ДАТА(ГОД(ПСТР($B$3;4;99))-$B5;МЕСЯЦ(ПСТР($B$3;4;99))-$C5;ДЕНЬ(ПСТР($B$3;4;99))-$D5);$E5;"y");"")

Автор - Manyasha
Дата добавления - 11.02.2016 в 14:39
_Boroda_ Дата: Четверг, 11.02.2016, 15:31 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4146 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не все так просто. там еще разница в один день у месяцев с 30-ю днями и 2-3 дня у февраля.
Файл с проверкой во вложении
Код
=РАЗНДАТ(ДАТАМЕС(B$3;-B5*12-C5)-D5+(31-ДЕНЬ(КОНМЕСЯЦА(ДАТАМЕС(B$3;-B5*12-C5)-D5;0)))*(D5>0);E5;"y")
К сообщению приложен файл: 5210700_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе все так просто. там еще разница в один день у месяцев с 30-ю днями и 2-3 дня у февраля.
Файл с проверкой во вложении
Код
=РАЗНДАТ(ДАТАМЕС(B$3;-B5*12-C5)-D5+(31-ДЕНЬ(КОНМЕСЯЦА(ДАТАМЕС(B$3;-B5*12-C5)-D5;0)))*(D5>0);E5;"y")

Автор - _Boroda_
Дата добавления - 11.02.2016 в 15:31
368800 Дата: Четверг, 11.02.2016, 21:23 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 20% ±

Огромное спасибо
 
Ответить
СообщениеОгромное спасибо

Автор - 368800
Дата добавления - 11.02.2016 в 21:23
368800 Дата: Четверг, 11.02.2016, 21:52 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 20% ±

И последний вопрос? Мне эти даты просто мозг выносят. Как правильно прибавить прошлый стаж к текущему?
К сообщению приложен файл: __2.xlsx(10Kb)


Сообщение отредактировал 368800 - Четверг, 11.02.2016, 21:53
 
Ответить
СообщениеИ последний вопрос? Мне эти даты просто мозг выносят. Как правильно прибавить прошлый стаж к текущему?

Автор - 368800
Дата добавления - 11.02.2016 в 21:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление стажа исходя из уже расчитанных данных. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!